LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (https://www.linuxquestions.org/questions/linux-networking-3/)
-   -   No Internet in Linux, Works in XP (https://www.linuxquestions.org/questions/linux-networking-3/no-internet-in-linux-works-in-xp-121040/)

whoami 11-29-2003 03:14 PM

No Internet in Linux, Works in XP
 
I have had no luck getting an Internet connection in Linux. I have tried using both Debian 3.0 and now Mandrake 9.2. I didn't mess around with Debian too much because I don't like the distro anyway. Here are some of the details: I use an on-motherboard REALTEK 8139 LAN chip. I have ADSL through (get this) China Railcom. I don't think think they use PPPoE or PPtP. Here are my Windows settings:

IP: xx.13.1.87
Subnet: 255.255.255.0
Gateway: xx.13.0.1

DNS: yyy.98.2.4 and zzz.96.64.68

(I have blanked out some of the numbers for privacy, though not sure if it matters).

I know the IP I gave is my local IP. The external IP is usually something like xx.236.27.43.

Hopefully someone can tell me how I connect by the information I gave. I have no username or password and no hostname leasing me to believe that I don't use PPPoE or other alternatives. I am 99 percent sure its not DHCP either.

I believe I have a ASDL modem and not a router, but I could be wrong. Hmm, just got out the manual which I neglected to look at since its in CHINESE, maybe I can figure something out.

Meantime if anyone has any comments they can throw my way please shoot! One funny thing is that I had this all working with linux a couple months ago but they changed my IP from xx.1.1.87 to xx.13.1.87 and my Gateway from xx.1.1.1 to xx.13.0.1.

Thanks in advance. Oh and by the way it seems that linux recognises the LAN just fine, it is "up" according to the little utility in Mandrake.

carlywarly 11-29-2003 03:21 PM

So, you have an ethernet card that connects to an external modem/ possibly router? Have you just tried going into your network set-up and popping in dhcp? If so, open a console as root, and try ping 158.43.240.4 or any other ip you know. Can you ping that address? Let us know.

whoami 11-29-2003 04:39 PM

DHCP
 
I have tried DHCP to no avail. Can't Ping out after trying to use it. I also thought that if you use DHCP then you won't have an IP address and I do have an IP xx.13.1.87.

What I think should work in Linux is just setting up the LAN card with the same settings as in Windows. But I noticed it doesn't allow me to input 2 DNS's it only allows one, which makes me suspicious that I am missing something.

And to clarify yes I have a ethernet card connected to an external ADSL modem or maybe router. I now think its a router, but I have had no luck trying to access it and since the manual is in Chinese I may be missing something. Will contniue to work on this angle.

digiplaya 11-30-2003 01:36 AM

Make sure that your router is compatible with Linux. If so, then find out whether it is assigning one IP address for DHCP or more than one. If it is assigning only one, make sure that the computer that is hooked to your modem is hooked into the router.

Hope that helps!

Digiplaya

whoami 11-30-2003 02:05 AM

Only have a modem
 
I'm still a bit confused myself but I believe the box on my desk is only a modem. So my connection goes Computer--->LAN Card--->DSL Modem--->Phone Socket in the wall.

I did have this working a month or so ago, but I uninstalled Linux when I upgraded my computer. In the meantime the DSL company changed the Gateway address and the IP as I mentioned before. Now it won't work. Everything else is the same.

:newbie: to LINUX.

digiplaya 11-30-2003 02:09 AM

I see. Perhaps you do not need a router for a DSL connection. I am also newbie, but I think I have a little hint to help solve your problem.

You should call your ISP and find out what the IP address is for your computer. Then, you may be able to manually configure it with that address and it should work.

Hope that helps!

Digiplaya

whoami 11-30-2003 03:18 AM

Just so its clear...
 
As the previous poster noted it would be a good idea to call my ISP provider and ask them a few questions. It would also be a good idea to look at the website of my DSL Modem and see what it has to say as well.

http://www.railcomnet.com/index.htm

This is my ISP.

http://www.dcee.com/chinese/dcp/CT-500/ADSL_WLAN.htm

This is one of the more relevant pages on my modem. I can't show you picture of my modem manual but hopefully you get the picture :)

It's all in Chinese. And I don't :tisk: know how to read Chinese (well enough to decipher this stuff at leat, but I'm decent with a restaurant menu).

bxb32001 11-30-2003 06:52 AM

Hi whoami, I have been in Beijing for about three years now, and my Mandarin has not improved one bit ;)

This was actually my problem about a year and a half ago. After a successfull conversion to Linux (finally), a year later we move and I get ADSL.... I remember the migraines it had caused me.

I don't know if I can be of much help since I am more of your average Desktop user than your Linux geek.

Back then, I had a Win2K / Red Hat Linux setup.... I had to install a third-party app in Win2K but Red Hat Linux already had an app for that.

The way I remember it, installed PPPOE software in my Win2K box, fired it up, inputted my user name and password, and voila..... in Red Hat Linux I fired up the PPPOE thingy, user name... password... that should be it....

I don't remember any special configuration for my LAN Card... just installed the driver in Win2K and that was it... the PPPOE software handled the dialing up.... oh, I should tell you... It should be like you are dialing up... ala modem... it's not, but it kinda works that way. Same thing with RH I think.

As you can see... there was no extra tweaking... everything as simple as that.

You have every right to disregard everything I have just said... I am no expert and though I recall the difficulties I encountered, I cannont recall how I overcame them. I can only think of this... it may help if you can dual boot... trace and retrace your steps on the Windows alter-ego to your Linux one...

You can also opt to purchase a router... maybe the easiest route... and work the router like a LAN...

whoami 11-30-2003 10:06 AM

RFC1483 Bridged or Routed
 
I don't use PPPoE. I have an always on connection via RFC1483 protocol which basically means it works more like a LAN than a modem. So my modem I think is really a modem and a router, but it only has one Ethernet connection. I think its actaully ideal from a technical standpoint and it should be super easy to setup too. That is why I am so frickin' confused. I use the 8139too driver for my LAN card. Anyone had a problem with this?

I tried an updated driver that I found here: compile my own driver huh?

But, I couldn't get them to compile using the make command. I just put them into there own directory and typed 'make' but it gave me a series of errors something about not having the kernal files installed. Anyone have any experience compiling drivers? It is one step beyond my know-how.

I also can't seem to access the router functions of my DSL Modem/Router., even through Windows. Supposedly I am to type 192.168.1.1/24 in to my browser and I should get the setup. But no luck, very strange indeed.

dubman 11-30-2003 08:14 PM

check you /etc/sysconfig/network-scripts/

there should be an ifcfg-eth0 file where all of you interface settings are located. Make sure you have it set for DHCP (unless your isp requires you to go static). Most DSL modems are intrinsic NAT (Network Address Translation) devices. This means that the modem requests a DHCP lease from your ISP, then in turn you request a DHCP lease from the modem. So in essence, the DSL modem is your DHCP server. So, an all you would need in your ifcfg-eth0 file is:

DEVICE=eth0
BOOTPROTO=dhcp
ONBOOT=yes

this should allow you to obtain a valid DHCP address.

also, check ifconfig (or ifconfig -a). if you do not have any eth interfaces, perhaps your NIC is bad, corrupt, or the driver isn't compiled/installed correctly.

-hope this helps

JordanH 11-30-2003 08:16 PM

I know you have said you don't use PPPoE... but it is rare to have an ADSL connection that doesn't use it.

How are you connecting to the Internet now?

whoami 12-01-2003 04:56 AM

Quote:

I know you have said you don't use PPPoE... but it is rare to have an ADSL connection that doesn't use it.
Well I use China Railcom as my ISP and they don't use PPPoE. They use an RFC 1243 Bridged (or maybe Routed) connection. This means I don't use DHCP either. I connect static as an earlier poster suggested.

My Internet connection works in Windows! That is how I am typing this now.

One interesting thing is that my local IP is 10.13.1.87 while my external is 61.236.27.41-46. That is, my address changes between those addresses from minute to minute! This might have to do with the Great Firewall of China. Not sure.

Can I infer anything about my connection from having a different internal address than external address?

Especially since the internal one is a private address? :Pengy: :Pengy: :Pengy:

Quote:

also, check ifconfig (or ifconfig -a). if you do not have any eth interfaces, perhaps your NIC is bad, corrupt, or the driver isn't compiled/installed correctly.
I am starting to lean toward thinking my NIC is incompatible with Linux with the current driver. But I have tried another NIC but only with Debian, not MDK. I'll go down this line of troubleshooting... Thanks.

davholla 12-01-2003 06:35 AM

what does cat /etc/modules.conf say ?

bxb32001 12-01-2003 08:04 PM

Hmmm... my ISP first provided me with a USB ADSL Modem and after a few frustrating months I called them back and told them I wanted an ADSL Modem that I will use with my LAN Card. They even provided me with a number of different PPPoE software so I can use whichever I wish.

It helps if there is someone to translate for you...

Point is, you can tell them you want to connect a different way (the way that you think will work for you). Though they have a method they have prescribed for you, any IT guy worth his salt can offer you a different way.

That was the way it was for me... I just said, "hey, I need to connect this way," thankfully, they obliged.


All times are GMT -5. The time now is 05:24 PM.