LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 05-16-2007, 02:22 PM   #1
bullium
Member
 
Registered: Aug 2003
Location: Ohio
Distribution: Ubuntu 12.04, Mint 13, RHES 5.5, RHES 6
Posts: 146

Rep: Reputation: 17
Question No Internet Connectivity on CentOS 4.4 Final


I'm Running CentOS release 4.4 (Final) on an HP DL360 Server with two NIC cards. I currently cannot communicate with anything outside the local network. I can ping and connect to all devices on the internal network including other devices on other internal networks. This means the router is routing traffic for this host. All other hosts on the network can communicate with the internet. This box and all others on the network are configured to use a local DNS server. This box is resolving domain names to IP address. I can ping the router and the firewall connected to the internet and vice versa, therefore all local communication is good. I found this thread http://www.linuxquestions.org/questi...ss#post2550959 where someone was running into the same problem on this release. Their solution was a reinstall, which is not an option for me. Therefore Iím starting a new thread in hopes of some help finding a solution to this problem. The system has two NICs. eth0 is being used and eth1 is disabled and not used.

This is the topology of how this box is connected to the network/internet.

-------------------------------------------------------------------------------------------------------------
centosbox -> 2950switch -> 4000router -> PIXfirewall -> Internet
-------------------------------------------------------------------------------------------------------------

Output from some config files as well as commands.

Code:
cat /etc/sysconfig/network
NETWORKING=yes
HOSTNAME=centosbox.localhost
GATEWAY=192.168.20.252
-------------------------------------------------------------------------------------------------------------

Code:
cat /etc/sysconfig/network-scripts/ifcfg-eth0
DEVICE=eth0
ONBOOT=yes
BOOTPROTO=static
IPADDR=192.168.20.218
NETMASK=255.255.255.0
-------------------------------------------------------------------------------------------------------------
Code:
cat /etc/resolv.conf
nameserver 192.168.20.226
-------------------------------------------------------------------------------------------------------------
Code:
ifconfig eth0
eth0 Link encap:Ethernet HWaddr 00:19:BB:38:F0:BA
inet addr:192.168.20.218 Bcast:192.168.20.255 Mask:255.255.255.0
inet6 addr: fe80::219:bbff:fe38:f0ba/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:984537 errors:0 dropped:0 overruns:0 frame:0
TX packets:203954 errors:365 dropped:0 overruns:0 carrier:365
collisions:422 txqueuelen:1000
RX bytes:114990204 (109.6 MiB) TX bytes:65373057 (62.3 MiB)
Interrupt:10 Memory:f8000000-f8011100

-------------------------------------------------------------------------------------------------------------

Code:
route
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.20.0 * 255.255.255.0 U 0 0 0 eth0
169.254.0.0 * 255.255.0.0 U 0 0 0 eth0
default 192.168.20.252 0.0.0.0 UG 0 0 0 eth0
-------------------------------------------------------------------------------------------------------------

Any help would be appreciated, thanks.
 
Old 05-16-2007, 03:30 PM   #2
Brian1
LQ Guru
 
Registered: Jan 2003
Location: Seymour, Indiana
Distribution: Distribution: RHEL 5 with Pieces of this and that. Kernel 2.6.23.1, KDE 3.5.8 and KDE 4.0 beta, Plu
Posts: 5,700

Rep: Reputation: 64
My setup is to place the Gateway line in the ifcfg-eth0 file. The other two lines left look fine there. Also I use the line bootproto=none. You also say eth1 is down. I would make sure to have onboot=no in the ifcfg-eth1 file. Only other thought is if not using IPv6 is to make sure it is disabled. This can be done by adding this line to /etc/modprobe.conf.
alias ipv6 off
Last thought is if using a web browser to look at internet site use The IP instead of the domain name of the web site to see if that works.

Brian
 
Old 05-17-2007, 07:43 AM   #3
bullium
Member
 
Registered: Aug 2003
Location: Ohio
Distribution: Ubuntu 12.04, Mint 13, RHES 5.5, RHES 6
Posts: 146

Original Poster
Rep: Reputation: 17
Quote:
Originally Posted by Brian1
My setup is to place the Gateway line in the ifcfg-eth0 file. The other two lines left look fine there. Also I use the line bootproto=none. You also say eth1 is down. I would make sure to have onboot=no in the ifcfg-eth1 file. Only other thought is if not using IPv6 is to make sure it is disabled. This can be done by adding this line to /etc/modprobe.conf.
alias ipv6 off
Last thought is if using a web browser to look at internet site use The IP instead of the domain name of the web site to see if that works.
I've disabled ipv6 as you suggested. I already had the onboot=no set in the eth1 cfg file. I do not have access to a web browser as X is not installed, and since I cannot access the Internet I cannot yum lynx or links (I know there are other ways of getting the packages on the box, but I can test access to the internet in more efficient ways). Also I know DNS names are resolving as I have an Intranet DNS server and the names are resolving to the correct IP's; I've checked this with other machines and they resolve the same IP's. I still have not access to the Internet, any other suggestions are greatly appreciated.
 
Old 05-17-2007, 11:26 AM   #4
bullium
Member
 
Registered: Aug 2003
Location: Ohio
Distribution: Ubuntu 12.04, Mint 13, RHES 5.5, RHES 6
Posts: 146

Original Poster
Rep: Reputation: 17
Thumbs up Fixed

Thanks to all who tried to help. Turns out when I had a Cisco tech config a limited VPN connection to that host he put a static route that looped all outbound (internet) traffic from that host back to itself? Must have thought I didn't want that host getting to the internet. He did a good job of that I just wasn't what I wanted . Thanks again for the input. Problem is now fixed, and wasn't the OS's fault .
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Sharing internet connectivity cidkato Linux - Wireless Networking 7 01-01-2005 06:38 PM
No Internet Connectivity laltupi Linux - Networking 1 07-19-2004 10:34 AM
Internet Connectivity is a NO-GO Help Please!! ClericPreston Linux - Newbie 1 06-04-2004 07:36 PM
Internet/Network connectivity unixops72 Linux - Networking 4 01-09-2004 08:35 PM
Internet connectivity at startup link1305 Linux - Networking 18 12-11-2003 05:31 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 01:44 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration