-   Linux - Networking (
-   -   No "connections" tab in network-settings in UbuntuStudio 10.4 (

getack 08-02-2010 03:02 PM

No "connections" tab in network-settings in UbuntuStudio 10.4
Just installed UbuntuStudio 10.4 X64 next to my main Ubuntu 10.4 X86. For some reason the network-settings app is not working right.

I use a Netgear WG311v3 wifi card to connect to my home network and I'm a pro with using ndiswrapper to emulate the drivers for both 64 and 32 bit machines. Everything driver-wise works and iwconfig shows my card as installed and working.

When I want to connect to the network I go to System > Admin > Networking to set everything up. But the problem is, there is no "Connections" tab. Only "General", "DNS" and "Hosts". So I cannot select my wifi card to set up the ip's and everything. I haven't tried using a normal UTP cable, as it's quite a hassle to extend it to my room, but I'm sure I will get the same results.

How come everything works hunky-dory in Ubuntu, but not in Studio? It's exactly the same!

If I am being a total noob please help me. Should I reinstall the Network settings app or what?


tekhead2 08-03-2010 11:28 AM

I've never used Ubuntu Studio before. There are some big differences in the kernels used. From my understanding Studio is using a real-time kernel. Do you have network manager installed and running? Typically on Ubuntu you would have a small network icon in your task area on the gnome bar. You may not have the wireless card installed correctly, or not at all. Open up a terminal and issue the iwconfig command to see if you have any wireless adapters installed. You may have to go to your restricted hardware drivers to see if you need to install some non-free drivers. Also if your still unsure you can do a lspci command in the terminal as well to see what hardware you have on your pci bus and there should be a listed wireless network adapter with the discovered hardware name.. that will give us more direction on what driver you need to have.

getack 08-03-2010 01:36 PM

Yep I did all that. The card is listed, and running. I found that the network manager was never installed, or only partially installed. So I reinstalled GNOME's Network-Manager and resolved all the dependencies. I can now configure a network, but the systray applet is still missing and therefore I cannot scan for a network. I am now looking for info about the systray app.

tredegar 08-03-2010 01:54 PM


but the systray applet is still missing and therefore I cannot scan for a network.
You can R-click a blank bit of the panel.
Add to panel...
Add what you'd like (systray or whatever).

But network-mangler isn't currently as functional, or intuitive or smart as wicd. Please try installing wicd for wireless happiness.

That said, NM manages "mobile/cell phone" dongles better than wicd currently does. So if you need to use one of these, reconsider.

Make your choice, or keep switching between them, depending on what connection you want to establish and how. Eventually, I expect this'll all be sorted out.

getack 08-03-2010 04:17 PM

It worked!!

Thanks tredegar, your suggestion about wicd worked the first time. I presume the 64bit niswrapper and NM does not see eye to eye. When one is working, the other one is not. I had a similar problem with Kubuntu Karmic last year. Well everything is working now, and I am posting this message using UbuntuStudio. I will post a good howto here and on the other threads when I have the chance. Many people are having trouble with ndiswrapper and NM in general.

Luckily I do not need a 3G modem or something with my machine, so I removed NM completely. I am going to do the same to my main Ubuntu installation.

All times are GMT -5. The time now is 11:15 PM.