-   Linux - Networking (
-   -   no active interface (yet?) network... (

breezewax 09-12-2004 08:23 PM

no active interface (yet?) network...
Hey all...

For seemingly no reason, my machine (running SuSE 9.1) fails to automatically make it's internet connection. During boot, it pauses on the errors:

no active interface (yet?)

...then just fails and eventually informs me that the network service has failed. I have changed nothing (did install giFT however) from yesterday and it worked fine. Would appreciate any help...


dthacker 09-12-2004 08:45 PM

My tips are:
1) Since I'm old and forgetful, I always verify my physical connections. You never know what a cat or small child may have unplugged.
2) I have a firewall/router. Do you? Sometimes my kids trip the circuit breaker and shut it off, so I check that.
3) Then I send more helpful information to LinuxQuestions.
  • Kind of internet connection (DSL/Cable/Partial T1)?
  • DHCP or static address?
  • What interface connects? eth0? eth1?
That will give LQ people more info to troubleshoot with.
Good Luck

breezewax 09-12-2004 10:26 PM

thanks for the quick reply...

I have a cable connection, and using DHCP.
so eth0 seems to connect, but 1-4 do not. They all have "Failed" in red next to them during boot.

breezewax 09-13-2004 02:49 PM

:bump: ::i'm really screwed here::

mermxx 09-13-2004 03:27 PM

what is the output of ifconfig -a
this should give u the information as to all interfaces whether up or down, or configure them

breezewax 09-13-2004 07:52 PM

here is the ouput from ifconfig...

eth0 Link encap:Ethernet HWaddr 00:50:DA:18:A3:58
inet addr: Bcast: Mask:
inet6 addr: fe80::250:daff:fe18:a358/64 Scope:Link
RX packets:14 errors:0 dropped:0 overruns:0 frame:0
TX packets:10 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:1456 (1.4 Kb) TX bytes:1730 (1.6 Kb)
Interrupt:5 Base address:0xec00

lo Link encap:Local Loopback
inet addr: Mask:
inet6 addr: ::1/128 Scope:Host
RX packets:42 errors:0 dropped:0 overruns:0 frame:0
TX packets:42 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:2708 (2.6 Kb) TX bytes:2708 (2.6 Kb)

sit0 Link encap:IPv6-in-IPv4
NOARP MTU:1480 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)'s greek to me...can't see any obvious problems...again, thanx for any help...

breezewax 09-13-2004 08:00 PM

sorry, forgot two more errors that might help...

i get an error during the network part of booting that says "can't load resolv.config" and also "error inserting 3c505"...thanks...

netopia 09-13-2004 09:04 PM

Did you say you have 5 ethernet cards? If you are just worried about connecting to the internet, can you try it with only one? If they all use the same driver there is some weird config thing you need to do, but I can't remember what. :scratch: FYI, DHCP is not being activated on eth0. Are you sure eth0 is the card you think it is, of the 5?

breezewax 09-13-2004 10:09 PM

ha, don't have 5 cards...that's just what's printed during boot...i don't know why it's trying 0-5, and i don't know what would have made it decide to one day. Worked fine before...strange. How would i fix the DHCP problem (if that's it)?

breezewax 09-14-2004 02:31 PM


mermxx 09-14-2004 02:40 PM

it looks like u have ur eth card recognised,
have a look in /etc/resolv.conf and see what u have there also check ur
/etc/sysconfig/network-scripts/ifcfg-eth0 to see if u have dhcp set to yes. It seems to me that u have a prob with grabbing ur ip addy from ur server. U can always statically assign. but see what the first suggestions turn up.
Also just out of interest check bios to see if u have ur NIC\ pnp enabled I don`t think this is a big problem just a bit of `trouble shooting` :-)

mermxx 09-14-2004 02:59 PM

ps what is the output of lspci is it a 3com network card u have?

breezewax 09-14-2004 05:04 PM

yep it's a 3com 10/100mbps...thanks for the help...i'll try those suggestions when i get home...

muchos gracias...

breezewax 09-14-2004 07:46 PM

okay, so i checked my BIOS for the /pnp stuff and saw an option for "Plug and Play capable OS?" was set to no so i selected yes and when it booted, low and behold...the internet worked. no freakin' idea if they're even related...the connection crapped out without rhyme or reason, so i wouldn't be that surprised if it just suddenly fixed itself too. strange...thanks for all the help anyways...this site is supporting a good 60% of my linux migration training load....thanks again...

amarillo 09-15-2004 05:14 AM


All times are GMT -5. The time now is 11:27 AM.