LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 10-07-2015, 03:18 AM   #1
DerMinze
LQ Newbie
 
Registered: Oct 2015
Posts: 5

Rep: Reputation: Disabled
nmcli device eth1 "unavailable"


Hi,

I have a motherboard with two Ethernet ports, and I would like to get a connection on both ports.
Eth0 already has a connection and can be used without problems. Eth1 however shows up as "unavailable" in nmcli. How can I make this Ethernet port usable as well?

Some related information:

Code:
ethtool eth1

Supported ports: [ TP MII ]
        Supported link modes:   10baseT/Half 10baseT/Full 
                                100baseT/Half 100baseT/Full 
        Supported pause frame use: No
        Supports auto-negotiation: Yes
        Advertised link modes:  100baseT/Half 100baseT/Full 
        Advertised pause frame use: Symmetric Receive-only
        Advertised auto-negotiation: Yes
        Link partner advertised link modes:  10baseT/Half 10baseT/Full 
                                             100baseT/Half 100baseT/Full 
        Link partner advertised pause frame us Symmetric
        Link partner advertised auto-negotiation: Yes
        Speed: 100Mb/s
        Duplex: Full
        Port: MII
        PHYAD: 1
        Transceiver: internal
        Auto-negotiation: on
        Supports Wake-on: pumbag
        Wake-on: d
        Current message level: 0x00000007 (7)
                               drv probe link
        Link detected: yes

Code:
ifconfig eth1

eth1      Link encap:Ethernet  HWaddr F6:7B:7B:7B:E9:C2  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

Code:
ip addr

eth1: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast qlen 1000
    link/ether f6:7b:7b:7b:e9:c2 brd ff:ff:ff:ff:ff:ff
 
Old 10-08-2015, 01:12 AM   #2
berndbausch
LQ Addict
 
Registered: Nov 2013
Location: Tokyo
Distribution: Mostly Ubuntu and Centos
Posts: 6,316

Rep: Reputation: 2002Reputation: 2002Reputation: 2002Reputation: 2002Reputation: 2002Reputation: 2002Reputation: 2002Reputation: 2002Reputation: 2002Reputation: 2002Reputation: 2002
Quote:
Originally Posted by DerMinze View Post
Hi,

I have a motherboard with two Ethernet ports, and I would like to get a connection on both ports.
Eth0 already has a connection and can be used without problems. Eth1 however shows up as "unavailable" in nmcli. How can I make this Ethernet port usable as well?
What's the precise nmcli output?
How is the interface configured (in Red Hat and derivatives, /etc/sysconfig/network-scripts, in Ubuntu, from memory, /etc/network/interfaces)?

Perhaps this part of the nmcli man page helps:

Code:
       nmcli dev disconnect iface em2

              disconnects a connection on interface em2 and marks the device
              as unavailable for auto‐connecting. That's why no connection
              will automatically be activated on the device until the device's
              "autoconnect" is set to TRUE or user manually activates a
              connection.
In other words, you need to do something to connect the interface manually or automatically.
 
Old 10-08-2015, 03:19 AM   #3
ericson007
Member
 
Registered: Sep 2004
Location: Japan
Distribution: CentOS 7.1
Posts: 735

Rep: Reputation: 154Reputation: 154
It states in the logs you showed the card has no carrier. Can you confirm the cables are properly plugged in.


Remember that there is a default option to not allow multiple devices to work simultaneously to prevent ip spoofing on different interfaces.

https://access.redhat.com/solutions/53031
 
Old 10-08-2015, 04:03 AM   #4
DerMinze
LQ Newbie
 
Registered: Oct 2015
Posts: 5

Original Poster
Rep: Reputation: Disabled
My settings are set to autoconnect, so I don't think that is the problem here.


Code:
nmcli dev

DEVICE  TYPE      STATE        CONNECTION 
eth0    ethernet  connected    eth0       
eth1    ethernet  unavailable  --         
lo      loopback  unmanaged    --         
sit0    sit       unmanaged    --
Code:
nmcli con

NAME  UUID                                  TYPE            DEVICE 
eth0  xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx  802-3-ethernet  eth0   
eth1  xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx  802-3-ethernet  --
Code:
nmcli -p con show eth1

===============================================================================
                       Connection profile details (eth1)
===============================================================================
connection.id:                          eth1
connection.uuid:                        xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx
connection.interface-name:              eth1
connection.type:                        802-3-ethernet
connection.autoconnect:                 yes
connection.autoconnect-priority:        0
connection.timestamp:                   0
connection.read-only:                   no
connection.permissions:                 
connection.zone:                        --
connection.master:                -
connection.slave-type:                  --
connection.secondaries:                 
connection.gateway-ping-timeout:        0
-------------------------------------------------------------------------------
802-3-ethernet.port:                    --
802-3-ethernet.speed:                   0
802-3-ethernet.duplex:                  --
802-3-ethernet.auto-negotiate:          yes
802-3-ethernet.mac-address:             --
802-3-ethernet.cloned-mac-address:      --
802-3-ethernet.mac-address-blacklist:   
802-3-ethernet.mtu:                     auto
802-3-ethernet.s390-subchannels:        
802-3-ethernet.s390-nettype:            --
802-3-ethernet.s390-options:            
-------------------------------------------------------------------------------
ipv4.method:                            auto
ipv4.dns:                               
ipv4.dns-search:                        
ipv4.addresses:                         
ipv4.gateway:                           --
ipv4.routes:                            
ipv4.route-metric:                      -1
ipv4.ignore-auto-routes:                no
ipv4.ignore-auto-dns:                   no
ipv4.dhcp-client-id:                    --
ipv4.dhcp-send-hostname:                yes
ipv4.dhcp-hostname:                     --
ipv4.never-default:                     no
ipv4.may-fail:                          yes
-------------------------------------------------------------------------------
ipv6.method:                            auto
ipv6.dns:                               
ipv6.dns-search:                        
ipv6.addresses:                         
ipv6.gateway:                           --
ipv6.routes:                            
ipv6.route-metric:                      -1
ipv6.ignore-auto-routes:                no
ipv6.ignore-auto-dns:                   no
ipv6.never-default:                     no
ipv6.may-fail:                          yes
ipv6.ip6-privacy:                       -1 (unknown)
ipv6.dhcp-send-hostname:                yes
ipv6.dhcp-hostname:                     --
-------------------------------------------------------------------------------

I can confirm that the cable is attached, and I have tried with other cables I know works fine.
I have tried connecting only eth1 as well, and there is no reaction to it. I still can't get no connection.
 
Old 10-08-2015, 06:47 AM   #5
ericson007
Member
 
Registered: Sep 2004
Location: Japan
Distribution: CentOS 7.1
Posts: 735

Rep: Reputation: 154Reputation: 154
You must also check your rp_filter settings. If rp_filter validates packets, you will struggle till blue in the face to try and get dual nics properly working.

Here is a quick explanation of reverse path filter.

http://www.slashroot.in/linux-kernel...path-filtering

If you want strict symmetric routing and prefer to leave rp filter on

http://jensd.be/468/linux/two-network-cards-rp_filter

By the way, what distro are you on?

Last edited by ericson007; 10-08-2015 at 07:05 AM.
 
Old 10-08-2015, 07:07 AM   #6
DerMinze
LQ Newbie
 
Registered: Oct 2015
Posts: 5

Original Poster
Rep: Reputation: Disabled
The reverse path filter is set to 0, and from your link indicates there is no source validation.

I am on an embedded Linux system, kernel number is 4.1.0-00200-g8d1bfcd armv7l.
 
Old 10-08-2015, 08:25 AM   #7
ericson007
Member
 
Registered: Sep 2004
Location: Japan
Distribution: CentOS 7.1
Posts: 735

Rep: Reputation: 154Reputation: 154
You are correct. 0 effectively disables it.
 
Old 10-08-2015, 06:55 PM   #8
ericson007
Member
 
Registered: Sep 2004
Location: Japan
Distribution: CentOS 7.1
Posts: 735

Rep: Reputation: 154Reputation: 154
May I ask what the purpose is, ie, failover, routing, etc.

If it is for failover and both connect to the same subnet, i would look into setting up a bond. That could either be used for failover or in tandem.

Please also show us the ifconfig files as well as the routing tables.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
"nmcli con" failed "Can't obtain connections: settings service is not running." parcox Slackware 2 08-14-2012 05:26 PM
eth1 won't start "device eth1 does not seem to be present, delaying initialization." ozindfw Linux - Networking 1 12-12-2008 05:58 PM
xine "Audio output unavailable. Device is busy." - Firefox problem wild_oscar Linux - Software 1 01-12-2008 10:40 AM
xine "Audio output unavailable. Device is busy." shellshock Linux - Software 3 05-13-2006 01:19 PM
SCSI Device unavailable after firmware download. Redhat or "sg" issue? jrvance Linux - Hardware 2 10-21-2003 02:41 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 06:21 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration