LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 07-06-2004, 09:30 AM   #1
jwizardc
LQ Newbie
 
Registered: Jul 2004
Posts: 12

Rep: Reputation: 0
nmblookup can't find itself


Okay, y'all tell me DNS isn't the solution, so what is?

smbclient -NL silver returns the usual stuff. Most importantly, it shows Silver as the master for the workgroup ozco. But nmbsearch -M ozco returns 'cannot find ozco'.

smbclient '//silver/tmp' works fine. Pinging the other machines on the net (by name if it is in the lmhosts or hosts file) works. But my windoze boxes sometimes shows silver as a machine, but won't open it. Other times it doesn't show it at all.

btw -- somewhere along the way, I managed to kill whatever it is that allows me to run the Users and Groups utility in RH8. Might this be related?
 
Old 07-06-2004, 11:03 AM   #2
LanRx
Member
 
Registered: Jul 2004
Posts: 85

Rep: Reputation: 15
Forgive me for coming in blind, and not having seen all of the configurations, etc.

Your nmbd IS running, right? It would seem to me, that nmbsearch is going to have to be configured to contact your nmbd, which if not running or the client is not configured to locate, will fail.
 
Old 07-07-2004, 09:23 AM   #3
jwizardc
LQ Newbie
 
Registered: Jul 2004
Posts: 12

Original Poster
Rep: Reputation: 0
yah. it comes up with:
'querying ozco on 192.168.0.255
name_query failed to find ozco#1d'

smbclient works dandy on the Linux box. Here's a new bit. My old Win98 (not SE) box can ping Silver, but still can't see it in network neighborhood. My WinXP box does the same. My Win98SE box can see Silver in explorer, but trying to ping gives me 'cannot find Silver.' When I do DIAGNOSE.txt, I only get to step 2 and it claims the DNS software is incorrectly installed (Can't ping server from Windoze boxes). I can smbclient -L silver. It gets me:
Domain=[OZCO] OS=[Unix] Server=[Samba 2.2.5]
Sharename Type comment
homes disk
tmp disk temporary files
IPC$ IPC IPC Service ("Hi, Yo!')
ADMIN$ Disk IPC Service ("Hi, Yo!")

Server comment
SILVER Hi, Yo!

workgroup Master
OZCO SILVER
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
nmblookup problem. bruse Linux - Networking 1 09-07-2005 02:07 PM
nmblookup problem. bruse Linux - Networking 0 09-07-2005 05:32 AM
nmblookup azeem81 Linux - Software 0 05-31-2004 02:33 PM
nmblookup ? Menestrel Linux - Networking 5 05-22-2004 03:55 AM
Samba - nmblookup will_k Linux - Networking 3 08-25-2003 01:48 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 04:59 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration