LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 09-06-2015, 08:49 PM   #1
LT72884
Member
 
Registered: Jul 2012
Posts: 151
Blog Entries: 1

Rep: Reputation: Disabled
nmap failed


here is the following output from terminal:

root@bt:~# nmap 192.168.4.129

Starting Nmap 6.25 ( http://nmap.org ) at 2015-09-06 21:48 EDT
Nmap scan report for 192.168.4.129
Host is up (0.000028s latency).
Not shown: 999 closed ports
PORT STATE SERVICE
80/tcp open http

Nmap done: 1 IP address (1 host up) scanned in 0.29 seconds
root@bt:~# nmap -sV 192.168.4.129

Starting Nmap 6.25 ( http://nmap.org ) at 2015-09-06 21:48 EDT
NSE: failed to initialize the script engine:
/usr/local/bin/../share/nmap/nse_main.lua:530: /usr/local/bin/../share/nmap/scripts/iax2-version.nse is missing required field: 'action'
stack traceback:
[C]: in function 'error'
/usr/local/bin/../share/nmap/nse_main.lua:530: in function 'new'
/usr/local/bin/../share/nmap/nse_main.lua:728: in function 'Entry'
/usr/local/bin/../share/nmap/scripts/script.db:210: in function 'db_closure'
/usr/local/bin/../share/nmap/nse_main.lua:741: in function 'get_chosen_scripts'
/usr/local/bin/../share/nmap/nse_main.lua:1239: in main chunk
[C]: in ?

QUITTING!
root@bt:~#
------------------

notice how it works the first time, but the second time it does not work. i have no idea why.. thanks
 
Old 09-08-2015, 06:02 PM   #2
unSpawn
Moderator
 
Registered: May 2001
Posts: 29,415
Blog Entries: 55

Rep: Reputation: 3600Reputation: 3600Reputation: 3600Reputation: 3600Reputation: 3600Reputation: 3600Reputation: 3600Reputation: 3600Reputation: 3600Reputation: 3600Reputation: 3600
Quote:
Originally Posted by LT72884 View Post
notice how it works the first time, but the second time it does not work. i have no idea why.. thanks
No, the first run you're using nmap defaults the second run you're doing a service version scan. Different things.

Quote:
Originally Posted by LT72884 View Post
Code:
NSE: failed to initialize the script engine:
/usr/local/bin/../share/nmap/nse_main.lua:530: /usr/local/bin/../share/nmap/scripts/iax2-version.nse is missing required field: 'action'
Note https://svn.nmap.org/nmap/scripts/iax2-version.nse does show an "action" field so maybe compare then trace back where you got stuff from?..
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] otcl-1.14 make failed [recipe for target `libotcl.a' failed] for ns-allinone-2.35-RC8 pratikjoshi Linux - Newbie 4 08-23-2013 06:44 AM
nmap ? how do i do nmap in linux ? command not found abbasakhtar Linux - Newbie 2 01-02-2011 01:08 AM
LXer: Learn how to use nmap, and nmap GUI, a great port scan tool LXer Syndicated Linux News 0 01-03-2008 09:10 AM
nmap increase send delay for nmap 4.20 matters Slackware 1 10-01-2007 11:37 PM
online_update failed - ERROR(Media:connection failed)[Connect failed] rover SUSE / openSUSE 8 02-22-2005 07:57 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 01:30 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration