-   Linux - Networking (
-   -   NIC is up but no ip (

khaos83 05-26-2008 04:39 AM

NIC is up but no ip
I have a D-Link DFE-530TX PCI Fast Ethernet.

I have installed it in Dell Dimension 3100 with RedHat 7.1.
Yes, i know both are old and extinct. But I can get them to work.

The problem is, I have a Dell Dimension 3000. I remove the NIC and put it into Dimension 3000. I install RedHat 7.1 the same way in Dimension 3000. Install the NIC driver the same way. But NIC refuse to go up. There are no error messages. Everything is quiet. Even if it's up, when I do a ifconfig:


eth0      Link encap:Ethernet  HWaddr 00:05:5D:7D:01:69 
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0

lo        Link encap:Local Loopback 
          inet addr:  Mask:
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:6 errors:0 dropped:0 overruns:0 frame:0
          TX packets:6 errors:0 dropped:0 overruns:0 carrier:0

I did netconfig and choose dhcp.
I tried to do a dhcpcd eth0 although I have no idea whats that for. It just hang there for some time and ends quietly. I did disable the onboard NIC. To confirm that, I moved the hdd from 3100 to 3000 and the NIC works and about to join the network.

I have totally no idea whats wrong here.

Nathanael 05-26-2008 05:34 AM

have you tried using a different ethernet cable (if you are not using the same one), have you tried giving the computer a static ip?
perhaps you could mention the different things you have tried so far (appart from using the nic in another computer)

khaos83 05-26-2008 09:55 PM


I apologise for the madness. :P

I just remove all out PCI cards and only insert the NIC into other slot. Reinstall OS and everything. It works now.
I am going to investigate abit what happen. Will update here when I have a conclusion.
If anyone have anything to suggest, please shoot.

Thanks for the help.

All times are GMT -5. The time now is 08:25 PM.