Latest LQ Deal: Latest LQ Deals
Go Back > Forums > Linux Forums > Linux - Networking
User Name
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.


  Search this Thread
Old 10-01-2005, 09:13 PM   #1
LQ Newbie
Registered: Oct 2005
Posts: 1

Rep: Reputation: 0
NFS server: RPC: Program not registered

I was trying to get a MacOS/X to nfs mount my Fedora4. I kept recieving...
"NFS Portmap: RPC: Program not registered"

So i went to hosts.allow on the FC4 and entered my address

portmap : : allow
portmap : ALL : deny

This changed nothing. I recived the same error upon attempt to connect. So out of curiosity I wanted to see what was being exported on the FC4 and ran...
showmount -e

This time the server gave the error. It said...
"mount clntudp_create: RPC: Program not Registered"

Thid I do not understand. Can anyone shed some light. By the way the /etc/export file on the server allows the clients ip read and write access.

Click here to see the post LQ members have rated as the most helpful post in this thread.
Old 10-02-2005, 06:34 PM   #2
Registered: Jul 2005
Location: Mafra, PT
Distribution: Fedora Core
Posts: 90

Rep: Reputation: 15
I have found a post that reported that the nfs deamon stays hooked to your systems if it is not shutdown correctly. The post referred to Fedora 2, I haven't test it on FC4 but this days when I have strange errors with nfs when everything should be write I just reboot my machine just to make sure there is nothing stuck in memory.

PS:I edited this message after I post because I tried to run the command you specified "showmount -e" and the first time I ran it gave the same error it gave you. I then did "service nfs start" and ran "showmount" and it returned what it was supposed to return. So I think you really should reboot your machine and make sure all daemons needed to run nfs correctly are loaded.

Hope this helps.

Last edited by jdogpc; 10-02-2005 at 06:41 PM.
Old 11-08-2006, 01:34 AM   #3
LQ Newbie
Registered: Nov 2006
Location: Bucharest - Romania
Posts: 2

Rep: Reputation: 10
You should not reboot your machine.

Just restart the services.
3 members found this post helpful.
Old 06-26-2008, 08:28 AM   #4
LQ Newbie
Registered: Feb 2007
Posts: 1

Rep: Reputation: 0
Thanks. it helped me.

Originally Posted by evolocaru View Post
Just restart the services.
Thanks. it helped me.
Old 09-12-2008, 04:22 AM   #5
LQ Newbie
Registered: Jun 2007
Location: Riyadh,KSA
Distribution: Redhat,Ubuntu,Solaris
Posts: 24

Rep: Reputation: 15
Itz just because of services.

Bcoz after restarting services it works

Last edited by smartyshan; 09-12-2008 at 04:29 AM.
Old 07-16-2010, 04:29 AM   #6
LQ Newbie
Registered: Jul 2010
Posts: 8

Rep: Reputation: 0
thanks it helped me too.....
Old 02-05-2011, 04:34 AM   #7
LQ Newbie
Registered: Feb 2011
Posts: 1

Rep: Reputation: 0
Thanks for your solution, I juste restart the daemon
Old 02-05-2011, 07:47 AM   #8
Senior Member
Registered: Oct 2004
Location: Houston, TX (usa)
Distribution: MEPIS, Debian, Knoppix,
Posts: 4,727
Blog Entries: 15

Rep: Reputation: 234Reputation: 234Reputation: 234

Welcome to LQ. You're off to an incredible start -- 4 thank you notes for your 1st post.


Now please consider giving evolocaru reputation (the scales icon), followed by answering "Yes" to "Did you find this post helpful?". If you do both, it's important to do it in that order.
Old 04-15-2011, 02:59 PM   #9
LQ Newbie
Registered: Feb 2009
Posts: 3

Rep: Reputation: 0
Sorry, I'm a Mac newbie ...

How does one restart the service? Assuming we want to restart nfsd.

I don't find an /etc/*nfs*, fer instance. Can't give that a "restart".
Old 04-15-2011, 11:49 PM   #10
LQ Newbie
Registered: Nov 2006
Location: Bucharest - Romania
Posts: 2

Rep: Reputation: 10
How to restart a service

Originally Posted by drub View Post
Sorry, I'm a Mac newbie ...

How does one restart the service? Assuming we want to restart nfsd.

I don't find an /etc/*nfs*, fer instance. Can't give that a "restart".
Try this: service nfsd restart
1 members found this post helpful.
Old 09-14-2011, 03:16 PM   #11
LQ Newbie
Registered: May 2011
Posts: 2

Rep: Reputation: Disabled
Check if portmap was added to /etc/hosts.deny,if so, comment the line and restart nfs
Old 09-15-2011, 02:04 PM   #12
LQ Newbie
Registered: Sep 2011
Distribution: redhat
Posts: 14

Rep: Reputation: Disabled
Restart portmap
/etc/init.d/portmap restart

restart nfs
/etc/init.d/nfsd restart


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
mount: RPC: Program not registered ritesh_aladdin Linux - Networking 7 10-01-2005 10:14 AM
mount: RPC: Program not registered Harry Seldon Linux - Networking 3 09-05-2005 03:05 PM
NFS Portmap: RPC: Program not registered fibbi Linux - Software 2 08-12-2004 12:40 AM
Mount RPC : Program not registered phonecian Linux - Networking 2 08-29-2003 05:51 AM
mount: RPC: Program not registered madenan Linux - Software 2 08-16-2003 02:39 PM > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 11:03 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration