-   Linux - Networking (
-   -   NFS + Red Hat 8 + me = no love (

Dark_Helmet 05-05-2003 12:50 PM

NFS + Red Hat 8 + me = no love
Ok, I just can't get NFS to work for me for some reason. I've searched through the archives for "NFS" and there were some hits, but mostly just discussions of why it should be used. Anyway...

I've got three machines. One has tremendous storage capacity that I want to use as a fileserver (Alexandria). The two others will connect as needed (Hermes, Deimos). Here are (what I believe to be) the important config files for Alexandria:


/etc/exports: -------------------------------------
/mnt/shared_net      *(ro,insecure,sync,all_squash)

/etc/hosts.deny: -------------------------------------

/etc/hosts.allow: -------------------------------------

My local network is set to use IP addresses in the range of throught So the masks in hosts.allow should work, right?

I check the services through Red Hat's tools, and it says NFS is running. Using ps and grep, I get this:


# ps -aux | grep rpc
rpc        612  0.0  0.2  1484  576 ?        S    Apr27  0:00 portmap
rpcuser    631  0.0  0.2  1528  612 ?        S    Apr27  0:00 rpc.statd
root    28899  0.0  0.2  3272  548 ?        S    02:06  0:00 rpc.rquotad
root    28912  0.0  0.0    0    0 ?        SW  02:06  0:00 [rpciod]
root    28918  0.0  0.3  1808  848 ?        S    02:06  0:00 rpc.mountd

I try to mount a share from either Hermes or Deimos with the following command:

mount -t nfs -o soft,intr,timeo=20 //alexandria:/mnt/shared_net /mnt/shared_files
The appropriate entry for alexandria is in the /etc/hosts file, and the /mnt/shared_files mount point does exist. When the command is executed, it always times out. I have tried adding the tcp option to the mount command, and I get a different error, but the result is the same.

The network is good because I can ping each machine from any other machine. I just can't figure this one out. Any suggestions?

td3201 05-05-2003 03:16 PM


< My local network is set to use IP addresses in the range of throught So the masks in hosts.allow should work, right?

Yes...according to HOSTS_ACCESS(5).

have you tried nmap from Hermes and Deimos to see if they can get to the NFS ports?

For example:
nmap -sT alexandria

What is the exact error messages you are receiving?

Dark_Helmet 05-05-2003 08:37 PM

Red Hat may have lied to me about NFS running. To double-check, I ran:

# ps -aux | grep nfs
root    28903  0.0  0.0    0    0 ?        SW  02:06  0:00 [nfsd]
root    28904  0.0  0.0    0    0 ?        SW  02:06  0:00 [nfsd]
root    28905  0.0  0.0    0    0 ?        SW  02:06  0:00 [nfsd]
root    28906  0.0  0.0    0    0 ?        SW  02:06  0:00 [nfsd]
root    28907  0.0  0.0    0    0 ?        SW  02:06  0:00 [nfsd]
root    28908  0.0  0.0    0    0 ?        SW  02:06  0:00 [nfsd]
root    28909  0.0  0.0    0    0 ?        SW  02:06  0:00 [nfsd]
root    28910  0.0  0.0    0    0 ?        SW  02:06  0:00 [nfsd]

That just doesn't seem right...

Anyway, here's the result of the command you suggested:

Starting nmap V. 3.00 ( )
Interesting ports on Alexandria (
(The 1595 ports scanned but not shown below are in state: closed)
Port      State      Service
21/tcp    open        ftp
22/tcp    open        ssh
111/tcp    open        sunrpc
139/tcp    open        netbios-ssn
671/tcp    open        unknown
6000/tcp  open        X11

Nmap run completed -- 1 IP address (1 host up) scanned in 1 second

That suggests even more strongly the NFS daemon is not, in fact, running.

For the sake of being thorough though. The UDP version of mount returns this:

mount: RPC: Timed out
Using the mount command with the tcp option returns:

NFS server reported service unavailable: Address already in use
So... it would seem the NFS daemon is not running. However, I haven't messed with NFS at all beyond trying to configure it with these files.

I tried killing off all the NFS processes listed above, and then restarted it using Red Hat's tool:

service nfs start
No luck though. What the next move? Find all the sources for NFS and its support, compile, and install on top of my existing stuff?

acid_kewpie 05-06-2003 03:00 AM

tried the correct syntax?

mount -t nfs -o options alexandria:/mnt/shared_net /mnt/shared_files

Dark_Helmet 05-06-2003 08:22 AM

Hehehe... I was hoping nobody would notice that...

I did run the mount command with the right syntax; I just transferred it to the post incorrectly. I've even tried:

mount -t nfs -o soft,intr,timeo=20 192.168.0.XX:/mnt/shared_net /mnt/shared_files

X's being replaced by the appropriate address of course.

The same failure. The remote procedure calls are running, but is the nfs daemon supposed to have a ps output of all 0s? What could be getting in the way? A firewall? Does Red Hat come installed with iptables blocking nfs access? Would that be why nmap couldn't see the ports?

At this point, I'm grasping at straws.

I really do appreciate all the help gentlemen.

td3201 05-06-2003 08:35 AM

Hrm, do you have mountd running?
Are you starting the server by issuing 'service nfs start' ?
Try simplifying it by taking out some of those options for now. You have the portmapper (111) running, which is what I wanted to see.

Dont worry about those zeroes.

Have you tried mounting it on the server?

Dark_Helmet 05-06-2003 11:45 AM

Yeah, the share is mounted locally on Alexandria. The shared files are located on a drive separate from the system. So, I mount it to Alexandria's filesystem tree, and then attempt to mount the share from Deimos or Hermes.

I used the Red Hat tool to set NFS to run on boot. I believe it's redhat-config-services or soemthing very similar. So, it should be started, but because of the trouble I've been having, I've gotten into the habit of restarting nfs anytime I do anything that might influence its operation:

# service nfs restart

I'm at work and can't try the mount commands or look for mountd right now. I'll post the results once I have some time to bang on the keyboard.

Dark_Helmet 05-06-2003 06:28 PM

I tried the mount command without any options, and it just gets to the timeout faster...

As for mountd...

# ps -aux | grep mountd
root    30227  0.0  0.3  1800  840 ?        S    May05  0:00 rpc.mountd

I may sit down and try things reversed: getting on of the other machines to share and try to have Alexandria mount it. If so, then there's something screwy with some other network-related config file...

Dark_Helmet 05-07-2003 09:23 PM

Well, I don't know what I did to screw Red Hat up, but I installed Mandrake on another drive I was planning to put LFS on. The short version is, NFS works using Mandrake.

I'm sure other folks got Red Hat going on the first try, but since Mandrake didn't cause me any grief, it's going to stay on the machine, and the Red Hat drive will become the future LFS.

I appreciate the help.

All times are GMT -5. The time now is 08:19 PM.