LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (https://www.linuxquestions.org/questions/linux-networking-3/)
-   -   NFS Problem with Knoppix (https://www.linuxquestions.org/questions/linux-networking-3/nfs-problem-with-knoppix-371171/)

pengzy 10-09-2005 06:59 AM

NFS Problem with Knoppix
 
Hi, I'm facing some problems with using NFS in knoppix, can someone help me out and point out what's wrong? Thanks.

I did the following:

1. Amended the exports file- etc/exports:
/KNOPPIX.IMG/home/knoppix/images 192.168.1.2(ro)

2. Changed the IP of the main machine to 192.168.1.1:
ifconfig eth0 192.168.1.1 netmask 255.255.255.0

3. Restarted the NFS services:
/etc/init.d/portmap restart
/etc/init.d/nfs-kernel-server restart
/etc/init.d/nfs-common restart

4. Log in to the 2nd machine (uCSimm running uCLinux, default IP of 192.168.1.2) and run:
mount -t nfs -o wsize=256,rsize=256 192.168.1.1:/KNOPPIX.IMG/home/knoppix/images /usr

5. Got the following error:
mount:RPC:Unable to receive; errno:Connection refused
mount:nfsmount faNFS: mount program didn't pass remote address!
iled: Bad file descriptor
mount: Mounting 192.168.1.1:/KNOPPIX.IMG/home/knoppix/rtai/images on /usr failed: Invalid argument
pid 36: failed 256

Can someone tell me which part is incorrect? It seems like the way I type the mount command may be wrong from the invalid argument part. I can ping the other machine from each machine respectively and I have turned off the Firewall as well. Thanks in advance!

b0nd 10-09-2005 08:09 AM

hello,
cross check it with this

regards

Edit: that time i wasn't able configure it.........but now everytime it works for me

pengzy 10-09-2005 10:35 PM

Thanks...will try it when i get back!
 
Thanks for the tips. If I still face any problems, then I will post it here again. Thanks!


All times are GMT -5. The time now is 09:34 AM.