LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 01-14-2007, 05:48 PM   #1
nafan
Member
 
Registered: May 2004
Location: /dev/bed
Distribution: Mandriva 2009.0 Powerpack
Posts: 172

Rep: Reputation: 30
Talking [FIXED] nfs mount can't read superblock


I'm having trouble mounting an nfs share. Trying to mount the share returns
Code:
mount: 192.168.1.3:/opt/Music: can't read superblock
/etc/exports on the server (192.168.1.3) contains
Code:
/opt/Music 192.168.1.6(sync,no_wdelay,insecure,no_root_squash,rw)
/etc/fstab on the client machine (192.168.1.6) has the line
Code:
192.168.1.3:/opt/Music /opt/Music nfs noauto,user,rw  0 0
I'm at a loss to explain what's happening (or not happening). Anyone have any ideas?

Edit:
I have been digging around a bit further and somehow missed the complaints from the kernel in /var/log/syslog that portmap wasn't started locally.
Code:
Jan 15 12:12:11 maxdata kernel: RPC: failed to contact portmap (errno -5).
Jan 15 12:12:11 maxdata kernel: lockd_up: makesock failed, error=-5
Jan 15 12:12:46 maxdata kernel: portmap: server localhost not responding, timed out
**feels like a right fool..**

Last edited by nafan; 01-15-2007 at 06:44 AM. Reason: Solution! - YMMV
 
Old 01-15-2007, 11:33 AM   #2
xjlittle
Member
 
Registered: Aug 2003
Location: Indiana
Distribution: fc6 sles9 & 10 kubuntu ubuntu-server
Posts: 240
Blog Entries: 2

Rep: Reputation: 30
Do you the nfs server and portmap service started on the server? See the howto at http://tldp.org/HOWTO/NFS-HOWTO/server.html to check and make sure everything is running ok.
 
Old 04-17-2007, 03:05 AM   #3
obourdon
LQ Newbie
 
Registered: Apr 2007
Posts: 1

Rep: Reputation: 0
try using the -o nolock option from the nfs mount command
 
1 members found this post helpful.
Old 04-17-2007, 04:08 AM   #4
mether
Member
 
Registered: Mar 2007
Distribution: RHEL, Fedora, Open Suse
Posts: 151

Rep: Reputation: 31
First check :

#shoumount -e serverip

If you see the shares check the settings suggested by xjlittle
 
Old 05-15-2007, 01:22 AM   #5
Jim_B
LQ Newbie
 
Registered: Jan 2007
Distribution: zenwalk,vector,dreamlinux,puppy,pclinuxos
Posts: 11

Rep: Reputation: 0
Wink same issue, -o nolock works perfectly...

Thanks.
 
Old 10-02-2008, 06:39 PM   #6
Firerat
Senior Member
 
Registered: Oct 2008
Distribution: Debian sid
Posts: 2,683

Rep: Reputation: 783Reputation: 783Reputation: 783Reputation: 783Reputation: 783Reputation: 783Reputation: 783
Just had the same problem, opened up the firewall on the server and it is working now
 
Old 04-22-2009, 05:33 PM   #7
guanx
Senior Member
 
Registered: Dec 2008
Posts: 1,069

Rep: Reputation: 160Reputation: 160
Quote:
Originally Posted by obourdon View Post
try using the -o nolock option from the nfs mount command
It works. Thank you!
 
Old 04-12-2010, 06:39 AM   #8
jazz13
LQ Newbie
 
Registered: Aug 2009
Location: Ukraine
Distribution: Archlinux
Posts: 6

Rep: Reputation: 2
Quote:
Originally Posted by obourdon View Post
try using the -o nolock option from the nfs mount command
Worked out! Thank you.
 
Old 06-12-2014, 04:40 AM   #9
bhussein
LQ Newbie
 
Registered: Sep 2013
Posts: 25

Rep: Reputation: Disabled
Quote:
Originally Posted by obourdon View Post
try using the -o nolock option from the nfs mount command
I'm having the same problem as the rest here, but the command above works for me too "Thanks Obourdon", but if i want to add the mount to fstab how can i do that?

if i edit the /etc/fstab and add this entry

nfsrvr:/main /content/html nfs noauto,user,rw 0 0

it doesnt mount it on the next reboot, so i need to add the -o nolock but not sure how to do that in fstab.

Thanks,
 
Old 06-12-2014, 05:48 AM   #10
bhussein
LQ Newbie
 
Registered: Sep 2013
Posts: 25

Rep: Reputation: Disabled
Quote:
Originally Posted by bhussein View Post
I'm having the same problem as the rest here, but the command above works for me too "Thanks Obourdon", but if i want to add the mount to fstab how can i do that?

if i edit the /etc/fstab and add this entry

nfsrvr:/main /content/html nfs noauto,user,rw 0 0

it doesnt mount it on the next reboot, so i need to add the -o nolock but not sure how to do that in fstab.

Thanks,
Please ignore i've managed to resolve by doing the following


nfsrvr:/main /content/html nfs nolock,nfsvers=3 0 0
 
Old 06-12-2014, 02:44 PM   #11
jefro
Moderator
 
Registered: Mar 2008
Posts: 19,968

Rep: Reputation: 3131Reputation: 3131Reputation: 3131Reputation: 3131Reputation: 3131Reputation: 3131Reputation: 3131Reputation: 3131Reputation: 3131Reputation: 3131Reputation: 3131
OK, thanks for the update and solution.

You are also welcome to start new threads on topics if you wish.
 
Old 09-08-2016, 09:22 PM   #12
fhleung
Member
 
Registered: Aug 2004
Distribution: Lubuntu Live OS
Posts: 432

Rep: Reputation: 30
superblock error, it may help after installing the nfs-common

nfs-common https://packages.debian.org/wheezy/i...ommon/download
 
  


Reply

Tags
mount, network, nfs


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
I get mount: /dev/cdrom: can't read superblock, How to fix? zLinuxz Linux - General 12 06-18-2008 02:42 AM
error mounting ext3 filesystem... mount: /dev/hdd1: can't read superblock versaulis Linux - Software 5 11-26-2006 08:34 PM
mount: server:/home can't read superblock phil.d.g Linux - General 0 05-11-2006 04:03 PM
mount: /dev/cdrom: can't read superblock raynmune Linux - Hardware 7 07-09-2005 04:02 PM
NFS killing me, (can't read superblock) wael_nasreddine Linux - Networking 13 06-09-2005 06:41 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 01:51 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration