-   Linux - Networking (
-   -   NFS: how can I get write-access?? (

pablovschby 12-24-2003 07:15 AM

NFS: how can I get write-access??

A RedHat9-Shrike-Dist as an NFS-server... all nfs-services are starting's my /etc/exports:
  • /etc/exports
    /home/test %ip of client% (rw)
well...everything works...(but write-access)....I'm mounting this share on a Neolinux (NW Capio 508)-TClient with the ip %ip of client%... like this:
  • mount %ip of rh9-server%:/home/test /writable/mount_server -o rw
....and also that works without an error message....but if I change to the directory /writable/mount_server on the client and want to create a new file with "vi".... per command "wq!"....this error occurs

can't open file for writing...
mmmh.... I can't understand what my redhat is doing...

cause I share this folder for the client as "rw" ... and I mount the share on the client with the options "rw".....
what the hell did I wrong?
thanks for all advices

jharris 12-24-2003 07:33 AM

What user as your trying to write the files as? If it is the root user on the client machine then this is the correct behaviour, the root user on an NFS client is 'squashed' be default. Any UID 0 (root) access from the client gets mapped to the nobody user on the server. You can change this by using the no_root_squash option on the server. Typically set in /etc/exports something like



Parksy 12-24-2003 08:15 AM

Re: NFS: how can I get write-access??
Make sure you don't have a space after the ip address:

/home (rw) - bad
/home - good

pablovschby 12-24-2003 08:39 AM

thanks a lot!!!!!

it works now with:

/home/test %client-ip%(rw,no_root_squash,sync)
problem is solved

All times are GMT -5. The time now is 09:56 PM.