LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 08-19-2015, 08:40 PM   #1
robshaw
LQ Newbie
 
Registered: Aug 2015
Posts: 16

Rep: Reputation: Disabled
Question Newbie with poor Linux techno skills needs to install a dialup modem for internet


Newbie Help Please, Hi guys I,m still unable to connect to the dialup service despite all efforts & ISP providor ( They will NOT assist because I am using Linux only if I use Windows). If you can offer any advice on what may be the problem from* the error message I would be most grateful. Please see the* attached Screen dump of the attempted initialising of the dial up connection Thank You Regards Rob

> WvDial: Internet dialer version 1.61
--> Cannot set information for serial port.
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
OK
--> Modem initialized.
--> Sending: ATM1L3DT0198308100
--> Waiting for carrier.
ATM1L3DT0198308100
CONNECT 57600
--> Carrier detected. Waiting for prompt.
** Dial IP **
Username:
--> Looks like a login prompt.
--> Sending: robertshaw1du
robertshaw1du
Password:
--> Looks like a password prompt.
--> Sending: (password)
L2TP: Starting session
Primary server '123.2.2.126'
Secondary server '123.2.2.127'
~[7f]}#@!}!}!} }9}"}&} }*} } }#}%B#}%}%}&[0e]?[0b][05]}'}"}(}"Te~
--> PPP negotiation detected.
--> Starting pppd at Thu Aug 20 11:13:22 2015
--> Warning: Could not modify /etc/ppp/pap-secrets: Permission denied
--> --> PAP (Password Authentication Protocol) may be flaky.
--> Warning: Could not modify /etc/ppp/chap-secrets: Permission denied
--> --> CHAP (Challenge Handshake) may be flaky.
--> Pid of pppd: 3230
--> Using interface ppp0
--> Disconnecting at Thu Aug 20 11:13:43 2015
--> The PPP daemon has died: A modem hung up the phone (exit code = 16)
--> man pppd explains pppd error codes in more detail.
--> Try again and look into /var/log/messages and the wvdial and pppd man pages for more information.
P.S. Error Code 16 The link was terminated because the peer is not responding to echo requests.- OS = Linux Mint 17 Quiana Modem = KTX 56K External Fax Modem. Reason fo Dial up service = Nil other options currently only very poor sat service ie .07Mbs
 
Old 08-20-2015, 01:12 PM   #2
jpollard
Senior Member
 
Registered: Dec 2012
Location: Washington DC area
Distribution: Fedora, CentOS, Slackware
Posts: 4,912

Rep: Reputation: 1513Reputation: 1513Reputation: 1513Reputation: 1513Reputation: 1513Reputation: 1513Reputation: 1513Reputation: 1513Reputation: 1513Reputation: 1513Reputation: 1513
It has been a long time since setting up a dialup, and there could be a couple of things happening here.

1. The dialer utility MOST LIKELY needs to be started by root. If doing this as root fixes the problem the next issue shouldn't be relevent, but MAY affect second logins and starting the dialer not as root.

2. The dialer may be running setuid to a dialer utility, and needs to be configured first.
According to the documentation for WvDial, the file /etc/wvdial.conf should exist - this file ought to have the
phone number, the username, and the password to use as well as the choice of authenticator (the default may be
wrong).

In addition the file /etc/ppp/pap-secrets is used to store the password so the dialer may be started by a user
without root (the setuid/setgid on the dialer should handle that) - but the file may be owned by root and not
the dialer account.

You will have to refer to the manpage on wvdial (both "man wvdial" and "man wvdial.conf") to see what the contents of the /etc/wvdial.conf should be (my file is empty, but I'm also not using dialup).
 
Old 08-20-2015, 01:23 PM   #3
colorpurple21859
LQ Veteran
 
Registered: Jan 2008
Location: florida panhandle
Distribution: Slackware Debian, Fedora, others
Posts: 7,434

Rep: Reputation: 1603Reputation: 1603Reputation: 1603Reputation: 1603Reputation: 1603Reputation: 1603Reputation: 1603Reputation: 1603Reputation: 1603Reputation: 1603Reputation: 1603
did you add user to dip group?
What isp are you using?
maybe this will help: http://dedoimedo.com/computers/dialup.html
 
Old 08-20-2015, 02:48 PM   #4
jefro
Moderator
 
Registered: Mar 2008
Posts: 22,029

Rep: Reputation: 3632Reputation: 3632Reputation: 3632Reputation: 3632Reputation: 3632Reputation: 3632Reputation: 3632Reputation: 3632Reputation: 3632Reputation: 3632Reputation: 3632
See warnings on this page maybe. http://manpages.ubuntu.com/manpages/.../wvdial.1.html
 
Old 08-20-2015, 03:29 PM   #5
JaseP
Senior Member
 
Registered: Jun 2002
Location: Eastern PA, USA
Distribution: K/Ubuntu 18.04-14.04, Scientific Linux 6.3-6.4, Android-x86, Pretty much all distros at one point...
Posts: 1,802

Rep: Reputation: 157Reputation: 157
Oh,... Besides jefro's excellent suggestion to look at the wvdial manpage,... You should also consider this; Many telephone modems are "Winmodems,"... That is, the modem lacks a DSP and relies on firmware (and the CPU) to do that job. What you want is a "true" modem with a DSP (Digital Signal Processor)... It's been years for me since using dial-up, but I recall I had to get an external modem with a DSP (it connected to the computer through an RS-232 port,... if that tells you anything about how long ago it was). Many of the old "Winmodems" were eventually made to work in Linux,... Many were not.
 
Old 08-21-2015, 03:46 AM   #6
robshaw
LQ Newbie
 
Registered: Aug 2015
Posts: 16

Original Poster
Rep: Reputation: Disabled
Unhappy Thanx for your assistance that file /etc/wvdial.conf does not exist. /etc does but NO Wvdial.config

Thanx for your assistance that file /etc/wvdial.conf does not exist. /etc does but NO Wvdial.config
Quote:
Originally Posted by jpollard View Post
It has been a long time since setting up a dialup, and there could be a couple of things happening here.

1. The dialer utility MOST LIKELY needs to be started by root. If doing this as root fixes the problem the next issue shouldn't be relevent, but MAY affect second logins and starting the dialer not as root.

2. The dialer may be running setuid to a dialer utility, and needs to be configured first.
According to the documentation for WvDial, the file /etc/wvdial.conf should exist - this file ought to have the
phone number, the username, and the password to use as well as the choice of authenticator (the default may be
wrong).

In addition the file /etc/ppp/pap-secrets is used to store the password so the dialer may be started by a user
without root (the setuid/setgid on the dialer should handle that) - but the file may be owned by root and not
the dialer account.

You will have to refer to the manpage on wvdial (both "man wvdial" and "man wvdial.conf") to see what the contents of the /etc/wvdial.conf should be (my file is empty, but I'm also not using dialup).
 
Old 08-21-2015, 04:48 AM   #7
ferrari
LQ Guru
 
Registered: Sep 2003
Location: Auckland, NZ
Distribution: openSUSE Leap
Posts: 5,864

Rep: Reputation: 1152Reputation: 1152Reputation: 1152Reputation: 1152Reputation: 1152Reputation: 1152Reputation: 1152Reputation: 1152Reputation: 1152
Quote:
Thanx for your assistance that file /etc/wvdial.conf does not exist. /etc does but NO Wvdial.config
Are you using a GUI dialer (eg gnome-ppp)? That may explain why the default config file (/etc/wvdial.conf) is not present. The graphical utility you are using will have a similar config file in a different location, and call wvdial using that config file.

Anyway, it does look like it is failing to establish the ppp session because it fails to authenticate, (likely for the reasons jpollard and colorpurple indicated already).
Code:
--> Warning: Could not modify /etc/ppp/pap-secrets: Permission denied
--> --> PAP (Password Authentication Protocol) may be flaky.
--> Warning: Could not modify /etc/ppp/chap-secrets: Permission denied
--> --> CHAP (Challenge Handshake) may be flaky.
--> Pid of pppd: 3230
--> Using interface ppp0
--> Disconnecting at Thu Aug 20 11:13:43 2015
--> The PPP daemon has died: A modem hung up the phone (exit code = 16)
Check that the user is in the appropriate group for access. I think that when you sort that, authentication should complete with no further issues.

Check the permissions of /etc/ppp/pap-secrets and /etc/ppp/chap-secrets too
Code:
ls -l /etc/ppp/pap-secrets
Code:
ls -l /etc/ppp/chap-secrets
 
Old 08-21-2015, 05:14 AM   #8
colorpurple21859
LQ Veteran
 
Registered: Jan 2008
Location: florida panhandle
Distribution: Slackware Debian, Fedora, others
Posts: 7,434

Rep: Reputation: 1603Reputation: 1603Reputation: 1603Reputation: 1603Reputation: 1603Reputation: 1603Reputation: 1603Reputation: 1603Reputation: 1603Reputation: 1603Reputation: 1603
Who it is your dial-up provider? If it is netzero, the default linux dialers will not work, but there is a work around.
 
Old 08-21-2015, 06:51 AM   #9
robshaw
LQ Newbie
 
Registered: Aug 2015
Posts: 16

Original Poster
Rep: Reputation: Disabled
Unhappy Thanx for your assistance

I think that's the thing I'm using lots of small pins & part of the reason to use this type of desktop PC. The modem seems to connect & handshake but immediately drops out with no connection. I am embarrassed to have to resort to attempts to use dial up as a means of connecting to the internet, however such is the availability of services in Australia for those that live outside of a major city. To add insult to injury i live on a property with a paved road approx 20 kms from a major town with the fiber optic cable less than 20 mtrs from my back door &have No access to the internet other than a VERY poor over subscribed satellite service. Connection to the internet would be quicker via dialup. How sad a state of affairs is that but that is the best available option..
Quote:
Originally Posted by JaseP View Post
Oh,... Besides jefro's excellent suggestion to look at the wvdial manpage,... You should also consider this; Many telephone modems are "Winmodems,"... That is, the modem lacks a DSP and relies on firmware (and the CPU) to do that job. What you want is a "true" modem with a DSP (Digital Signal Processor)... It's been years for me since using dial-up, but I recall I had to get an external modem with a DSP (it connected to the computer through an RS-232 port,... if that tells you anything about how long ago it was). Many of the old "Winmodems" were eventually made to work in Linux,... Many were not.
 
Old 08-21-2015, 06:54 AM   #10
robshaw
LQ Newbie
 
Registered: Aug 2015
Posts: 16

Original Poster
Rep: Reputation: Disabled
Talking Thanks for your help

Here in Australia it is DoDo. There are very limited dial up service providors available.Thanx again
Quote:
Originally Posted by colorpurple21859 View Post
Who it is your dial-up provider? If it is netzero, the default linux dialers will not work, but there is a work around.
 
Old 08-21-2015, 02:53 PM   #11
jefro
Moderator
 
Registered: Mar 2008
Posts: 22,029

Rep: Reputation: 3632Reputation: 3632Reputation: 3632Reputation: 3632Reputation: 3632Reputation: 3632Reputation: 3632Reputation: 3632Reputation: 3632Reputation: 3632Reputation: 3632
I don't think you would have gotten an AT at all if it were an unsupported modem. Even winmodems are somewhat supported. I think your assessment of the fault is correct.

--> Starting pppd at Thu Aug 20 11:13:22 2015
--> Warning: Could not modify /etc/ppp/pap-secrets: Permission denied
--> --> PAP (Password Authentication Protocol) may be flaky.
--> Warning: Could not modify /etc/ppp/chap-secrets: Permission denied
--> --> CHAP (Challenge Handshake) may be flaky.

Think you need to look at a few solutions. One being if this pap-secrets and chap-secrets. Some web pages suggest putting in your info to them first.

It is failing on pap/chap.
 
Old 08-21-2015, 07:49 PM   #12
ferrari
LQ Guru
 
Registered: Sep 2003
Location: Auckland, NZ
Distribution: openSUSE Leap
Posts: 5,864

Rep: Reputation: 1152Reputation: 1152Reputation: 1152Reputation: 1152Reputation: 1152Reputation: 1152Reputation: 1152Reputation: 1152Reputation: 1152
Hi Rob

Further to jefro's excellent advice (which I also believe should get you a working dialup connection), you can actually use 'wvdial' itself to test and get connected from a terminal window. The 'wvdialconf' utility will detect your modem and create a basic /etc/wvdial.conf file.

Code:
sudo wvdialconf
Once that's done you can edit the file as root using your favourite editor, entering your phone number and authentication credentials.
Code:
sudo nano /etc/wvdial.conf
For example, a basic working configuration might look something like this
Code:
[Dialer Defaults]
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Phone = 0198308100
Modem Type = Analog Modem
Stupid Mode = yes
BAUD = 57600
New PPPD = yes
Modem = /dev/ttyUSB0
ISDN = 0
Carrier Check = no
Password = ********
Username = *****
You modem might be different to the example above, but wvdialconf should take care of getting that right. Here you can see that you'd add your phone number, username and password in the lines shown.

When done with editing, try dialling with
Code:
sudo wvdial
It may take a bit of further tweaking to get connected, but the wvdial output should reveal what is needed.
 
Old 08-21-2015, 07:59 PM   #13
ferrari
LQ Guru
 
Registered: Sep 2003
Location: Auckland, NZ
Distribution: openSUSE Leap
Posts: 5,864

Rep: Reputation: 1152Reputation: 1152Reputation: 1152Reputation: 1152Reputation: 1152Reputation: 1152Reputation: 1152Reputation: 1152Reputation: 1152
Quote:
I am embarrassed to have to resort to attempts to use dial up as a means of connecting to the internet, however such is the availability of services in Australia for those that live outside of a major city. To add insult to injury i live on a property with a paved road approx 20 kms from a major town with the fiber optic cable less than 20 mtrs from my back door &have No access to the internet other than a VERY poor over subscribed satellite service. Connection to the internet would be quicker via dialup. How sad a state of affairs is that but that is the best available option..
I can assure you that the situation you're facing is like that in many rural and even semi-rural areas of NZ, and in the USA from what I've read online from time to time. Do you have mobile phone coverage in your area? Is 3G/4G access an option? I know that the data is often capped in these situations, but better than dial-up in some use cases.

In any case, I am confident that we can get your dial-up connection working. You're so close!
 
Old 08-21-2015, 09:46 PM   #14
robshaw
LQ Newbie
 
Registered: Aug 2015
Posts: 16

Original Poster
Rep: Reputation: Disabled
Angry Thanx for all your help No 2G 3G or 4G Fixed Wireless or ADSL available

Thanx for all your help No 2G 3G or 4G Fixed Wireless or ADSL available. Addition to Sat service expected March 2016, however they cant forsee how long it will be before they will be able to change me over.Thanx again Regards Rob

Quote:
Originally Posted by ferrari View Post
I can assure you that the situation you're facing is like that in many rural and even semi-rural areas of NZ, and in the USA from what I've read online from time to time. Do you have mobile phone coverage in your area? Is 3G/4G access an option? I know that the data is often capped in these situations, but better than dial-up in some use cases.

In any case, I am confident that we can get your dial-up connection working. You're so close!
 
Old 08-21-2015, 11:00 PM   #15
robshaw
LQ Newbie
 
Registered: Aug 2015
Posts: 16

Original Poster
Rep: Reputation: Disabled
How to Save the Edit in /etc/wvdial.conf ?

Thanx Ferrari I can get into the /etc/wvdial.conf ( Someone told me to use sudo nemo PW change to the file & enter edit. I can do this but how do I make it save the edit please ? It does not seem to save the edit entry. Regards Rob. P.S. I am removing the semi colons & justifying it all to the left. ( I think this is right) Appreciate your assistance Rob
[Dialer Defaults]
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Modem Type = Analog Modem
; Phone = <Target Phone Number>
ISDN = 0
; Password = <Your Password>
New PPPD = yes
; Username = <Your Login Name>
Modem = /dev/ttyS0
Baud = 115200







[ Read 12 lines ]
^G Get Help ^O WriteOut ^R Read File ^Y Prev Page ^K Cut Text ^C Cur Pos
^X Exit ^J Justify ^W Where Is ^V Next Page ^U UnCut Text^T To Spell

Quote:
Originally Posted by ferrari View Post
Hi Rob

Further to jefro's excellent advice (which I also believe should get you a working dialup connection), you can actually use 'wvdial' itself to test and get connected from a terminal window. The 'wvdialconf' utility will detect your modem and create a basic /etc/wvdial.conf file.

Code:
sudo wvdialconf
Once that's done you can edit the file as root using your favourite editor, entering your phone number and authentication credentials.
Code:
sudo nano /etc/wvdial.conf
For example, a basic working configuration might look something like this
Code:
[Dialer Defaults]
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Phone = 0198308100
Modem Type = Analog Modem
Stupid Mode = yes
BAUD = 57600
New PPPD = yes
Modem = /dev/ttyUSB0
ISDN = 0
Carrier Check = no
Password = ********
Username = *****
You modem might be different to the example above, but wvdialconf should take care of getting that right. Here you can see that you'd add your phone number, username and password in the lines shown.

When done with editing, try dialling with
Code:
sudo wvdial
It may take a bit of further tweaking to get connected, but the wvdial output should reveal what is needed.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Internet dialup with HDA CX11720 soft modem jepjeffery Debian 4 07-09-2011 07:07 PM
internet sharing using dialup modem? hitesh_linux Linux - Networking 7 12-06-2004 12:28 PM
cannot connect to the internet with dialup modem and kppp shams Linux - Networking 2 10-16-2004 11:21 AM
Route dialup modem packets back through dialup instead of default route cable modem jogress Linux - Networking 1 10-21-2003 03:48 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 08:14 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration