LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 01-12-2005, 12:56 AM   #1
garydamm
LQ Newbie
 
Registered: Jan 2005
Posts: 7

Rep: Reputation: Disabled
Newbie: Trouble configuring http to respond to outside requests


I am running Mandrake 10 and a Resin 3.0 app server. From my machine I can hit the Resin homepage as root or any other user. But from other machines on the LAN I can not hit the Resin homepage. The connection times out.

I am running a Samba server and the same two machines on the LAN are able to use Samba.

I am unable to ping my Mandrake computer either from itself (ping localhost) or the Windows machine on the LAN (ping ipaddress).

Granted this is probably simple but I'm not sure where to start.

Thanks in advance for any help.
 
Old 01-12-2005, 03:41 AM   #2
rjlee
Senior Member
 
Registered: Jul 2004
Distribution: Ubuntu 7.04
Posts: 1,991

Rep: Reputation: 76
You should probably start by looking at your firewall settings, and the configuration of your eth0 (wired) or wlan0 (wireless) network interface.

You'll find both of these in your configuration tool (which I think is Drakx for Mandrake?)
 
Old 01-12-2005, 11:32 AM   #3
garydamm
LQ Newbie
 
Registered: Jan 2005
Posts: 7

Original Poster
Rep: Reputation: Disabled
I've checked the firewall and eth0 with Mandrakelinux Control Center

I've set the firewall to allow ping and web server requests using the Mandrakelinux Control Center. Since my http server is listening on 8080 I added that to the miscellaneous ports on the firewall. Then I set the device to eth0 when prompted. One note, when I go back into the firewall it always resets the "device connected to the internet" to ppp+ and I always have to change it back to eth0. I'm not sure if this is a UI issue or it is actually never saving my change.

I also checked my tcp/ip device for eth0. It is an ethernet card connected to a linksys router. The IP and Netmask are set. It is using DHCP. So as far as I can tell it is good.

But I still do not get a response from ping or http from my other computer on the LAN. Note, Samba seems to work fine.

Any other suggestions? Thanks for any help.

Gary
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Apache doesn't respond png requests from a remote host. glitchful Linux - Software 3 09-02-2005 09:58 AM
Can't get my http server to respond to requests... garydamm Linux - Networking 9 01-16-2005 10:00 AM
Help! (I'm getting flooded with http requests) rknoesel Mandriva 6 11-14-2004 05:57 PM
capture http requests at squid ssharma_02 Linux - Networking 1 09-26-2004 09:04 AM
Program to capture all Http requests in a Network leninkoduru Linux - Security 4 02-02-2004 02:00 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 03:44 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration