-   Linux - Networking (
-   -   Newbie (me) wants to connect Linux laptop to hotel network (

wjn 09-28-2003 03:39 PM

Newbie (me) wants to connect Linux laptop to hotel network
I'm staying at a hotel with Zum ethernet service.

My uSoft box connects just fine.

However, my Linux RH8 laptop is having problems. It connects, and I can do rudimentary surfing. However, if I try to do any major downloading (like running RH update) it begins the file transfer and then the data transfer stops.

When I called Zum tech support, they first said they don't support Linux. Then I called them back and wheedled a bit more information. They said the connection is 10 MBit with no proxy and they usually tell the customer to set up full duplex or half. (I found that comment particularly perplexing).

Anyway, they have two DNS, one at and another at Their subnet mask is Their default gateway is and they ask you to configure your box for DHCP.

Does anyone have any suggestions for me? I will thank you in advance... this Winders box is driving me nutz.



david_ross 09-28-2003 03:47 PM

Well If they say to use dhcp then I suggest that may be the best way to start. Considering you can surf I would go with the suggestion of running at half duplex. Take a look at:

wjn 09-28-2003 03:57 PM


Thanks for your input.

This is going to show my level of competence... how do I change the NIC parameters? In the RH8 GUIs you can set the major stuff, but I can't see anything about modify stuff like baud rates and such.

I have a BFB with me, too... a 6 pounder. ("Practical Guide to Linux RH8" by Mark Sobell. It's a good book, just not quite down to the detail needed to do this.)



PS... I tried that rm / rf thingie and now it won't do anything.


Just kidding.

david_ross 09-28-2003 04:00 PM

Like I said - look into "mii-tool":
man mii-tool

wjn 09-28-2003 04:36 PM

Dear David...

Thank you for your expert advice. You actually answered my question in your first reply, didn't you?

After reviewing the manual, I ran

mii-tool --force=10baseT‐HD

I am now ecstatically posting you from my Linux machine.

Thanks again... on behalf of all of us newbies.


david_ross 09-28-2003 04:40 PM

Glad you got it going the way you wanted.

I did mention mii-tool in the first post. I try not to give extremely direct answers for 2 reasons:
1) It takes me longer as I'm terrible at typing ;)
2) You are more likely to remember yourself now since you did most of the work - I just gave you the pointer.

All times are GMT -5. The time now is 02:36 AM.