-   Linux - Networking (
-   -   networking with Fedora 5 (

Jan Tanjo 10-31-2006 10:19 AM

networking with Fedora 5

Have taken the final step and going Linux.

Installed Fedora 5 and when I try to ping other machines (Windows for now), the response is Destination host unreachable.

I had a simailer problem when I was using Mandrake and with the help of determined that it was a firewall setting. Fedora looks a lot different so am having a hard time figuring which setting to change. I found IPTables in service but shutting that down made no diffence that I could see

This machine is going to be used as a file server and hopefully an Application server. Everything appears to be setup right, IP addresses, NICs, etc though I'm not sure about whether Workgroup is named right,(though in 'smb.conf' it looks right.) also I'm not using DHCP.

I've Googled this and a lot of the time I can't get some commands to work in terminal, even as SU and using /sbin/

shaman66 11-01-2006 05:29 AM

what does route show You?
Maybe some problem with Your network?
Destination host unreachable can appear when theres firewall installed on target machine.

Jan Tanjo 11-01-2006 09:44 AM

hi shaman66,

I should mention that there are 3 NICs in this machine. Just wondering if it knows which card to use?!?!

Did route and the last IP segment is showing 0 instead of what ever I put in.

eth0 shows twice, first with the shortened IP address and the second with the right gateway address.

eth1 shows once with the shortened IP and no gateway, which is right

eth2 shows twice with the shortened IP address with an unknown address, I think a gateway address, which there is supposed to be none.

All Flags are 'U' with the gateway flag 'UG'

Jan Tanjo 11-01-2006 09:57 AM

I did a 'IP route show' and the unknown address has no 'scope link' but everything else showed up right.

(I remember learning all this stuff with DOS 12 years ago :study: )

shaman66 11-01-2006 03:30 PM

can You input here the exact output please?
it would help me seeing it ;)

Jan Tanjo 11-06-2006 09:16 AM

Hi shaman66,

OK, this is as verbatum as I could get, meaning I think I got it right

from root /sbin/ip route show dev eth1 proto kernel scope link src 192.168.3 200 dev eth0 proto kernel scope link src 192.168.2 101 dev eth2 proto kernel scope link src 192.168.2 50 dev eth2 scope link
default via dev eth0

Also, from root /sbin/route

Kernel ip routing table
Destination Gateway Genmask Flags Metric Ref Use Iface * U 0 0 0 eth1 * U 0 0 0 eth0 * U 0 0 0 eth2 * U 0 0 0 eth2
Default UG 0 0 0 eth0

Is not the a default ip address when there is no DHCP present? I'm not using DHCP, also the gateway computer is not yet working. (no high speed yet) The only NIC that should have a Gateway is eth0, I did not specify any for eth1 or eth2

shaman66 11-06-2006 01:29 PM

This looks weird. * U 0 0 0 eth0 * U 0 0 0 eth2

2 networks can be gained through 2 different NICs.
169.254 is IMO (but i may be wrong) default IP for windows machines without DHCP server working.

Also what IPs You are trying to ping?
Can Your machine be pinged from other computers?

I hope we will sort this out ;)


Jan Tanjo 11-06-2006 09:54 PM

Sorry, I was concentrating on copying everything accurately and neglected to mention how I had configured them. It is supposed to be;

gate (on eth0)

And as mentioned earlier, there is no DHCP. Fedora can't see anything other than itself and nothing else can see Fedora.

shaman66 11-07-2006 05:28 AM

You need to fix routes on all nics.
ill edit this post with commands to do later.
if you will fix it earlier, tell me please ;)


try tu put down interfaces. all that you wont use at the moment.
for example if you want to ping machines on eth0 put down eth1 and eth2 and tell me if that worked.

Jan Tanjo 11-07-2006 08:23 AM

I deactivated eth1 and eth2 and tried pinging other machines and still nothing

Jan Tanjo 11-10-2006 09:43 PM

I am such an idiot

I'm reconfiguring the studio and there are a few cable ends laying around and I plugged the wrong goddamn network cable into the Fedora box.

Well, when you get that part right things work a lot better. Well I'm off to figure out permission and such. Thanks shaman66 for you time

shaman66 11-11-2006 02:46 AM

nice one :D
but the worst thing is that.. it just happens :D
np m8, we're here to help :)

All times are GMT -5. The time now is 01:16 AM.