-   Linux - Networking (
-   -   networking problem after kernel upgrade (

dt' 12-14-2002 07:25 AM

networking problem after kernel upgrade
Hi. Almost had a successful upgrade from kernel 2.2.19 to 2.4.20. Everything went well except for now I get this error on boot:

Attempting to configure eth0 by contacting a DCHP server...
dchpcd[73]: dhcpstart: ioctl SIOCGIFHWADDR: No such device

The only things I know about my card is it is a 3Com and it was using the 3c59x.o in 2.2.19. Why wouldn't the same module work in the newer kernel? Anyone know what module I would need to use in the newer kernel?

Hopefully someone can help. In the meantime I'm fried and need some sleep so I'm not a grouch at work tommorrow ;)

Incase you can't tell, this IS my first kernel upgrade.

Thanks in advance.

dt' 12-14-2002 04:48 PM

OK, I seem to have a 3Com Corporation 3c905C-TX Fast Etherlink (rev 78) card. I can't seem to find a driver on 3Com's site for this card with the newer kernel. I tried the 3c90x module but i got an error saying this driver is not for kernel verison 2.4.20. Any suggestions?

peter_robb 12-14-2002 04:59 PM

A quick Google search threw this up... ...

dt' 12-14-2002 05:39 PM

OK that's talking about the same driver I was using in 2.2.19 :confused: but I'll give it a try

wdingus 12-14-2002 05:57 PM

The driver for that ethernet card/chipset has been built into the kernel for a _long_ time. Most things are, the idea of downloading a driver from the manufacturer's site like in the Windows world usually isn't necessary.

shoot2kill 12-14-2002 07:50 PM

maybe you might want to compile all 3coms ethernet card as modules since you cannot guess the correct one.

dt' 12-14-2002 07:56 PM

I'm going to forget about this for now and just continue to use 2.2.19. It works beautifully. I was taught at an early age that if it isn't broken, don't try to fix it.

shoot2kill 12-14-2002 08:01 PM

and or at least give it a try till it works. you may fail but you shouldn't give up. Just my thought.

dt' 12-14-2002 08:13 PM

I'm not giving up. Have already tried every suggestion thrown at me with no success. OK, maybe I am giving up, but only temporarily.

Quixotic 01-23-2003 06:47 PM

foudn this for you
i'm having problems with my ethernet too.. and i stumble across this page.
hardware configuration error is when some sort of resource conflict or mis-configuration (that the driver didn't detect at boot) stops the card from working properly. This typically can be observed in several different ways. (1) You get an error message when ifconfig tries to open the device for use, such as ``SIOCSFFLAGS: Try again''. (2) The driver reports eth0 error messages (viewed by dmesg | more) or strange inconsistencies for each time it tries to send or receive data. (3) Typing cat /proc/net/dev shows non-zero numbers in one of the errs, drop, fifo, frame or carrier columns for eth0. (4) Typing cat /proc/interrupts shows a zero interrupt count for the card. Most of the typical hardware configuration errors are also discussed in the FAQ section

the url is:

All times are GMT -5. The time now is 09:18 PM.