-   Linux - Networking (
-   -   networking not working after upgrade (

dontest 01-23-2003 10:27 PM

networking not working after upgrade

I'm running Redhat8.0 and
I've just built the 2.4.20 kernel and upgraded from 2.4.18.
I believe that I must have missed something in the config
for the build of the kernel (hopefully not).

Here's the problem:
When the system boots with the new kernel, I get this:
Bringing up interface eth0
Determining IP information for eth0... failed

When the system comes up and I try to activate the device,
I get "Cannot activate network device eth0"

Luckily, I have the old kernel around and can boot it up
and the networking works just fine (using DHCP).

Where should I start looking to find my problem?

Thanks a bunch,

oulevon 01-23-2003 10:48 PM

What kind of network card are you using? You might need to enable it in make menuconfig (or xconfig). I know I have to enable mine whenver I compile a new kernel.

unSpawn 01-23-2003 11:03 PM

Also, does your usual setup require you to have for instance some "append" line in LILO? Some cards need extra initialization parameters like Base I/O addr and/or Irq.

dontest 01-24-2003 12:33 AM

Thanks for the responses .. though its still not working

The machine is an IBM ThinkPad T30 with an Intel EtherExpress Pro 100B.

So, when I do 'make xconfig', I go to Network device support,
then to Ethernet (10 or 100Mbit) and both EtherExpressPro/100
support buttons are on ('y')

As for LILO .. I'm using the same lilo entry for the new kernel
(just a different label) as I did for the old kernel .. so, I don't
believe the card needs extra init params

oulevon 01-24-2003 12:40 AM

type lsmod at the prompt and see if the module for your card is loaded. You'll have to be su to do this.

dontest 01-24-2003 12:52 AM

ok .. this is weird, when I do an lsmod there is nothing

though, when I boot into my old kernel, there is a long list

What did I do wrong?

oulevon 01-24-2003 12:56 AM

when you compiled the kernel, did you do a
'make modules'
'make modules_install'

dontest 01-24-2003 12:57 AM

yep .. did both

dontest 01-24-2003 12:59 AM

where do the modules come from?

Should I have specified in 'make xconfig' that some
of the choices are modules rather than just clicking
the 'y' button?

oulevon 01-24-2003 01:02 AM

what kind of messages are you getting related to eth0 when you type the command 'dmesg'

dontest 01-24-2003 01:05 AM

# dmesg | grep eth

eth0: Intel Corp. 82801CAM (ICH3) PRO/100 VE (LOM) Ethernet Controller, <MAC ADDR>, IRQ 11

where <MAC ADDR> is my ethernet address

oulevon 01-24-2003 01:15 AM

Okay, It seems that the support for your card is being loaded, but it's running into trouble when it tries to get it's ip address from dhcp. DHCP is still enabled right? You could boot in to your old kernel and type 'ifconfig' to find out your relevant information (write it down), and then boot in to the other kernel and enter it manual with 'ifconfig someipaddress' 'netmask somenetmast' and 'broadcast someaddress'
I don't know if that will work, but it's the best I've got to offer. Somebody with a better idea of how to fix it will probably come along. Sorry.

dontest 01-24-2003 01:18 AM

thanks very much for the help

Anyone else want to take a stab at it?

dontest 01-24-2003 11:41 AM

anyone have any thoughts on this?

KevinJ 01-24-2003 12:01 PM

When you clicked "y" for the devices on your recompile, you compiled everything into the kernel instead of making modular support. That makes for a really big kernel.

Have you tried running "netconfig" to get the card going?

What does /etc/sysconfig/network-scripts/ifcfg-eth0 look like?


All times are GMT -5. The time now is 08:09 PM.