-   Linux - Networking (
-   -   Networking crashes my machine (amd64, gentoo, kernel 2.6.12) (

Polygon 08-11-2005 09:14 AM

Networking crashes my machine (amd64, gentoo, kernel 2.6.12)
I installed Linux on my new machine and noticed that networking (especially longer lasting connections) tends to crash the machine (= instant power off). A safe way to reproduce the problem is opening a connection for a longer time (large file transfer, webradio, irc, doesn't really matter) and just wait some time (5-30 minutes, more connections speed it up) and it will turn the machine off as if I pulled the plug. Connections lasting only a short time (like browsing the web) have not produced crashes so far.
If I do other things (compiling, 3D graphics or listening to music stored locally) the machine runs stable as long as there is no networking involved.

I've tried 3 different network cards (onboard, a RTL8029 and a VIA VT6105) and while it takes different amounts of time to finally crash, the overall problem persists. I also tried to disable ACPI and updated the BIOS but no success. A 12 hour memtest run didn't bring up any memory problems.

My system specs are:
Athlon64 3400+
Asus K8N-E deluxe (nForce3 250gb)
410W Chieftec PSU
GeForce 6600 128MB (from AOpen)
250GB Seagate SATA HDD

The installed Linux system:
Gentoo 2005.1 for amd64 (2.6.12-gentoo-r6 kernel), stable branch
I'd like to give my kernel .config but I'm not allowed to post a link and appending it would make the posting too long. Perhaps a mod can help me here?

Please tell me if you need any more information, I'm very willing to try out everything as I'm currently totally out of ideas what the cause could be.

musicman_ace 08-12-2005 02:24 AM

How aggressive are your CFLAG optimizations?

Polygon 08-13-2005 11:07 AM

Thanks for your reply. Apparently the machine has a more or less wicked hardware issue as the crashes also happened in a Windows system. It's currently back to the store that built it for repair.

Apart from that the CFLAGS were very conservative (-march=k8 -O2 -pipe)

All times are GMT -5. The time now is 11:48 PM.