LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 07-03-2009, 08:09 PM   #1
FlatBallFlyer
LQ Newbie
 
Registered: Jul 2009
Location: Asheville NC
Posts: 6

Rep: Reputation: 0
Smile ./network start shows error RTNETLINK answers: File exists Error adding address [ip]


I'm only partially new to Linux. I'm running Fedora 11. I've just set up two machines, I thought to be identical. Evidently I missed something. I had some problems getting the network started on the second machine, and I must have forgotten a name change somewhere. Anyway, after doing lot's of comparisons between the boxes, editing and renaming and re-linking the ifcfg-GigaStorey file, they are both functioning. The problem is that whenever I start or restart the network on box 2, it reports the following error:

Bringing up interface GigaStorey: RTNETLINK answers: File exists
Error adding address 192.168.1.6 for eth0.
[ OK ]


The file ifcfg-GigaStorey is linked in the following directories
/etc/sysconfig/network-scripts
/etc/sysconfig/networking/devices
/etc/sysconfig/networking/profiles/default


The contents of the file on box 2 (error) are:
# Networking Interface
DEVICE=eth0
HWADDR=00:10:C6:A3C:C7
ONBOOT=yes
IPADDR=192.168.1.6
BOOTPROTO=none
NETMASK=255.255.255.0
TYPE=Ethernet
GATEWAY=192.168.1.1
DNS1=192.168.1.1
IPV6INIT=no
USERCTL=no
PREFIX=24
NAME="System eth0"
UUID=52c359b4-bce1-4ee9-49f8-1928b302e041


The same file on box #1 (No errors here) is:
# Networking Interface
DEVICE=eth0
HWADDR=00:10:C6:B2:5D:F8
ONBOOT=yes
IPADDR=192.168.1.5
BOOTPROTO=none
NETMASK=255.255.255.0
TYPE=Ethernet
GATEWAY=192.168.1.1
DNS1=192.168.1.1
IPV6INIT=no
USERCTL=no
PREFIX=24
NAME="System eth0"
UUID=5fb06bd0-0bb0-7ffb-45f1-d6edd65f3e03


Like I said, it's not super critical, just annoying. The networking comes up ok, but the error is puzzling. I figure if I learn what this problem is I'll be one step closer to my Linux beanee. As always, the fates will smile on you for your gracious help!
 
Old 07-04-2009, 12:29 AM   #2
f14f21
Member
 
Registered: Sep 2008
Distribution: rhel
Posts: 42

Rep: Reputation: 6
the problem is between 2 services [network],[NetworkManager]

u should use either of these Modes :
a. GUI mode
#chkconfig --level 35 NetworkManager on
#chkconfig --level 0123456 network off

#/sbin/service NetworkManager stop
#/sbin/service network stop

#/sbin/service NetworkManager start

b. CONSOLE mode
#chkconfig --level 35 network on
#chkconfig --level 0123456 NetworkManager off

#/sbin/service NetworkManager stop
#/sbin/service network stop

#/sbin/service network start

Last edited by f14f21; 07-04-2009 at 12:30 AM.
 
Old 07-04-2009, 06:49 AM   #3
FlatBallFlyer
LQ Newbie
 
Registered: Jul 2009
Location: Asheville NC
Posts: 6

Original Poster
Rep: Reputation: 0
Thanks f14f21, this fixed the problem right away. I reviewed the man pages for chkconfig and I think I have a better understanding now. Service priority seems to be obvious (order in which services are brought up or down?) Runlevel is a bit more perplexing, I've reviewed the man pages for shutdown, which is where I expected to find an option to re-boot at a specific runlevel, but nooooo I miss-guessed, but hey, that's what man pages are for. While the man pages make reference to runlevel, there doesn't seem to be an option. I also looked over the man pages for init, telinit, and runlevel. My questions are: What is the "regular" uses of the various priorities and runlevels? and How do I set the runlevel for the next reboot? If you don't have time to write out a lengthly answer, but can refer me to some documentation, I can rtfm.

Thanks
FlatBallFlyer
 
Old 07-07-2009, 12:40 PM   #4
FlatBallFlyer
LQ Newbie
 
Registered: Jul 2009
Location: Asheville NC
Posts: 6

Original Poster
Rep: Reputation: 0
Duuuhhhh, let's all say it together, "I should always check Wikipedia first" - They have a pretty good explanation of runlevel and how/why it works.
 
Old 09-27-2010, 07:15 PM   #5
NPH0RM
LQ Newbie
 
Registered: Apr 2009
Location: Hagen, Germany
Distribution: Slackware
Posts: 3

Rep: Reputation: 0
Hi,

i am using archlinux and i have the same error and have to manually execute "netcfg wpa_suppl" after boot. how can i fix it, so it starts automatically?

here are the files:
http://paste.pocoo.org/show/268283/
http://paste.pocoo.org/show/268285/

best regards
Rome

edit: problem solved! removed "network" from daemons.

Last edited by NPH0RM; 09-27-2010 at 08:03 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] RTNETLINK answers: File exists - Error when doing ifup on alias (eth1:1) on RHEL5 MensaWater Linux - Networking 17 04-12-2015 07:32 AM
RTNETLINK answers: File exists Winanjaya Linux - Networking 5 06-24-2014 05:22 AM
bringing up interface eth1 rtnetlink answers file exists, error adding address homyangcha Linux - Newbie 7 10-20-2010 11:40 PM
fc9 booting Bringing up interface eth0: RTNETLINK answers: File exists pankajd Linux - Software 0 11-27-2008 08:33 AM
server ifup: RTNETLINK answers: Network is unreachable problem evasion81 Linux - Networking 5 07-07-2005 08:44 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 08:28 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration