-   Linux - Networking (
-   -   Network problems with bittorrent / azureus (

pim42 11-14-2004 01:39 PM

Network problems with bittorrent / azureus
This problem right now is driving me nuts. I've been using Linux lightly for awhile now, but have finally started using it on my desktop as my main OS. This is the one problem preventing me from using Linux exclusively.

Here is what I got:
SUSE 9.1 Linux version 2.6.5-7.111-default (geeko@buildhost) (gcc version 3.3.3 (SuSE Linux)) #1 Wed Oct 13 15:45:13 UTC 2004
KDE 3.3.1
Sun Java2-jre 1.4.2

The problem:
My network connection dies soon after starting a torrent. I think it is related to the upload, rather than download. There have been a few torrent that completed, but with abysmal share ratios. I've tried many different settings for Azureus including severely limiting my upload & download bandwidth and alternative socket pooling. My cable modem is not the problem. In windows it works fine and in linux The problem is fixed (for a bit) with rebooting my computer. I have tried disabling the SUSE firewall. At least I think it is, I disabled it in YaST. I think the problem might be with some of my TCP/IP settings but I don't have the first clue on how to change these. I have IPv6 enabled, I'm going to turn that off see if it fixes anything, doubt it.

Anybody got a clue to what is causing the problem, and how to fix it?

Dillius 03-15-2005 02:44 PM

I am having the exact same problem, would love to see some information regarding this.

MarkKingMinuet 03-16-2005 12:15 PM

Torrenting in Linux

You should get a static IP address so that you can be seen on the IP without having a different IP address everytime you try to use Azureus. Do you have at least two NICs in your Linux box??? That would be handy so that it acts as your gateway to the internet. Do you have an internal network set up?

Hope this helps!

Mark King MCP
Marketing Manager
Minuet Internet Services

Dillius 03-17-2005 08:31 AM

I am behind a router, but it's on a static IP and my IP within the subnet does not ever change.

This problem is quite an annoyance. Would still like to hear from any other people who may have dealt with this.

benjithegreat98 03-17-2005 03:42 PM

You need to forward the bittorrent ports to your computer from the router. The ports are these:

Dillius 03-17-2005 04:16 PM

Already have. I also have UPnP enabled, still no dice.

All times are GMT -5. The time now is 07:58 PM.