-   Linux - Networking (
-   -   Network problem with Suse 10.0 on Sony Vaio laptop (

athv_gr 10-25-2005 08:55 AM

Network problem with Suse 10.0 on Sony Vaio laptop
I have a Sony Vaio laptop on which I had until recently Suse 9.2. I updated to Suse 10.0 and I have a strange problem with the network.
During the installation the network was fine (It even did online update). When the graphic environment starts the network seems to die. If I start Suse in command prompt only (Runlevel 3) the network is fine. However, when running in Runlevel 5 (with KDE) the network does not work. The strange thing is that during the boot process no warning messages appear and I even get assigned with an IP address (I use DHCP).
Even if I use static IP the problem is the same. I also did a new installation of Suse 10.0 (formatted everything that existed before) but the problem remains.
The firewall is not running (I have it disabled).
Any ideas on the problem?

Keruskerfuerst 10-25-2005 09:14 AM


open a console and enter "ifconfig".

You should take a look at /var/log/messages or /var/log/warn.


athv_gr 10-25-2005 09:38 AM

I tried 'ifconfig' but I don't know what to look for in /var/log/messages or /var/log/warn. In /var/log/messages there are some errors about ACPI, but I don't find something that explains the cause of the problem for the network. Do you think that ACPI errors can be related with my problem? Thanks!

Gray345 11-15-2005 09:39 AM

Network problem with Suse 10.0 on Sony Vaio laptop
Just to let you know that I have had this problem on a Sony 'lugtop' PCG-GRT896HP when installing SuSE10.
All worked well during the install, then I did the online updates and the network stopped.
The solution was to edit /etc/modprobe.conf and '#' out the two lines containing sonypi
# alias char-major-10-250 sonypi
# options sonypi minor=250
I rebooted and the network came back to life.
Hope this helps.

athv_gr 11-15-2005 09:50 AM

Thanks for your answer! Because I could not figure out what the problem was, I switched back to Suse 9.2. If I have time may I will try reinstalling Suse 10. But, thanks anyway!

baronlynx 01-20-2006 05:11 PM


i have had the same problem. i have figured out that it happens in the moment you update whether the kernel or kde main package, but i have had no chance in finding what causes it directly?
i will give a try Grays idea tonight.

All times are GMT -5. The time now is 06:50 AM.