LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 02-24-2003, 10:46 AM   #1
Mighty_Viking
LQ Newbie
 
Registered: Feb 2003
Posts: 21

Rep: Reputation: 15
network ok but no internet


Hi

I have just installed the network on my linux machine, and i can ping the other PC in my network and my dns server, but i can't start the internet.
how come ?

Thanks
Mikkel
 
Old 02-24-2003, 10:55 AM   #2
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,696

Rep: Reputation: 232Reputation: 232Reputation: 232
What kind of connection you have? Modem, ADSL, other?
Have you set your default gateway?
 
Old 02-24-2003, 10:01 PM   #3
MikeT
LQ Newbie
 
Registered: Jan 2003
Location: Texas
Distribution: RH 7.2
Posts: 20

Rep: Reputation: 0
What distro are you using?
 
Old 02-25-2003, 05:32 PM   #4
kc8tbe
Member
 
Registered: Feb 2003
Location: Cleveland, Ohio (USA)
Distribution: Gentoo, Kubuntu 6.06
Posts: 179

Rep: Reputation: 30
Exclamation network ok but no internet

I'm having the same problem myself!

I am running Red Hat 8.0 (Psyche). My wireless lan card is the MA311 (by Netgear) and the router it is connected to is the MR814 (also by Netgear). From linux, I can access all computers hooked up to the local network - I can even log into the router and play with its settings! I cannot, however, access the internet.

Yes, I have tried using the actual IP addresses of servers rather than their domain names. No affect. Yes I have tried pinging servers outside my local network rather than http'ing to them. I receive no response. Yes I also have a wired ethernet card (by Realtek) and yes it is disabled on startup.

I am running a custom kernel I have compiled on my sytem. I got my pci wlan card to work by installing the three appropriate rpm's (found at http://prism2.unixguru.raleigh.nc.us/rh80/index.html) and then downloading and building the prism2_pci module (found at ftp://ftp.linux-wlan.org/pub/linux-w...6-pre10.tar.gz). Perhaps this is the cause of the problem...?

Incidentally, I cannot connect to the router using DHCP - I must manually specify an IP address and SSID, although if I connect to the router through my wired ethernet card, DHCP and the internet work. Also, I my machine is a dual-boot. The card works fine under Windows 98. I have no http proxy settings defined under Windows or Linux.

This sound anything like your setup?
Thanks in advance for any help!

-kc8tbe

Last edited by kc8tbe; 02-27-2003 at 05:44 PM.
 
Old 02-27-2003, 12:51 PM   #5
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,696

Rep: Reputation: 232Reputation: 232Reputation: 232
Do you have the default gateway set? It should be set to your router IP.
 
Old 02-27-2003, 06:00 PM   #6
kc8tbe
Member
 
Registered: Feb 2003
Location: Cleveland, Ohio (USA)
Distribution: Gentoo, Kubuntu 6.06
Posts: 179

Rep: Reputation: 30
Thanks, Mara. Truthfully, I have very little concept of what I am doing. My wireless device is configured as "wlan0". I think the following file defines the gateway (the comments were added by me):
Filename: /etc/sysconfig/network-scripts/ifcfg-wlan0

DEVICE=wlan0
ONBOOT=yes
BOOTPROTO=static #DHCP hasn't been working
IPADDR=192.168.0.3 #I've configured my router to reserve this address for my machine
GATEWAY=192.168.0.1 #This is the same ip address I use to configure the router
NETMASK=255.255.255.0
NETWORK=192.168.0.0
BROADCAST=192.168.0.255
GATEWAYDEV=wlan0
TYPE=Ethernet
USERCTL=yes
PEERDNS=yes

I think the gateway is defined here, but perhaps I need to define it somewhere else as well...? Also, should the last two lines be altered since DHCP isn't working? I hope you can figure this out!

-kc8tbe
 
Old 02-28-2003, 04:08 PM   #7
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,696

Rep: Reputation: 232Reputation: 232Reputation: 232
It looks OK for me.
 
Old 03-02-2003, 08:35 AM   #8
kc8tbe
Member
 
Registered: Feb 2003
Location: Cleveland, Ohio (USA)
Distribution: Gentoo, Kubuntu 6.06
Posts: 179

Rep: Reputation: 30
How do I know wether or not my gateway is set correctly - is their a command I can use to determine what my current gateway settings are?
 
Old 03-02-2003, 09:30 AM   #9
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 270Reputation: 270Reputation: 270
Quote:
Originally posted by kc8tbe
How do I know wether or not my gateway is set correctly - is their a command I can use to determine what my current gateway settings are?
Type:

route

And it should display your default route which should be your router/gateway. Also make sure you have your default DNS server's listed in /etc/resolv.conf
 
Old 03-02-2003, 09:30 AM   #10
Crashed_Again
Senior Member
 
Registered: Dec 2002
Location: Atlantic City, NJ
Distribution: Ubuntu & Arch
Posts: 3,503

Rep: Reputation: 57
If you can access the internet then your gateway is set correctly. You defined what your gateway is in your /etc/sysconfig/network-scripts/ifcfg-wlan0:

GATEWAY=192.168.0.1 #This is the same ip address I use to configure the router
 
Old 03-02-2003, 10:39 AM   #11
kc8tbe
Member
 
Registered: Feb 2003
Location: Cleveland, Ohio (USA)
Distribution: Gentoo, Kubuntu 6.06
Posts: 179

Rep: Reputation: 30
Thank you Trickykid and Crashed_Again.

As you can see in my previous posts, my gateway is properly set in ifcfg-wlan0 but I cannot access the internet - only the local network.
Upon typing route I received the following output:

Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.0.0 * 255.255.255.0 U 0 0 0 wlan0
127.0.0.0 * 255.255.255.0 U 0 0 0 lo
default 192.168.0.1 0.0.0.0 UG 0 0 0 wlan0

(sorry I couldn't format the table better)

Does this look correct - and if not, how to I go about changing it?
Thanks again!

-kc8tbe
 
Old 03-02-2003, 10:52 AM   #12
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 270Reputation: 270Reputation: 270
Like I mentioned in my previous post, also make sure your DNS server entries are in /etc/resolv.conf file.

In this format of course without the [ ] around the IP adress of each DNS server:

nameserver [ First IP Address Of DNS ]
nameserver [ Second DNS IP Address ]
 
Old 03-02-2003, 11:07 AM   #13
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,696

Rep: Reputation: 232Reputation: 232Reputation: 232
The routing table is correct if 192.168.0.1 is the right IP (router). Check the DNSes as trickykid suggested.
 
Old 03-02-2003, 12:21 PM   #14
kc8tbe
Member
 
Registered: Feb 2003
Location: Cleveland, Ohio (USA)
Distribution: Gentoo, Kubuntu 6.06
Posts: 179

Rep: Reputation: 30
My router identifies my computer as being named "Jack" (this is its windows name). Just for poops and giggles, I changed my linux hostname to "Jack" - voilla! Now I can access the internet... but only through giving the browser the IP address of the site I want to view (previously, even this didn't work).

My resolv.conf file simply says:
search Jack
("Jack" used to be "localhost". Doesn't work either way.)

Also, since changing my hostname I get the following error from lpd on startup:
localhost Get_local_host: 'localhost' IP address not available!

I don't actually know the IP addressed of any nameservers. Should I use the IP address of my ISP, Ameritech?

nameserver 67.38.255.254
 
Old 03-02-2003, 12:31 PM   #15
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 270Reputation: 270Reputation: 270
Quote:
Originally posted by kc8tbe
My router identifies my computer as being named "Jack" (this is its windows name). Just for poops and giggles, I changed my linux hostname to "Jack" - voilla! Now I can access the internet... but only through giving the browser the IP address of the site I want to view (previously, even this didn't work).

My resolv.conf file simply says:
search Jack
("Jack" used to be "localhost". Doesn't work either way.)

Also, since changing my hostname I get the following error from lpd on startup:
localhost Get_local_host: 'localhost' IP address not available!

I don't actually know the IP addressed of any nameservers. Should I use the IP address of my ISP, Ameritech?

nameserver 67.38.255.254
Yes, it would be your ISP's DNS servers you are connected to, unless your running your own.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
network yes, internet no paracetamolo Linux - Wireless Networking 3 12-05-2005 04:44 AM
10.0 On network but cannot get internet hydro Mandriva 0 04-24-2004 07:36 PM
Internet and Network AbsoluteMonkey Linux - Networking 3 04-22-2004 02:52 AM
network/internet help Global_Throttle Linux - Software 1 03-19-2004 08:45 AM
No Internet/Network p1az Slackware 2 11-13-2003 04:21 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 09:24 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration