LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 12-03-2004, 11:09 PM   #1
Keith106
LQ Newbie
 
Registered: Nov 2004
Posts: 10

Rep: Reputation: 0
Network no-worko


I am starting a new thread because my previous comments were mixed in with a different thread that started out the same, but ended up differently. So let me state the problem again. I appreaciate the good comments and suggestions, but so far nothing has worked:

I installed Fedora Core 2. Installation seemed to go well, I can run all the game, but I can not access the network.

I have a home network running for 4 years. I have a Linksys router connecting the network to a cable modem. The addresses of this home network are 106.106.106.*. I could not get DHCP to work with FC2, so I instead hardcoded an IP address of 106.106.106.105 and 106.106.106.107. There are no other computers configured with this address. I have two other computers on the home network, both are Windows XP.

When I run /sbin/route I get:

Code:
$ route -n
106.106.106.0     |  0.0.0.0          | 255.255.255.0  
169.254.0.0       |  0.0.0.0          | 255.255.0.0
127.0.0.0         |  0.0.0.0          | 255.0.0.0
0.0.0.0           |  106.106.106.1    | 0.0.0.0
When I run /sbin/ifconfig I get:

Code:
eth0   Link encap:Ethernet HWaddr 00:C0:4F:93:86:4A
      inet addr:106.106.106.105  Bcast:106.106.106.255   Mask 255.255.255.0
      inet6 addr: fe80::2C0:4ffff:fe93:864a/64 Scope:Link
      UP BROADCAST RUNNING MULTICAST   MTU:1500   Metric:1
      RX packets:0 error:0 dropped:0 overruns:0 frame:0
      TX packets:0 errors:103415 dropped:0 overruns:0 frame:0
      collisions:0 txqueuelen:1000
      RX bytes:30769 (30.0 Kb)  TX bytes:0  (0.0b)
      Interrupt:11 Base Address:0xcc80

eth0:1   Link encap:Ethernet HWaddr 00:C0:4F:93:86:4A
      inet addr:106.106.106.107  Bcast:106.106.106.255   Mask 255.255.255.0
      UP BROADCAST RUNNING MULTICAST   MTU:1500   Metric:1
      RX packets:0 error:0 dropped:0 overruns:0 frame:0
      TX packets:0 errors:103415 dropped:0 overruns:0 frame:0
      collisions:0 txqueuelen:1000
      RX bytes:30769 (30.0 Kb)  TX bytes:0  (0.0b)
      Interrupt:11 Base Address:0xcc80


lo   Link encap:Local loopback
      inet addr:127.0.0.1 Mask 255.0.0.0
      inet6 addr: ::1/128  Scope:Host
      UP BROADCAST RUNNING MULTICAST   MTU:16436   Metric:1
      RX packets:6562 error:0 dropped:0 overruns:0 frame:0
      TX packets:6562 errors:0 dropped:0 overruns:0 frame:0
      collisions:0 txqueuelen:1000
      RX bytes:3537269 (3.3 Mb)  TX bytes:3537269 (3.3 Mb)
When I run /bin/lspci there are a number of entries, but most notably is one for the ethernet card:

Code:
00:11.1 Ethernet Controller: 3Com Corporation 3c905 100BaseTX [Boomerang]
When I run the network device control, I get Status=Active, Device=eth0 and Nickname=eth0. It claims that the network card is active

When I press configure, I get the Network Configuration window, showing again eth0 active, in the "hardware" panel it shows the 3c905 with a Status=ok. I have set up two DNS host to be the same as those settings on my windows machines. And the hosts tab is empty.

/etc/resolv.conf contains the addresses of the DNS machines I configured.

On of the windows machines on the local area network is 106.106.106.101. When I try to ping this address from the Linux machine, I get "Destination host unreachable". When I ping this same address from the other windows machine it works fine.

I checked the cables from the linux machine to the hub (Linksys router). When I disconnect the cable, the lights go out, when I reconnect, the assocaited indicator lights turn back on.

When I try to ping 106.106.106.105 or 106.106.106.107 from the windows machines, the request times out.

Before installing FC2 on the machine, I had windows 2000, and it worked with the network perfectly, so I know there is no hardware problem.

when i tail the /var/log/messages I get:

Code:
eth0: transmit error, Tx status 90.
Flags; bus-master 1, dirty 1(1) current 17(1)
Transmit list 0514a340 vs. 0714a2a0
... then a bunch of lines where length = status

other places in the log say:
NETDEV WATCHDOG: eth0: trasmit timed out
eth0: transmit timed out, tx_status 00 status e000
diagnostics: net 0cc0 media 8802 dma 00000000 fifo 8800
.....
I am not even attempting DNS names at this point, I am always using the IP address numbers that I mention above.

Any idea what to try next?
-Keith
 
Old 12-04-2004, 08:52 AM   #2
minrich
Member
 
Registered: Aug 2003
Location: Isles of Man & Wight
Distribution: See signature
Posts: 548

Rep: Reputation: 40
What is your Linksys Router IP - hopefully it is 106.106.106.1 !!!!

If so, I would suggest that you set the DNS's to the router IP, same with Default gateways. I recently had a problem with Suse 9.2 Pro which has a new (?) name for the default gateway 'Routing' - once I had set this to my default gateway I could surf the net and see my two Win2k machines and my WinXPpro machine. Please note that all my Linux machines run under VMware. I can't recall exactly what my setup entailed in my FC2 virtual machine, but I will check if you let me know.

Are you sure that your XP boxes are shared properly - have you edited your C:\Windows\System32\drivers\etc\hosts file - you need to add 106.106.106.106 <machinename> (leave a space between the IP address and the machine name) on the next line you should enter 106.106.106.107 <machine2name> ( I also have an uncommented (i.e. no #) line 127.0.0.1 (space) localhost. You may have to reboot the Windows machine for it to realize that it has these new settings.

You should then 'see' the XP boxes when you ping them from the FC2 box.

I presume that you will be setting up a Samba server on the FC2 box next !!!!

HTH
 
Old 12-04-2004, 11:25 AM   #3
jarib
Member
 
Registered: Jun 2003
Location: British Columbia
Distribution: Slackware
Posts: 112

Rep: Reputation: 15
You do know that 106 is not a private ip range. If you're using the router for an internal lan the ip should be non routable such as 192 or 10 Also why did you give eth0 2 ip addresses?
 
Old 12-04-2004, 09:17 PM   #4
Keith106
LQ Newbie
 
Registered: Nov 2004
Posts: 10

Original Poster
Rep: Reputation: 0
>> What is your Linksys Router IP - hopefully it is 106.106.106.1 !!!!
Yes it is. But I am not yet at the stage of testing routing to the external Internet. I am just trying to get the card to work with other computers on the local lan.

>> Are you sure that your XP boxes are shared properly?
>>I would suggest that you set the DNS's to the router IP
At this point I am sticking with numeric IP addresses. That has to work, before any of the names will work. Editing the hosts file will give a name to the address, which I will look into once I can see that the network card is working. Setting the DNS addresse will help in resolving names, but again I am not using names yet.

>> I presume that you will be setting up a Samba server
Yes this is my intent. But I have to see ping work first.

>> You do know that 106 is not a private ip range
Yes I do. It is a quirk of mine to use this range. It has been working for 4 years, and there is no reasons that it should not work, except if I try to contact the computers on the "real" 106 range. I know I am taking that chance.

>> Also why did you give eth0 2 ip addresses
When I installed FC2 it automatically created the two, I don't know why. I have deactivated and reactivated various combinations of these, but I get the same results. At one point I deleted the second, but no difference.

Thanks for the input, but I need some sort of diagnostic that is telling me why the OS is not talking to the network card, when it says that everything is configured OK. I should mention that pinging localhost and pinging the addresses I have configured for this machine works, but pinging of anything outside of this machine always says it is unreachable.
 
Old 12-05-2004, 02:16 AM   #5
bdogg
Member
 
Registered: Sep 2004
Location: Salt Lake City, UT
Distribution: Debian Sarge
Posts: 93

Rep: Reputation: 15
This the open source community! Conform now! There is no room for personal quirks in this eniron....

oh....wait....
 
Old 12-05-2004, 06:03 AM   #6
skint
LQ Newbie
 
Registered: Dec 2004
Distribution: Suse / Fedora
Posts: 7

Rep: Reputation: 0
Keith

I have exactly the same problem with Fedora Core 3 and Suse 9.1 (see my posting under Can't get network connectivity).

I've tried both DHCP with a Netgear Router (set to 192.168.x.x range) as well as static using the 10.x.x.x range and cannot get either system to work (I have two different computers 1 at home 1 at work, and both give the same symptoms).

If you manage to get it up and running, let me know how you did it.

Skint
 
Old 12-05-2004, 09:02 AM   #7
minrich
Member
 
Registered: Aug 2003
Location: Isles of Man & Wight
Distribution: See signature
Posts: 548

Rep: Reputation: 40
This maybe a studid question - in the form of an answer - make sure that you have no firewalls, iptables etc. workinng and/or running as services. I know for a fact that Suse 9.2 and winXP SP2 enable firewalls automatically.

What make of nic card do you have?

Do you have a celeron (i.e. built-in wireless) processor? Perhaps, if you gave us an idea of the hardware that you are using we might be able to diagnose your blockage. I agree that pinging between machines is the first step.

Are you sure that you have no crossover cables iin your LAN?

Do you have a switch or hub in addition to your Linksys cable router? An idea of exactly how your boxes are connected may provide us with a clue.

Cheers
 
Old 12-05-2004, 08:35 PM   #8
Keith106
LQ Newbie
 
Registered: Nov 2004
Posts: 10

Original Poster
Rep: Reputation: 0
>> make sure that you have no firewalls, iptables etc. working

I ran "iptables -L" and for every case it said "ACCEPT". I am led to believe that this means that the firewall is disabled, but no one has actually confirmed this. Would you know for a fact that if it lists ACCEPT for every case, that this means packets are being allowed through?

>>What make of nic card do you have?
I believe it is on the motherboard, and describes itself as "3Com Corporation 3c905 100BaseTX".

>>Do you have a celeron (i.e. built-in wireless) processor?
No. It is a Dell desktop (floor top) computer, no wireless.

>>Are you sure that you have no crossover cables in your LAN?
Yes I am sure. When I had Windows running on this machine, the network using all the same hardware and cables worked perfectly.

>>Do you have a switch or hub in addition to your Linksys cable router?
The cable router is also a 100-base-T switch. I only have three computers plugged into it (2 windows, and 1 rather sick linux box)

Thanks for the ideas, but apparently this is a real common problem with Red Hat. I can see that Microsoft has nothing to fear from Linux -- and this is the most disappointing aspect of this problem.

-Keith

Last edited by Keith106; 12-05-2004 at 08:39 PM.
 
Old 12-05-2004, 09:51 PM   #9
minrich
Member
 
Registered: Aug 2003
Location: Isles of Man & Wight
Distribution: See signature
Posts: 548

Rep: Reputation: 40
Okay ... thanks for your answers ... I determined that it was time to crank up my FC2 virtual machine using 2.6.5 kernel.

Check on your System Settings > Server Settings > Services (if you are using KDE - I'm not sure of the gnome equivalents) scroll down to iptables and stop it if it is running. I do have netfs and network and nfslock running.
i alsoo have portmap, rhnsd,rpcgssd,rpcidmapd, and rpcsvcgssd running but I don't think they should affect your connection problems.
likewise 'services' and 'smb' and 'xinetd' running.

after you checked these services are/are not running open a terminal and type: ifconfig

on second line, you should see that eth0 is set to:

inet addr: 106.106.106.106 Bcast:106.106.106.255 Mask:255.255.255.0

if so you should be able to ping 106.106.106.xxx where 'xxx' is the specific address of each or either of the windows boxes ( [Ctrl]+C to terminate.

Let us know how it goes
 
Old 12-06-2004, 03:26 AM   #10
Draygo
Member
 
Registered: May 2004
Location: Frisco, TX
Distribution: Debian Unstable
Posts: 73

Rep: Reputation: 15
Dumb question but what is your subnet mask on your windows machine?
 
Old 12-06-2004, 03:34 AM   #11
skint
LQ Newbie
 
Registered: Dec 2004
Distribution: Suse / Fedora
Posts: 7

Rep: Reputation: 0
Checked firewall, appears to be off (service stopped)

Running ifconfig produces expected result - IP address, netmask, MAC address etc.

Pinging local NIC statically assigned address (10.0.0.1 in this case) produces expected response.

Pinging IP address of other device on same network (10.0.0.2 connected by HUB) produces Destination Host unreachable.

Pinging IP address of linux host (10.0.0.1 from Windows XP 10.0.0.2) produces Destination Host Unreachable.

At this point I'm lost for ideas and so might try and reinstall an earlier distro that I know I have had working in the past.

I have same NIC as Keith - 3Com 3C 509 Boomerang - It works when the same computer is booted into Windows.

Any other suggetstions greatfully received
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Fedora C2 - Wireless network drivers? Broadcom 802.11g Network Adapter FragTek Linux - Wireless Networking 7 01-22-2010 01:10 AM
3c905C network card in docking station. Cannot activate network device eth0. pathelms Linux - Networking 4 04-12-2006 03:55 PM
Network speed problems on 15 user network to broadband wireless router AntWarrior Linux - Wireless Networking 2 12-02-2004 12:05 PM
CD Burner no worko in RedHat 9 newlinuxjunkie Linux - Newbie 13 09-03-2003 12:23 PM
Newbie wanna setup up a linux network on existing home network... marvc Linux - Networking 3 03-19-2003 10:02 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 11:24 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration