-   Linux - Networking (
-   -   Network-manager motor is running...who's driving? Not me. (

lumix 10-30-2008 07:29 AM

Network-manager motor is running...who's driving? Not me.
Installed and (uninstalled and) reinstalled network-manager. No steering wheel. Tried running every process that begins with "network-manager..." but still no interface, no icon, etc. And documentation?

indienick 10-30-2008 08:56 AM

Try running "nm-applet". :)

lumix 10-30-2008 10:58 AM

Yeah...tried that too. Thanks for the suggestion though. It says something along the lines of:


** (nm-applet:24251): WARNING **: <WARN> applet_dbus_manager_start_service(): Could not acquire the NetworkManagerUserSettings service as it is already taken. Return: 3

(nm-applet:24251): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed
Or something to that effect.

indienick 10-30-2008 02:52 PM

Okay - try killing all nm-applet instances, and re-running it:

$ sudo killall nm-applet
$ nm-applet

lumix 10-30-2008 03:23 PM

Thanks. What a lame-brain I am for not trying that first. It might be worth noting for others that in order to start it without being tethered to a terminal screen, "nohup nm-applet" will do the trick, though perhaps there is a better way.

Now the question is, should this not show up in every user's system tray?

indienick 10-30-2008 03:53 PM

More than likely - simply because nm-applet assumes control of all of your networking. It would be much like the Windows system tray and network tray icons combination.

All times are GMT -5. The time now is 11:07 AM.