LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 07-17-2004, 01:24 PM   #1
chop
LQ Newbie
 
Registered: Jun 2004
Location: norway
Distribution: tsl 2.1
Posts: 18

Rep: Reputation: 0
Network issue


Hi!

I have set up dhcpd on my webserver, on the 192.168.100 range.
The server gives ip's from 192.168.100.2, to 192.168.100.5
My fileserver gets an ip easily, but my windowsmachine won't get an ip.
I can't find the servers if i set the ip to 192.168.100.10 either.

What could be the problem?

Thanks to all who tries to help
 
Old 07-17-2004, 01:27 PM   #2
yongbeng
LQ Newbie
 
Registered: May 2003
Posts: 15

Rep: Reputation: 0
what is your windows OS?is the NIC on windows working at all? did you try to do a ping from the windows machines? there are many possibilities I suppose..I would advice you can try to ping from the windows machines which is not getting the IP range from the linux server. But do remember to do a manual configuration of the IP on the windows machines b4 pinging. then see if it works.
 
Old 07-17-2004, 01:30 PM   #3
chop
LQ Newbie
 
Registered: Jun 2004
Location: norway
Distribution: tsl 2.1
Posts: 18

Original Poster
Rep: Reputation: 0
I'm using windows2000, and yes, the NIC is working fine.
I can't find any of the servers if i try pinging from my machine, with 192.168.100.10 manually configured.
 
Old 07-17-2004, 04:22 PM   #4
chop
LQ Newbie
 
Registered: Jun 2004
Location: norway
Distribution: tsl 2.1
Posts: 18

Original Poster
Rep: Reputation: 0
Now i have the following configuration:

Server with two nics, one connected to the dsl-modem and one to the 100mbit-switch. How can i share the internet with iptables to the local network?
The local network is eth1, internet is eth0
 
Old 07-17-2004, 06:48 PM   #5
chop
LQ Newbie
 
Registered: Jun 2004
Location: norway
Distribution: tsl 2.1
Posts: 18

Original Poster
Rep: Reputation: 0
*bump*
 
Old 07-17-2004, 11:51 PM   #6
interOperate
LQ Newbie
 
Registered: Jul 2004
Location: Australia
Distribution: Fedora 21
Posts: 22

Rep: Reputation: 15
network issue

Chop > it's a little confusing because you seem to be using different terminology for both the same, and different systems.

Please outline again the names of the various machines, what OS they are running, and how many NICs they have.

If I have understood correctly, the problem windows machine seems to have two NICs, and perhaps the default route is set for the Internet and not your internal LAN.
 
Old 07-17-2004, 11:59 PM   #7
chop
LQ Newbie
 
Registered: Jun 2004
Location: norway
Distribution: tsl 2.1
Posts: 18

Original Poster
Rep: Reputation: 0
Chise (Server) - two NICs, both 8139too
Aoi (Fileserver) - one NIC, Sis900

Windows 2000 - one NIC, via-rhine

Both the servers are running trustix 2.1

The windows machine had one of the NICs in the webserver, but i uninstalled it before unplugging, so there shouldnt be a problem
 
Old 07-18-2004, 07:29 AM   #8
chop
LQ Newbie
 
Registered: Jun 2004
Location: norway
Distribution: tsl 2.1
Posts: 18

Original Poster
Rep: Reputation: 0
I think maybe i've misconfigured dhcp, because i'm easily getting an ip from my isps dhcp-server. Here's the configuration:

Code:
ddns-update-style interim;

#subnet 81.191.15.0 netmask 255.255.255.0 {
#        not authoritative;
#}

subnet 192.168.100.0 netmask 255.255.255.0 {
        authoritative;
        option routers                  192.168.100.1;
        option subnet-mask              255.255.255.0;

#        option nis-domain               "chopped.net";
#        option domain-name              "chopped.net";
        option domain-name-servers      62.101.193.44, 217.118.32.13;

        option time-offset              1;
#       option ntp-servers              192.168.1.1;
        option netbios-name-servers     192.168.100.1;
        next-server     192.168.100.1;
        filename        "pxelinux.0";
#       option netbios-node-type 2;

        range dynamic-bootp 192.168.100.2 192.168.100.10;
        default-lease-time 21600;
        max-lease-time 43200;

        host aoi {
                hardware ethernet 00:0E:A6:XX:XX:XX;
                fixed-address 192.168.100.2;
        }
But then, why would aoi get an ip ?

Edit: I've tried running dhcpd -d -f, and this is what i get when my windowsmachine is trying to get an ip:
DHCPDISCOVER from 00:50:8d:xx:xx:xx via eth1
DHCPOFFER on 192.168.100.10 to 00:50:8d:xx:xx:xx via eth1

However, when i'm not setting the network-card to auto-negoating, no output will come. I have to set it to auto-negoate

Last edited by chop; 07-18-2004 at 09:08 AM.
 
Old 07-18-2004, 11:42 AM   #9
chop
LQ Newbie
 
Registered: Jun 2004
Location: norway
Distribution: tsl 2.1
Posts: 18

Original Poster
Rep: Reputation: 0
Mhh, think i'll lay dhcpd on ice until i get this shit working.

Could anybody please give me some ifcfg-ethX examples for a static 192.168.X.X ip with netmask, gateway, broadcast etc, and a windows-configuration suited for it? I've tried many times here myself, but i can't ping either of my servers, but they can ping eachother.
 
Old 07-18-2004, 06:41 PM   #10
interOperate
LQ Newbie
 
Registered: Jul 2004
Location: Australia
Distribution: Fedora 21
Posts: 22

Rep: Reputation: 15
A few things to try

Chop, a few things you can try (in no special order):

1) You've said that you cannot ping from the Windows machine to either of the Linux boxes. But when you've set a static IP on the Windows machine, can either of the Linux machines ping the Windows machine?

2) Are you running a Firewall on the WIN2K machine, such as ZoneAlarm?

3) From what I remember, Trustix is a high security Linux, therefore you may have iptable rules set on the Linux machines that is blocking communications from the Windows machine. Have you checked this issue?

4) It sounds like the DHCP client is working okay, but best to double-check under the Windows Services that DHCP is indeed enabled.

5) When you configure a static IP address on the Windows box, does it hold the info after a reboot?

6) Re the IP configuration, if you set the IP info manually to say:
IP ADDRESS: 192.168.100.11
NETMASK: 255.255.255.0
GATEWAY: will be the 192.168.100.x IP address of the NIC on Chise

7) Change the line in your dhcp-server:
range dynamic-bootp 192.168.100.2 192.168.100.10;
because I think you're already using 192.168.100.2 for another NIC, and such can cause an IP conflict
 
Old 07-19-2004, 01:57 PM   #11
chop
LQ Newbie
 
Registered: Jun 2004
Location: norway
Distribution: tsl 2.1
Posts: 18

Original Poster
Rep: Reputation: 0
I took one of the NICs from my webserver, and now it's working fine.
Seems like the onboard VIA Rhine is the culprit
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
crazy network issue aweber1nj Linux - Networking 4 10-16-2005 03:27 PM
security issue? network casey24601 Linux - Security 2 11-04-2004 05:56 PM
Network issue Conkie Linux - Networking 2 10-24-2004 11:39 PM
network issue abulafiar Linux - Software 1 08-07-2004 12:44 AM
Network Issue Neur0tek Linux - Newbie 7 05-01-2002 06:24 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 10:03 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration