LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 06-15-2015, 12:17 PM   #1
Zarathuztra
LQ Newbie
 
Registered: Mar 2015
Posts: 7

Rep: Reputation: Disabled
Question Network is unreachable, ubuntu server 14.04, running on Wireless LAN


EDIT NOTE: Original subject was incorrect. replaced "WAN" with "Wireless LAN"

For Solution see post #8

Running Ubuntu server 14.04 and experiencing network problem. I have it on a PC that is connecting to Wireless LAN. All goes well during install, tests and connects with no issue. But once I get on it after installation is done and I try to ping my result is... *connect: network is unreachable*

Not sure where to begin with this. Does a driver need to be installed for it to work properly?

My ISP is verizon Fios, Modem/Router is Actiontec MI424WR

Code:
    blahblah@server01:~$ ifconfig -a
    eth0       Link encap:Ethernet HWaddr fc:aa:14:57:34:86
               BROADCAST MULTICAST  MTU:1500  Metric:1
               RX packets:0 errors:0 dropped:0 overruns:0 frame:0
               TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
               collisions:0 txqueuelen:1000
               RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

    lo         Link encap:Local Loopback
               inet addr:127.0.0.1  Mask:255.0.0.0
               inet6 addr: ::1/128 Scope:Host
               UP LOOPBACK RUNNING  MTU:65536  Metric:1
               RX packets:32 errors:0 dropped:0 overruns:0 frame:0
               TX packets:32 errors:0 dropped:0 overruns:0 carrier:0
               collisions:0 txqueuelen:0
               RX bytes:2480 (2.4 KB)  TX bytes:2480 (2.4 KB)

    wlan0      Link encap:Ethernet  HWaddr 68:1c:a2:01:f0:1b
               BROADCAST MULTICAST  MTU:1500  Metric:1
               RX packets:0 errors:0 dropped:0 overruns:0 frame:0
               TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
               collisions:0 txqueuelen:1000
               RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

    blahblah@server01:~$ lshw -c network
    WARNING: you should run this program as super-user.
      *-network DISABLED
           description: Ethernet interface
           product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           vendor: Realtek Semiconductor Co., Ltd.
           physical id: 0
           bus info: pci@0000:02:00.0
           logical name: eth0
           version: 0c
           serial: fc:aa:14:57:34:86
           size: 10Mbit/s
           capacity: 1Gbit/s
           width: 64 bits
           clock: 33MHz
           capabilities: bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
           configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half latency=0 link=no multicast=yes port=MII speed=10Mbit/s
           resources: irq:54 ioport:d000(size=256) memory:fe900000-fe900fff memory:d0000000-d0003fff
      *-network DISABLED
           description: Wireless interface
           product: AR9485 Wireless Network Adapter
           vendor: Qualcomm Atheros
           physical id: 0
           bus info: pci@0000:03:00.0
           logical name: wlan0
           version: 01
           serial: 68:1c:a2:01:f0:1b
           width: 64 bits
           clock: 33MHz
           capabilities: bus_master cap_list rom ethernet physical wireless
           configuration: broadcast=yes driver=ath9k driverversion=3.16.0-30-generic firmware=N/A latency=0 link=no multicast=yes wireless=IEEE 802.11bgn
           resources: irq:17 memory:fe800000-fe87ffff memory:fe880000-fe99ffff
    WARNING: output may be incomplete or inaccurate, you should run this program as super-user.

Last edited by Zarathuztra; 06-15-2015 at 09:55 PM. Reason: Incorrect terminology
 
Old 06-15-2015, 12:45 PM   #2
suicidaleggroll
LQ Guru
 
Registered: Nov 2010
Location: Colorado
Distribution: OpenSUSE, CentOS
Posts: 5,569

Rep: Reputation: 2130Reputation: 2130Reputation: 2130Reputation: 2130Reputation: 2130Reputation: 2130Reputation: 2130Reputation: 2130Reputation: 2130Reputation: 2130Reputation: 2130
Why are you connecting to the WAN side?

You can't connect because you have no IP. What exactly are you trying to do? What do you want your network to look like?
 
Old 06-15-2015, 12:54 PM   #3
Zarathuztra
LQ Newbie
 
Registered: Mar 2015
Posts: 7

Original Poster
Rep: Reputation: Disabled
There is no hardline in the room where the PC is located, so it has to run off WAN. I plan to run ownCloud on the server once it is setup.
 
Old 06-15-2015, 01:01 PM   #4
suicidaleggroll
LQ Guru
 
Registered: Nov 2010
Location: Colorado
Distribution: OpenSUSE, CentOS
Posts: 5,569

Rep: Reputation: 2130Reputation: 2130Reputation: 2130Reputation: 2130Reputation: 2130Reputation: 2130Reputation: 2130Reputation: 2130Reputation: 2130Reputation: 2130Reputation: 2130
I think there's a problem with terminology.

WAN = wide area network. This is the "internet", where your machine has a public IP that anybody in the world can access.

LAN = local area network. This is the "intranet", where your machine has a private IP that only other machines on the LAN can connect to. You're "protected" by the firewall in the router. You can still access the internet, but the internet can't access you unless you let it.

It sounds like you're trying to use wireless/wifi. This is not "WAN", it's simply a "wireless LAN".

Are you using the GUI or CLI on your machine?
 
Old 06-15-2015, 02:14 PM   #5
Zarathuztra
LQ Newbie
 
Registered: Mar 2015
Posts: 7

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by suicidaleggroll View Post
I think there's a problem with terminology.

WAN = wide area network. This is the "internet", where your machine has a public IP that anybody in the world can access.

LAN = local area network. This is the "intranet", where your machine has a private IP that only other machines on the LAN can connect to. You're "protected" by the firewall in the router. You can still access the internet, but the internet can't access you unless you let it.

It sounds like you're trying to use wireless/wifi. This is not "WAN", it's simply a "wireless LAN".

Are you using the GUI or CLI on your machine?
You are correct, my terminology was wrong. I am using a Wireless LAN. I will correct the OP.

I'm using the CLI.
 
Old 06-15-2015, 02:48 PM   #6
JimKyle
Member
 
Registered: Dec 2001
Location: Oklahoma City, OK, USA
Distribution: Xubuntu 16.04 LTS
Posts: 214
Blog Entries: 1

Rep: Reputation: 39
Quote:
Originally Posted by Zarathuztra View Post
Not sure where to begin with this. Does a driver need to be installed for it to work properly?

My ISP is verizon Fios, Modem/Router is Actiontec MI424WR

Code:
    blahblah@server01:~$ ifconfig -a
    eth0       Link encap:Ethernet HWaddr fc:aa:14:57:34:86
               BROADCAST MULTICAST  MTU:1500  Metric:1
               RX packets:0 errors:0 dropped:0 overruns:0 frame:0
               TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
               collisions:0 txqueuelen:1000
               RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

    lo         Link encap:Local Loopback
               inet addr:127.0.0.1  Mask:255.0.0.0
               inet6 addr: ::1/128 Scope:Host
               UP LOOPBACK RUNNING  MTU:65536  Metric:1
               RX packets:32 errors:0 dropped:0 overruns:0 frame:0
               TX packets:32 errors:0 dropped:0 overruns:0 carrier:0
               collisions:0 txqueuelen:0
               RX bytes:2480 (2.4 KB)  TX bytes:2480 (2.4 KB)

    wlan0      Link encap:Ethernet  HWaddr 68:1c:a2:01:f0:1b
               BROADCAST MULTICAST  MTU:1500  Metric:1
               RX packets:0 errors:0 dropped:0 overruns:0 frame:0
               TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
               collisions:0 txqueuelen:1000
               RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

    blahblah@server01:~$ lshw -c network
    WARNING: you should run this program as super-user.

... eth0 removed ...

      *-network DISABLED
           description: Wireless interface
           product: AR9485 Wireless Network Adapter
           vendor: Qualcomm Atheros
           physical id: 0
           bus info: pci@0000:03:00.0
           logical name: wlan0
           version: 01
           serial: 68:1c:a2:01:f0:1b
           width: 64 bits
           clock: 33MHz
           capabilities: bus_master cap_list rom ethernet physical wireless
           configuration: broadcast=yes driver=ath9k 
driverversion=3.16.0-30-generic firmware=N/A latency=0 
link=no multicast=yes wireless=IEEE 802.11bgn
           resources: irq:17 memory:fe800000-fe87ffff memory:fe880000-fe99ffff
    WARNING: output may be incomplete or inaccurate, you should run 
this program as super-user.
The line I've put in red here tells you that the driver is already in place; the two WARNING lines that I've put into boldface tell you how to get more information from the "lshw" command.

When I was setting up wireless on a laptop for a friend, I had a very similar problem (although it wasn't even a Linux system) -- which turned out to be simply that the wireless capability of the laptop had been turned off! Locating the almost-hidden little switch that controlled it, and sliding it to the ON position, solved the problem. The "link=no" (in blue, above) makes me suspect that this might be the case for you!

Tell us the make and model of the laptop and we may be able to help you locate the switch; the one I encountered was from HP, and dates from the time before Windows 7. Its switch is on the front edge, toward the left side, with a tiny LED that shows blue when on or orange when off.

Last edited by JimKyle; 06-15-2015 at 02:51 PM.
 
Old 06-15-2015, 03:07 PM   #7
Zarathuztra
LQ Newbie
 
Registered: Mar 2015
Posts: 7

Original Poster
Rep: Reputation: Disabled
@JimKyle - I have a PC not a laptop that I'm working on, there is no switch I know of, and I had used the internet on it a couple days ago before I wiped the hdd and installed ubuntu server 14.04. So unfortunately the fix will be more than flicking a switch, I wish it were so simple.

I'm currently at work and unable to run the commands as SU, so I'll post the result later this evening.
 
Old 06-15-2015, 03:43 PM   #8
suicidaleggroll
LQ Guru
 
Registered: Nov 2010
Location: Colorado
Distribution: OpenSUSE, CentOS
Posts: 5,569

Rep: Reputation: 2130Reputation: 2130Reputation: 2130Reputation: 2130Reputation: 2130Reputation: 2130Reputation: 2130Reputation: 2130Reputation: 2130Reputation: 2130Reputation: 2130
Have you configured the interface to look for your SSID with your key?

eg:
http://askubuntu.com/questions/46450...-wpa2-personal
 
1 members found this post helpful.
Old 06-15-2015, 04:18 PM   #9
Zarathuztra
LQ Newbie
 
Registered: Mar 2015
Posts: 7

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by suicidaleggroll View Post
Have you configured the interface to look for your SSID with your key?

eg:
http://askubuntu.com/questions/46450...-wpa2-personal
This looks pretty similar to my issue, I will attempt this fix when I return home.
 
Old 06-15-2015, 09:53 PM   #10
Zarathuztra
LQ Newbie
 
Registered: Mar 2015
Posts: 7

Original Poster
Rep: Reputation: Disabled
Ok... I tried to follow the method from the above link (See posts #7 & #8). It worked. I'm able to connect now.

Thanks for the help.
 
  


Reply

Tags
network, ubuntu 14.04


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] /etc/init.d network dependent scripts running/failing at boot [on ubuntu server] pimanlives Linux - Newbie 5 03-15-2010 08:59 PM
ftp server unreachable outside of Network ServalSoft Linux - Networking 2 05-22-2009 02:29 PM
Network Unreachable on Ubuntu 7.04 glok_twen Linux - Networking 6 06-26-2007 02:43 PM
Ubuntu Dapper - network unreachable ipv6 server not found ~ganga~ Linux - Wireless Networking 1 01-14-2007 03:50 PM
server ifup: RTNETLINK answers: Network is unreachable problem evasion81 Linux - Networking 5 07-07-2005 09:44 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 02:51 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration