LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 07-07-2004, 03:39 PM   #1
kkallaur
LQ Newbie
 
Registered: Jul 2004
Posts: 6

Rep: Reputation: 0
Network is unreachable Fedora Core 2


To start with, I'm extremely new to Linux . I just installed Fedora Core2 and am having trouble getting my internet connection up and running via aDSL. I have a Linksys 100Tx NIC connecting to a Linksys BEFW11S4 router which in turn is connected a Netopia DSL Modem. The issue I am having is that I am unable to access anything on the web. I can ping the router and the remote address found in the system log but I can't ping outside of that . When I do something like ping 216.109.127.29 I get the error network is unreachable. When I did a Route -n I got the following results:

Code:
Destination      Gateway         GenMask               Flags      Metric  Ref   Use   Iface
68.77.203.252    0.0.0.0         255.255.255.255       UH         0       0      0     pp0
192.168.1.0      0.0.0.0         255.255.255.0         U          0       0      0     eth0
169.254.0.0      0.0.0.0         255.255.0.0           U          0       0      0     eth0
127.0.0.1        0.0.0.0         255.0.0.0             U          0       0      0     l0
The following is what I got with ifconfig -a:

eth0
Link encap: Ethernet
inet addr: 192.168.1.101 Bcast:192.168.1.255 Mask 255.255.255.0
inet 6 addr: fe80::20c:41ff:feef:f424/64 Scope: link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
Rx Packets: 489 errors: 0 dropped: 0 overruns: 0 frame: 0
Tx Packets: 473 errors: 0 dropped: 0 overruns: 0 carrier: 0
collisons: 0 txqueuelen: 1000
Rx Bytes: 36601 (35.7 kb) Tx Bytes: 16380 (15.9 kb)

lo
Link encap: Local Loopback
inet addr: 127.0.0.1 Mask: 255.0.0.0
inet6 addr: ::1/128 Scope: Host
UP LOOPBACK RUNNING MTU:16436 Metric: 1
Rx Packets: 3070 errors: 0 dropped: 0 overruns: 0 frame: 0
Tx Packets: 3070 errors: 0 dropped: 0 overruns:0 carrier: 0
collisions: 0 txqueuelen: 0
Rx Bytes: 2607798 (2.4 mb) Tx Bytes: 2607798 (2.4 mb)

ppp0
Link encap: Point to Point Protocol
inet addr: 68.77.202.101 P-t-P: 68.77.203.252 Mask: 255.255.255.255
UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1492 Metric:1
Rx Packets: 59 errors: 464 dropped: 0 overruns: 0 frame: 0
Tx Packets: 16 errors: 0 dropped: 0 overruns: 0 carrier: 0
collisions: 0 txqueuelen: 3
Rx Bytes: 8268 (8.0kb) Tx Bytes: 984 (984 b)

sit0
Link encap: IPv6-iniIPv4
NO ARP MTU: 1480 Metrics: 1
Rx Packets: 0 errors: 0 dropped: 0 overruns: 0 frame: 0
Tx Packets: 0 errors: 0 dropped: 0 overruns: 0 carrier: 0
collisions: 0 txqueuelen: 0
Rx Bytes: 0 (0.0 b) Tx Bytes: 0 (0.0 b)

Can anyone help me figure out what's going wrong? Thanks in advance


Ken
 
Old 07-07-2004, 04:07 PM   #2
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,696

Rep: Reputation: 232Reputation: 232Reputation: 232
You don't have a default gateway. To add it temporary use (I assume ppp0 is the right interface):
route add default ppp0
Does it work?
 
Old 07-07-2004, 05:14 PM   #3
kkallaur
LQ Newbie
 
Registered: Jul 2004
Posts: 6

Original Poster
Rep: Reputation: 0
Mara, it works like a charm!!! Now how can I get it so that the gateway is permanent? Thanks so much for your help.
Ken
 
Old 07-07-2004, 07:40 PM   #4
schurt
Member
 
Registered: Nov 2003
Location: raleigh, nc
Distribution: fedora, arch
Posts: 78

Rep: Reputation: 15
Quote:
Originally posted by kkallaur
Mara, it works like a charm!!! Now how can I get it so that the gateway is permanent? Thanks so much for your help.
Ken
in fc2, edit /etc/sysconfig/network and add the line GATEWAY=iphere

remember you only want the gateway listed once and this is best place to put it
 
Old 07-07-2004, 09:10 PM   #5
kkallaur
LQ Newbie
 
Registered: Jul 2004
Posts: 6

Original Poster
Rep: Reputation: 0
schurt,
I'm not sure I understand you I put the gateway command into /etc/sysconfig/network and rebooted. No gateway was added and had the same problems as before. I'm very new to Linux so I'm sure I'm just not understanding you correctly. Thanks,

Ken
 
Old 07-07-2004, 10:03 PM   #6
schurt
Member
 
Registered: Nov 2003
Location: raleigh, nc
Distribution: fedora, arch
Posts: 78

Rep: Reputation: 15
basically open your /etc/sysconfig/network file in your preferred text editor as user root

and at the end of the file add

GATEWAY=xxx.xxx.xxx.xxx

and restart your network, now also make sure you have ip_forward set to 1 in your /etc/sysctl.conf file as well

a reboot shouldnt be necessary just a

service network restart

would be sufficient

hope this clears things up
 
Old 07-08-2004, 03:42 PM   #7
kkallaur
LQ Newbie
 
Registered: Jul 2004
Posts: 6

Original Poster
Rep: Reputation: 0
Schurt, it didn't work. I put in GATEWAY=192.168.1.1 in the /etc/sysconfig/network and changed the ip_forward to 1 in the /etc/sysctl.conf and did service network restart and no gateway is created. There are three entries in the network file:
NETWORK=yes
HOSTNAME=
GATEWAY=192.168.1.1

The ip_forward I changed in the sysctl.conf file was the net.ipv4.ip_forward line, it was the only one that came close, is that correct?

Again, thanks for the help, hopefully, I can get this thing to work.

Ken
 
Old 07-08-2004, 05:05 PM   #8
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,696

Rep: Reputation: 232Reputation: 232Reputation: 232
kkallaur, how have you configured your network settings? have you used Fedora's tools or you modified the configuration files manually?
 
Old 07-08-2004, 06:34 PM   #9
kkallaur
LQ Newbie
 
Registered: Jul 2004
Posts: 6

Original Poster
Rep: Reputation: 0
Mara, I used Fedora's tools. I'm completely brand new to linux, and I haven't a clue as to what I'm doing yet. I did find out that after I rebooted(restarting the network didn't ) schurts changes did create a gateway, the problem is it was to eth0 and not ppp0. with the gateway on eth0 I don't get the network is unreachable error, but I also don't get anything when I ping, it just sits there. So, I guee my question is how do I get the gateway to connect to the right device?
Thanks, Ken
 
Old 07-09-2004, 04:48 PM   #10
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,696

Rep: Reputation: 232Reputation: 232Reputation: 232
If you're using Fedora tools there's probably an easier way to set it up than to modify the configuration files. But I don't know Fedora, so can't tell you where to click.
There's an option in /etc/sysconfig/network that may make it work correctly for you. Add
GATEWAYDEV=ppp0
 
Old 07-09-2004, 09:14 PM   #11
kkallaur
LQ Newbie
 
Registered: Jul 2004
Posts: 6

Original Poster
Rep: Reputation: 0
Mara,
Thanks for your help!! I found GATEWAYDEV earlier today, but it didn' work. So what I did, being that this was a new install, I reinstalled then in the network scriot for the ppp0 device I added GATEWAY=0.0.0.0 restarted the network and it worked!!! So I'm now up and running and ready to start learning Linux. Again, thank you Mara and also Schurt for the help.

Ken
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
fedora core network skyyfox Fedora 6 12-04-2005 06:11 AM
No network activity in FEDORA CORE 2. mir_sheely Linux - Networking 11 01-09-2005 01:47 PM
Network - Fedora Core 2 thejackal13 Linux - Networking 9 12-28-2004 02:23 PM
Fedora Core 2 Network Issue gatoral65 Linux - Hardware 1 09-24-2004 04:35 PM
No network Fedora Core 2 angel.at Linux - Networking 6 08-23-2004 04:31 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 12:15 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration