-   Linux - Networking (
-   -   Network exists, eth0/route/something fails (

43r05p4c3 06-29-2006 12:19 PM

Network exists, eth0/route/something fails
Hey all,

I've managed to connect two computers via xover cable (client is Gentoo laptop, server is Mandrake 10.0 desktop).
The network works since the computers can ping each other, but when I try: mount x.x.0.2:/ /mnt/network
I get an error like RPC: no route to host
(or something to that effect, I don't have the exact message here right now)
Also, on the MDK server, during boot it fails to bring up eth0. Despite this, ifconfig shows eth0.

As far as the IP addresses, they should be set up properly...
gateway: x.x.0.1
server: x.x.0.2
client: x.x.0.3
broadcast: x.x.0.255

I'm not sure what troubleshooting commands you'll need since I haven't done much networking before, so let me know what you need to help solve this problem.

Thanks in advance,


PS how do you get the ping command to not go forever? I keep having to ctrl+alt+f2 and kill it manually...

michaelk 06-29-2006 12:57 PM

The c option allows for a fixed number of counts if not specified ping will operate until interrupted. Use ctrl-C to interrupt. See man pages for ping for
additional details.

Is NFS running on the server i.e. your MDK box?
Did you setup /etc/exports.
If the firewall is running does it allow NFS traffic.

43r05p4c3 06-29-2006 08:55 PM

Thanks for the help with ping (why is it the man pages make so much more sense when I already know what they mean?)

As far as NFS running, ps axu shows 8 processes called [nfsd] running.
I did setup /etc/exports:

/ x.x.0.3(ro)

where x.x is obviously the values I'm using for the network. I intend to adjust it later so I'm not sharing the entire drive, but for I figured it's easier to do this until I get some kind of results.

iptables is running, and may very well be the problem. I haven't changed anything from the system default. I know I can find out how to add rules from the man pages, but last time I tried to adjust the iptables rules (for the purposes of ssh) I succeeded only in stopping everything from coming in. (Actually I think I was permitting requests from a non-existant address but you can imagine how useless that was).

How should I tell iptables to allow NFS?

michaelk 06-29-2006 09:03 PM

Take a look at the howto.

43r05p4c3 06-30-2006 11:53 AM

Thanks a lot, I'll let you know how it works out

43r05p4c3 07-10-2006 01:06 PM

Ok, I've got things figured out now. Turns out my problem was even before configuring iptables. Apparantly I editted /etc/hosts.allow and /etc/hosts.deny wrong. I fixed it with the same howto:

I can now mount NFS. There is one problem left though. I need to know how to setup the default ip address for the Mandrake distro. I currently have to set it manually every time I boot.



All times are GMT -5. The time now is 08:57 AM.