Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back > Forums > Linux Forums > Linux - Networking
User Name
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.


  Search this Thread
Old 02-14-2010, 08:21 PM   #1
Registered: Aug 2005
Distribution: Debian Stable
Posts: 218

Rep: Reputation: 17
Network connections cut-out but pinging IP works: two lan cards+dhcp server+www

Alright, here is the ordeal...

Ethernet port (wired internet) <---> Desktop 1 <---> Server 1

Server 1 details:
Debian Linux box with DHCP3-server setup.
Gives Desktop 1 its IP address after IP request.
Desktop 1 connects to Server 1's SSH server.

Ethernet port details:
Comes from wall
Gives Desktop 1 it's wired connection

Desktop 1 details:
Main computer that connects to LCD monitor
Used to connect to Ethernet Internet and Server 1.
Runs using Windows XP and Debian Lenny

After connecting to the ethernet port and Server 1, Desktop 1 eventually cannot resolve dotcom addresses. A recent trial with pinging the IP address of google (74.something.something.something) allowed me to ping the website. As such, I have come to consider this is a DNS issue.

I have no clue as to why this is an issue. It makes NEGATIVE ONE sense to me.

It would appear that Windows XP does not have a problem with being assigned an IP address from the ethernet port nor from the Linux Server 1 computer AT THE SAME TIME. I want two cards working, but their getting their IP addresses from different setups. I don't know why Windows on the Desktop seems to be working ok and that when I use Debian Lenny on the Desktop things go down for me.

Weird DNS issue to say the least.
I'm not sure what to do.

I have forced a dhclient eth0 and dhclient eth1 in the rc.local script, so they do get their ip addresses at start. I've also uninstalled firestarter with the thought that it was messing with things. I also have disabled network manager, because it didn't like me using two cards at once. So, yes, rc.local is what's making things connect now. However, I'm still getting some weird issue.

What's the solution, folks?

Last edited by Cyberman; 02-14-2010 at 08:22 PM.
Old 02-14-2010, 08:43 PM   #2
LQ Newbie
Registered: Sep 2001
Location: Portland, OR
Posts: 13

Rep: Reputation: 1
When your desktop stops resolving DNS names, what DNS server is it trying to use? If it is trying to use your Server1, is Server allowed to send Internet bound traffic through the desktop (is the desktop set up to allow routing between two networks)? Does server1 have a DNS server (or at least query forwarding) enabled?
Old 02-14-2010, 08:53 PM   #3
Registered: Aug 2005
Distribution: Debian Stable
Posts: 218

Original Poster
Rep: Reputation: 17
Server 1 does not act as a DNS server. It serves only to access as an SSH server from Desktop 1.
Desktop 1 and Server 1 are in the same room, as is the ethernet port.

I'm also noticing something funny.
Maybe someone can refresh my memory as to how Debian Linux works, because maybe someone just implemented something new in the Debian system.

Isn't rc.local suppose to be executed before GDM? Because it's not being executed before nautilus is done loading, which I thought it was suppose to be... hmm...

Anyway, I've been noticing that on startup that ethernet 1 is requesting an IP address but eth0 is not requesting an ethernet address. Furthermore, after forcing eth0 to get an address, it would appear that the resolv.conf turns toward wanting Server 1 (eth0 connects to Server 1) to resolve the DNS addresses.

I recently went to...

System > Administration > Network and signified some criteria for eth0.
I set a static IP and the netmask.
The dhcpd.conf on Server 1 is setup to give Desktop 1's eth0 card the static IP address.

I notice that eth1 does get the correct DNS server information in resolv.conf but once I start trying to get an IP address for eth0, it would appear that Desktop 1 thinks that Server 1 is the DNS server, which is just not right.

I've also begun to notice that rc.local is executed after nautilus loads. I thought it was the other way around: rc.local is executed before nautilus is executed. Either way, I suspect if I insert a "pkill gdm;gdm &" command into rc.local, then that should straighten things out.

Still, I think the Desktop's DNS confusion is odd, and I'm not sure if I'll have it solved after this rc.local alteration I'm about to commit.
Old 02-14-2010, 09:07 PM   #4
LQ Newbie
Registered: Sep 2001
Location: Portland, OR
Posts: 13

Rep: Reputation: 1
Server1's DHCPH config is over writing resolv.conf which gets back to my original question. Change the DHCPH config to not give out a DNS server. Are you using DHCP for experience? I don't see another point if there is only one client computer.
Old 02-14-2010, 09:30 PM   #5
Registered: Aug 2005
Distribution: Debian Stable
Posts: 218

Original Poster
Rep: Reputation: 17
Alright, I went into dhcpd.conf on Server 1 and disabled the DNS option.
I think that will make sure it doesn't move over to the Server 1's DNS property again.

Still, this rc.local issue is bothering me.
I'll have to figure that out next.
I think my issue is figured for now on the DNS ground.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Power-cut. If try pinging, get "connect: Network is unreachable" Azazwa Linux - Newbie 2 05-06-2009 12:35 AM
dhcp server with two network cards kashif2131971 Linux - Newbie 3 03-31-2008 07:41 AM
2 network cards, 2 network connections - routing problem tvojvodi Linux - Networking 4 02-24-2004 03:26 PM
www access 2 network cards mphanke Mandriva 5 08-26-2003 08:08 AM
DHCP server on two LAN cards V.krishna kumar Linux - Networking 3 10-24-2002 12:57 PM > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 11:04 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration