-   Linux - Networking (
-   -   network connection 'pauses'? (

rl5 10-26-2011 03:17 PM

network connection 'pauses'?
I'm having a difficult time finding a solution for this one and Google searches aren't much help. I'm running Debian Wheezy ( kernel) and my internet connection seems to "pause" when it starts a new connection. Here are several examples:

I click a link in a web browser and nothing happens for 10-20 seconds... then the connection starts and the page loads normally.

I click "send/receive" in Icedove (email) and the connection status shows that it is waiting for the first mail server... after 10-20 seconds the program connects and then proceeds to download email and connect to and downloads from all other account mail servers normally and quickly.

In the terminal, I run "apt-get update" - the terminal echoes that it is looking for but doesn't respond for 10-20 seconds - when it starts responding, it connects to the server and also connects normally to all of the other servers in my sources.list.

It seems that the first time a connection is requested there is the pause - then any connection that immediately follows is made normally. But then the next new connection pauses again.

This computer is dual boot - Linux and Windows 7. Windows does not have this connection problem. And I don't remember this being an issue with the previous 2.6 kernel. And none of the other computers on my home network exhibit this issue.

What do you network experts think?

rl5 10-27-2011 09:17 AM

Well, I discovered the solution to my problem, and since it's always very frustrating to be searching for a solution only to find posts that briefly state "I solved my problem" without including the solution, here's the solution to my issue.

I had first set up wheezy (2.6.x kernel) months ago and was using ATT DSL at the time, and I had also been using custom DNS servers with my DSL (set in /etc/dhcp/dhclient.conf). More recently I moved to cable internet, upgraded to the kernel and did a dist-upgrade, which is when I noticed the network "pausing". Now somewhere in my upgrading process dhcp3 had been installed so when I was looking at my "pausing" problem I discovered that my resolv.conf had custom DNS servers and I naturally checked /etc/dhcp3/dhclient.conf. When I saw that there were no DNS servers listed I was stumped, until I looked at the dhclient.conf in /etc/dhcp/. The custom servers were still listed there and removing them solved my problem.

I had assumed that since dhcp3 was installed that the dhclient.conf in the /etc/dhcp folder wasn't being used which led to a couple of hours of googling and my post here. Now I'm wondering if dhcp3 is being used at all. :scratch:

All times are GMT -5. The time now is 07:18 PM.