LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 11-26-2007, 10:33 AM   #1
qugreat
LQ Newbie
 
Registered: Nov 2007
Posts: 2

Rep: Reputation: 0
network configuration problem


Hey Guys,

I'm working on Red hat enterprise linux 4 . I config ip addresses are:
eth1 172.17.160.125/22 and eth0 192.168.0.2/24
I meet the problem one is that whenever ServerB restart only one network card can work properly, I need to ifconfig eth0 up manually.
The route for this server can only for one network card. when server up, either eth1 or eth0 is up , network cards cannot be up at the same time. Meanwhile, if eth0 is up , the route for eth1 cannot be added ,if eth1 up , the route for eth0 cannot added.

Your help is greatly appreciated!!
 
Old 11-27-2007, 08:35 PM   #2
mt83
LQ Newbie
 
Registered: May 2007
Distribution: RedHat 9, ES4, CentOS4
Posts: 16

Rep: Reputation: 0
Hi,
You can set your config under /etc/sysconfig/network-script/ifcfg-eth0 and ifcfg-eth1.
This will keep your config after reboot.
 
Old 11-28-2007, 08:41 AM   #3
qugreat
LQ Newbie
 
Registered: Nov 2007
Posts: 2

Original Poster
Rep: Reputation: 0
Wink it doesn't work

Thanks for your reply.

But this didn't work properly ,I have configure those two files already, but after server only startup only one network properly either eth0 or eth1, Which means we only have one netwrok card can be active after reboot.
After reboot, I can startup inactive netwrok card.
ifup eth1 or ifup eth0. I don't know if any problem on linux system , could you advise ?

Your support is great appreciated
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Slackware 10 network configuration. Problem with 8139 network card drivers ! Padmakiran Linux - Networking 8 03-27-2007 07:48 AM
Possible Network Configuration Problem Hewson Linux - Software 3 02-28-2007 05:22 PM
Problem with network configuration anasahmad Linux - Networking 1 02-26-2006 08:13 AM
problem with network configuration btb Linux - Newbie 4 06-27-2005 07:23 PM
problem in network configuration mohdali Linux - Networking 2 10-10-2003 01:08 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 04:04 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration