-   Linux - Networking (
-   -   Network Card Not getting IP (newbie) (

gtjr92 06-30-2006 07:51 AM

Network Card Not getting IP (newbie)
I set up DSL linux on an OLD laptop. Upon Boot my Network Card is recognized as Eth0 (something like that) it says it is getting DHCP. Once i get to the GUI my card has no IP address. I tried assigning a static IP via net card config, i was able to do that, except i get no connectivity. I tried to ping to see if maybe this was a hardware issue, but i get the error stating i can't ping unless i am root.
I didn't login so i thought maybe i was already in as root evidently not.
Also When I plug my lan line in to the Card then I check my switch theat the line is plugged into I do not get a link light. I am pretty sure that even if my NIC card configuration is wrong I should still be able to at least get the Link lights to light up. I tried plugging the cable to another pc and the link light was fine on my switch.
Being a novice with Linux I am unsure what to try next.

cdhgee 06-30-2006 10:14 AM

The first thing to solve is why you aren't getting the link light on the NIC - this is independent of the OS and if it isn't lighting up, then there are a few options:
  • faulty cable
  • faulty NIC
  • router not turned on
  • crossover cable instead of standard cable or vice-versa

When you've identified the problem and got a link light, then we can look at the other problems you mentioned but there's no point trying to fix any of the other problems until you've got working hardware.

gtjr92 06-30-2006 10:23 AM

It's not "faulty cable,router not turned, or crossover cable instead of standard cable or vice-versa"
As i stated in my post i tried plugging the cable to another pc and it is fine.
I am thinking it's faulty nic, but I am not sure the best way to go about diagnosing this.
Like i said i tried to ping but got the acess denied problem.
Any ideas how to diagnose the nic?

cdhgee 06-30-2006 10:24 AM

Has the NIC ever worked?

Can you try the NIC in another machine?

Do you have another NIC you can try in this machine?

Oh and you'll need root access at some point, so you might as well fix that now too.



which should prompt you for the root password. You are now root, so try pinging again.

gtjr92 06-30-2006 10:29 AM

yes the nic has worked but it has been a LONG time since i have used this pc. I can't try the nic in another pc or try another nic because this is an OLD laptop. I'll have to try to login as root when i get home.

Marc 06-30-2006 02:27 PM

Using a PCMCIA NIC on the old laptop might not be a bad idea. It does sound like a NIC hardware failure.

hard_wired_00 07-01-2006 01:29 PM

hmm.. might be a NIC problem of course, the connector contacts might be dirty or oxidated, so it might be minor hardware fault..(hopefully). if it worked before then it might not fail completely so might be a minor thing, check for connection contacts(both LAN and PCMCIA).
Also, you should try to connect that machine & NIC to another network. It might be a cable problem (crossover instead of straight tru) even if it works on another computer... the other computer might have a newer NIC and new generation NICs have the ability to detect and negotiate the medium, so regardless of cable type the new card still works.. but the old laptop nic doesn't know about that. Also, try to connect the laptop in a P2P net with another computer and see if u get a link... if none of them works (and one more thing that cames into my mind, u said it is a PCMCIA card, is it turned on? is pcmcia working proberly? if it is and the system recognizez the card correctly...) then it might be a hardware failure.. :(

Ian_Hawdon 07-01-2006 02:32 PM

to get root access go to shell and type


# sudo su
sudo has been set up to not ask for a password for commands :D

All times are GMT -5. The time now is 12:52 AM.