-   Linux - Networking (
-   -   Network Card Driver Problem ??? Dunno (

kaz4u2dig 03-26-2004 09:29 AM

Network Card Driver Problem ??? Dunno
I have a RR Cable connection, Toshiba Modem, Belkin Router, Two XP machines, and a Linux running (Mandrake 9.2 MCI board no onboard etho) at home. The two XP machines are networked fine. My router assigns them ip's similar to and When I plug in the Linux Machine using an network card ( first one i tried was a...LinkSys) when I plugged it in the light blinked once and never again. I started Drake and it walked me through a install of the network card everything seems ok. But the network card was not blinking, I cannot connect to the internet and my router cannot see it and therefore it will not assign it an ip using DHCP. I opened up the drake network and internet dialog window and it says that the card is down and there is no internet connection. I toyed around with it for a couple of days, trying different options and i managed to get the card "up" but when i clicked on the button to setup the internet connection the net card said "down". With my experience with computers I thought maybe linux is not compatible with this network card, so... I tried two other network cards, Kingston with a netgear chipset and a 3com which I thought would work for sure. I tried the same steps above with these two other cards and the same problem... no internet connections.
please help

something that might help in finding the problem is that when my linux machine boots up it stays on Eth0 and for a couple minutes finally says found Etho9 or something like that =( :study: :study: :study:

robe8 03-26-2004 12:03 PM

First, if there is no link light most likely it has to be the connection between the router and the linux box, so most likely the cable, the distance, or the ports on the router because you did say you've tried several cards but did not mention cabling, the distance between the router and the box or if you've switched ports on the router. Then if you have done all that, next thing to do is check if your NIC is working on the linux box. Try typing ifconfig on you console and see if it prints out eth0 with some information, then post the info here.

All times are GMT -5. The time now is 11:33 AM.