-   Linux - Networking (
-   -   Network Browsing in Fedora (

JustMe5551212 12-15-2003 09:38 AM

Network Browsing in Fedora
Hi everyone. I was wondering a couple of things about my Fedora install and working with other machines on my LAN.

I had used Mandrake a little before and I remember something like "Lin Neighborhood", where I could browse my LAN and see other machines and so on.

Is there a similar thing in RH / Fedora ? I've read some things on using the command line to map drives and so on, but is there a GUI tool to just surf to the occasionally needed share?

Also, is it possible to map to the Windows Admin shares (C$, D$, etc) from a Linux machine?

I tried to use the smb client from a command line in Fedora, but I was only prompted for a password, and I think I need to specify a user and pass since the Linux userID does not exist on the Win machines.

I apologize if I am rambling or even suggesting things that cannot or should not be done.

Obviously I'm a :newbie:

Thanks for the help


finidi 12-15-2003 09:47 AM

In Fedora, If using the GNOME desktop, simply do :

- open a Nautilus window
- issue smb:/// on the address bar

also you have and entry on the system menu (network servers) which do exactly the same.

I think it will ask you for (user, password), but not sure.

JustMe5551212 12-15-2003 10:52 AM

I use KDE right now, would the same command work in Konqueuer ?

Thanks for the reply too :)

finidi 12-16-2003 09:05 AM

I know there is a KDE network browser, but I can't remember how is it called.

wytiger 12-16-2003 10:14 AM

smb://computername will work on Konqueror as well.

One thing I noticed on my Fedora install was that the computername did not work, but the IP address did. (as in smb://ipaddress)

There are different ways that smb can find another computer, such as lmhosts, WINS or broadcast. My Fedora was set up to use lmhosts, so adding an entry for my windows box did the trick.

JustMe5551212 12-16-2003 10:25 AM

Sounds good.

I'd like to go the broadcast route since some machine on my LAN use DHCP so the IP will not always be the same.

Anyone have ideas or info on how to have Fedora / RH 'listen' for the broadcasts of the other PCs on the LAN so it'll recognize them via //name?

Thanks again everyone.

finidi 12-17-2003 06:08 AM

These seems to be M$ / samba issues. In my LAN I use samba as share server and also as smb nameserver, so the machines can be browsed by name. Do you have M$ servers ?

JustMe5551212 12-17-2003 10:30 AM

All the other machines on my LAN are Microsoft. My LAN is p2p, so the servers should broadcast themselves, but perhaps Fedora is not listening :)

wytiger 12-17-2003 10:35 AM

I think you need to look for "name resolve order" in the smb.conf file...(?)

BruceCadieux 12-17-2003 05:30 PM

I just type smb:/ into Konq and it shows the workgroup, if I type smb://workgroupname all the computers in my network show up, I created a link to url on my desktop with a url of smb://workgroupname I click it and it opens to all my computers on the network. :D

JustMe5551212 12-18-2003 08:52 AM

Nice. That sounds like a great idea :) I think I need to mod my setup to put my Linux machine in to my workgroup. But I should be able to find that setting.

Thanks :)

SteelKane 12-18-2003 10:18 AM

I was having trouble getting my dsl to work, Fedora see's the hardware but cant connect

finidi 12-19-2003 04:53 AM

JustMe.... , there is no concept of "workgroup" in linux. If you have a samba server you can define the workgroup it takes on, but it's not the case. So if the smb:// does not work in Konqueror you may hear what wytiger says.

Also be sure there is not a firewall blocking the thing in your linux box... but if you say it works with the IP....

JustMe5551212 12-22-2003 12:01 PM

Thanks again for the replies. I've been out of town and have not been able to try these suggestions, but I will this evening. I think my machine should 'see' the others as my DNS resolution is set to use my Smoothwall firewall as it's first resolver, which should cause Fedora to resolve local names since the Smoothwall box sits on the LAN.

I'll post back when I have some results :)

JustMe5551212 12-23-2003 09:25 AM

Everything is working great! :)

I changed my local machine to also be localhost.home, but I am not sure whether or not that was needed.

But my link on the desktop to browse the local network seems to be working great.

Thanks everyone for your help :)

All times are GMT -5. The time now is 06:45 AM.