LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (https://www.linuxquestions.org/questions/linux-networking-3/)
-   -   Need To Open Port 8087 (https://www.linuxquestions.org/questions/linux-networking-3/need-to-open-port-8087-a-169150/)

vladdy2004 04-12-2004 10:24 AM

Need To Open Port 8087
 
Can Anyone help and tell me where the config file is for this?


Thanks

maxut 04-12-2004 10:48 AM

what port? tcp 8087 or udp 8087? if its so, the answer is iptables. in redhat (or fedora) systems, save file located /etc/sysconfig/iptables. but u do not need to edit this file. try the following line (it will work in all distors which support iptables):

iptables -A INPUT -p tcp --dport 8082 -j ACCEPT

if it works save the changes. in redhat systems u can type the following to do that.
#service iptables save

vladdy2004 04-12-2004 11:08 AM

Thanks for responding so quick. It's TCP I believe. I have to be able to connect to e website's VDECK Control panel and they said they use PORT 8087 and 8080. I'm using e-smith server firewall. I'll try what you said.


Thanks!

vladdy2004 04-12-2004 11:16 AM

I just tried that command on my redhat box and did a cat iptables and don't see that change.

maxut 04-12-2004 11:28 AM

hmm.. if u have redhat u can try configure your firewall.
type follwing in terminal (become root if u are not.)

setup

choose "firewall configuration"
choose costumize and open needed ports.

u said " I'm using e-smith server firewall". is it working on your cmputer? if you are behind a firwall, u must configure your firewall to redirect needed ports (tcp 8082..) to your computer.

vladdy2004 04-12-2004 12:03 PM

Yea i'm using E-Smith as the firewall which is based on redhat. I remember a few weeks ago Someone mentioned a particular file to edit and I simply put 8087 in the safe ports section. That worked fine and I could connect to the VDECK on startlogics site. I ended up reinstalling and cant remember the file. lol

vladdy2004 04-12-2004 12:06 PM

I must add that the e-smith is a stand alone firewall/server. i'm on other machines behind the firewall .If I plug in my old dlink router I can connect fine to the vdeck on port 8087. What is the main file that has the ports listed as Safe etc..?

vladdy2004 04-12-2004 12:48 PM

There appears to be several areas where Iptables is locate. When I did a ./Iptables in etc/rc.d/init.d it showed the port open.

maxut 04-13-2004 03:23 AM

i dont know e-smith nor other firewalls. possibly it is an iptables script to configure firewall. i prefer to configure my firewall myself.
yes u r right, the following shows u the current iptables status in kernel:
/etc/rc.d/init.d/iptables status

safe port means the ports will be opened. so your firewall will allow the request comes to safe ports. u make some ports safe. so there is not certain safe ports. if u wanna see the port numbers of services look at /etc/services file.

u said " i'm on other machines behind the firewall ". so u must configure your firewall. is it a linux too? if it is a linux u can do port forward.

maxut 04-13-2004 10:54 AM

maybe this URL will help u. take a look
http://iptables-script.dk/

vladdy2004 04-13-2004 11:12 AM

Thanks.. Yes my e-smith is the firewall. The computers behind it are windows and linux. Those arent the problem. The problem is in the e-smith and located the conf file where the ports are listed so I can simply add 8087 like I did before. I'll be damned if I can remember where it was..lol It wasn't ip chains though.

artur 04-13-2004 11:22 AM

I don't get why you would need to open a port on your firewall to connect to a remote port 8087 or whatever other port you might want. Shouldn't your firewall block any incoming connections to ports you don't want people connecting to but allow any outgoing connections to any port you want? That is so weird.

Anyway, try
grep -r -i safe /etc/*
this will list any files that contain the word safe anywhere within /etc/directory, which is where the file you;re looking for is most likely located. Consult man grep for details.

AutOPSY 04-13-2004 12:38 PM

yah, dud, but you are forgetting about the response.

the whole thing probably operates on tcp/8080 and 8088.

artur 04-13-2004 05:32 PM

Quote:

Originally posted by AutOPSY
yah, dud, but you are forgetting about the response.
Actually, no, I thought this might be the reason. But I always thought that once the connection is originated from a local machine, any response coming back is allowed through. Only the connections originating outside are blocked. But I guess I might be wrong on this one and any packets, including response, coming in are blocked unless specifically allowed through. That would be silly though, most of the time one would presume that since the connection originated from a trusted local network, we'd want to hear the response.

Idunno... Just some food for thought...

vladdy2004 04-14-2004 09:00 AM

Tell me about it! lol Last night I simply unplugged the linux router and plugged into a dlink router...Connected to the site..got done what I needed to get done then plugged in the linux router again. There is no GUI With this E-smith Router/Gateway Box. It's all command line which I really dont have a problem with, I just done know where you can clearly open or close a port at will.. the defacto place where ports are denied or accepted? And ive tried for week on the google and forums and noone else seems to know either.


All times are GMT -5. The time now is 07:25 AM.