LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 04-28-2015, 07:20 AM   #1
novicunix
LQ Newbie
 
Registered: Jan 2013
Posts: 18

Rep: Reputation: Disabled
Need to connect centos 6.6 minimal VM to internet


Hi,
I have installed centos 6.6 minimal on my VM.
I have wireless internet connection on my laptop.
I am completely new to configuring network on linux. Please get me started.

My eth0 does not have an ip. How to determine an IP address? Whether it is DHCP or static , I have no idea. Please can any one help me with the concepts and process.

Thank you
 
Old 04-28-2015, 09:02 AM   #2
Vennox
LQ Newbie
 
Registered: Apr 2015
Posts: 4

Rep: Reputation: Disabled
I need to ask you some questions to know better your case.
1. What operating system are you using to run Virtual Machine ( like Windows 7, Windows 8, Ubuntu, Debian, CentOS )
2. What program are you using to run the virtual machine (Virtualbox, VMWare, etc)?
Please answer this questions and then we can continue.
 
Old 04-28-2015, 09:10 AM   #3
novicunix
LQ Newbie
 
Registered: Jan 2013
Posts: 18

Original Poster
Rep: Reputation: Disabled
OS details

Hi
1. I am using oracle virtual box installed on windows 7 (64-bit) which is my desktop.
2. I created a VM instance using centos 6.6 minimal image.
 
Old 04-28-2015, 09:16 AM   #4
Vennox
LQ Newbie
 
Registered: Apr 2015
Posts: 4

Rep: Reputation: Disabled
Hello,
1. Did you change virtual machine settings in the network profile? ( Link, how it looks: http://puu.sh/htUIh/e33ef87ae7.png . Try to use the bridged settings cause it's using your physical interface )
2. Please check interface configuration inside VM. The path to config file /etc/sysconfig/network-scripts/ifcfg-<interface-name> . In your case type cat /etc/sysconfig/network-scripts/ifcfg-eth0. It will show your config file and take a screenshot with combination of Host(Right Control) + E and show me it.
3. Do you have any DHCP server inside your network?
 
Old 04-28-2015, 09:33 AM   #5
novicunix
LQ Newbie
 
Registered: Jan 2013
Posts: 18

Original Poster
Rep: Reputation: Disabled
Yes. I did change the network settings as shown in the image file.
Please find the attachment for ifcfg-eth0.

I tried changing BOOTPROTO between dhcp and static. But unable to generate ip for eth0.

I dont have much knowledge about dhcp server. I am trying from my laptop.
Attached Thumbnails
Click image for larger version

Name:	Cent OS 6.png
Views:	162
Size:	6.1 KB
ID:	18283  
 
Old 04-28-2015, 09:40 AM   #6
Vennox
LQ Newbie
 
Registered: Apr 2015
Posts: 4

Rep: Reputation: Disabled
Please, check your Windows 7 network settings. We need to know if it's a static or dhcp assigned ip address. This will show us is there a DHCP server in your network.
Try to enable the enable your network adapter inside VM by typing ifup eth0 and show me the output.
 
Old 04-28-2015, 10:16 AM   #7
novicunix
LQ Newbie
 
Registered: Jan 2013
Posts: 18

Original Poster
Rep: Reputation: Disabled
Yes. My windows 7 is DHCP enabled set to 'Yes'.
Please find the snapshot of ifup eth0. This is where I am struck. It fails.
Attached Thumbnails
Click image for larger version

Name:	ifup.png
Views:	114
Size:	6.4 KB
ID:	18284  
 
Old 04-28-2015, 10:17 AM   #8
novicunix
LQ Newbie
 
Registered: Jan 2013
Posts: 18

Original Poster
Rep: Reputation: Disabled
Now, I am able to get DHCP server ip address. What is next?
 
Old 04-28-2015, 10:29 AM   #9
Vennox
LQ Newbie
 
Registered: Apr 2015
Posts: 4

Rep: Reputation: Disabled
The fastest way of getting the internet connection is pluging the network cable to your PC via ethernet port. I think the problem is the VM is thinking you have ethernet access but you have only WiFi and it says no cable connected. Can you connect via ethernet or you can only access internet via WiFi?
 
1 members found this post helpful.
Old 04-28-2015, 10:46 AM   #10
novicunix
LQ Newbie
 
Registered: Jan 2013
Posts: 18

Original Poster
Rep: Reputation: Disabled
I have wifi.
 
Old 04-28-2015, 10:47 AM   #11
michaelk
Moderator
 
Registered: Aug 2002
Posts: 25,925

Rep: Reputation: 5999Reputation: 5999Reputation: 5999Reputation: 5999Reputation: 5999Reputation: 5999Reputation: 5999Reputation: 5999Reputation: 5999Reputation: 5999Reputation: 5999
If your VM network adapter is configured as bridge adapter mode and if eth0 is getting a DHCP address then networking should be functional. You should be able to access devices on the network as well as the internet. What do you want to accomplish?

It should not matter whether the laptop is using wireless or wired the VM will configure it is a wired connection.
 
Old 04-28-2015, 10:50 AM   #12
novicunix
LQ Newbie
 
Registered: Jan 2013
Posts: 18

Original Poster
Rep: Reputation: Disabled
Please find my VM network settings.
Attached Thumbnails
Click image for larger version

Name:	VM_network.png
Views:	205
Size:	46.9 KB
ID:	18286  

Last edited by novicunix; 04-28-2015 at 10:54 AM.
 
Old 04-28-2015, 10:59 AM   #13
novicunix
LQ Newbie
 
Registered: Jan 2013
Posts: 18

Original Poster
Rep: Reputation: Disabled
My purpose is to later install a lot of tools using internet connection.
 
Old 04-28-2015, 11:22 AM   #14
michaelk
Moderator
 
Registered: Aug 2002
Posts: 25,925

Rep: Reputation: 5999Reputation: 5999Reputation: 5999Reputation: 5999Reputation: 5999Reputation: 5999Reputation: 5999Reputation: 5999Reputation: 5999Reputation: 5999Reputation: 5999
Can you ping other computers on the network or internet i.e. ping google.com?
 
Old 04-28-2015, 11:23 AM   #15
suicidaleggroll
LQ Guru
 
Registered: Nov 2010
Location: Colorado
Distribution: OpenSUSE, CentOS
Posts: 5,573

Rep: Reputation: 2142Reputation: 2142Reputation: 2142Reputation: 2142Reputation: 2142Reputation: 2142Reputation: 2142Reputation: 2142Reputation: 2142Reputation: 2142Reputation: 2142
You said you have an IP address, what else are you looking for? Does it not work? If not, then what's not working?
 
  


Reply

Tags
centos6, internet connection, virtual host, wirelessnetworking


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Minimal Centos 6.6 Wifi can scan and see APs but will not connect to an AP callowaa Linux - Newbie 1 02-10-2015 01:45 PM
[SOLVED] CentOS 6 Media Server Can't Connect to Internet Jackoalltrades Linux - Server 6 09-14-2014 01:23 PM
CentOS 5.6 can connect to internet, but can't display websites or SSH SecurityGate Linux - Newbie 4 05-20-2011 01:00 AM
cannot connect to internet from centos machine mbanwi Linux - Newbie 3 07-08-2009 08:40 PM
Cannot Connect to Internet; CentOS lucknowm62 Linux - Networking 8 08-26-2007 01:27 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 08:30 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration