-   Linux - Networking (
-   -   ndiswrapper issues fedora core 9 (

DigiLogik 10-31-2008 03:00 AM

ndiswrapper issues fedora core 9
Hi i'm trying to get my wireless card working on my fresh install of fedora core 9 for my laptop. I have a HP Pavilion dv2116wm. The driver im trying to use is here provided below. I am generally new at linux but I have a little experience. I was trying to get ndiswrapper to work so my wireless card would work. I have installed ndiswrapper using yum and got the driver installed in ndiswrapper. When i enter the command "ndiswrapper -l" I get:
bcmwl6 : driver installed
device (14E4:4311) present (alternate driver: ssb)
Which I've read is a good sign. I then tried "ndiswrapper -m" and then "modprobe ndiswrapper" My wireless card still isnt working. I have also tried rebooting my system. When I check the log using dmesg, wlan0 doesn't show up in the log at all. I have tried everything I can think of to try and get this to work any help would be appreciated. Don't want to go back to XP.

SkyEye 10-31-2008 03:50 AM

Welcome to LQ!

For your problem try adding the line

blacklist ssb

into /etc/modprobe.d/blacklist and reboot. You might have to modprobe ndiswrapper again if you haven't run (ndiswrapper -m). What the above line does is blacklisting the ssb module, so that it won't load and let ndiswrapper load.

If the module is loaded, the following will show you.
# lsmod | grep ndis

DigiLogik 10-31-2008 10:40 AM

Thank you so much SkyEye. That was all I was forgetting. Posting this using my wireless card. Now hopefully I can help out the next time someone asks this question.

SkyEye 11-02-2008 01:12 AM

Glad to know you got it working.


Originally Posted by DigiLogik (Post 3327400)
Now hopefully I can help out the next time someone asks this question.

That's great. :)

All times are GMT -5. The time now is 07:35 PM.