LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 11-26-2015, 04:24 PM   #1
jozmak
Member
 
Registered: Aug 2005
Posts: 81

Rep: Reputation: 1
My new dls modem doesn't connect the internet. Please help.[SOLVED]


Hello,

I got new dsl modem and can't connect the internet. When I set up the new modem all light come up except the internet light.

This is a very basic simple set up. Includes a dsl moden and a dlink router to be able to use wireless devices. Nothing wrong with the dlink router because when I turn it off the modem still can't connect the internet.

I set up the system 10 years ago and ever since I have never had to do anything with networking interfaces. When I installed a new distro the setup always configured my network and it always worked.

But now my old modem is getting a little bit worn out and my internet service provider gave me a new one.

When I set up the new one, it configures itself and all lights come up except the internet light power, dls, ethernet everything fine.

I have very little knowledge of networking, because I've never had to do anything about it.

So I don't even know how to start trouble shooting the thing.

Is it possible that I have to reenter the username or passwd for the new modem? But I don't even know where to enter them. I remember vaguely, about 10 years ago I entered username and passwd, but I don't remember how it was done.

I went through several network wikis but I found no useful tips of how to go about fixing this problem.

The old modem connects right away when I set it up, so I guess nothing wrong with may network set up.

Perhaps the new modem can't find the ISP address? Could this be?

Could anyone give me some basic instructions how to go about fixing this?

Thank you

Last edited by jozmak; 11-28-2015 at 03:46 PM.
 
Old 11-26-2015, 04:49 PM   #2
astrogeek
Moderator
 
Registered: Oct 2008
Distribution: Slackware [64]-X.{0|1|2|37|-current} ::12<=X<=15, FreeBSD_12{.0|.1}
Posts: 6,286
Blog Entries: 24

Rep: Reputation: 4238Reputation: 4238Reputation: 4238Reputation: 4238Reputation: 4238Reputation: 4238Reputation: 4238Reputation: 4238Reputation: 4238Reputation: 4238Reputation: 4238
Quote:
Originally Posted by jozmak View Post
I set up the system 10 years ago and ever since I have never had to do anything with networking interfaces. When I installed a new distro the setup always configured my network and it always worked.
Well, it has nothing to do with your distro.

Quote:
Originally Posted by jozmak View Post
But now my old modem is getting a little bit worn out and my internet service provider gave me a new one.
Surely it came with some basic instructions? If not, ask your ISP for info on setup.

Quote:
Originally Posted by jozmak View Post
Is it possible that I have to reenter the username or passwd for the new modem? But I don't even know where to enter them. I remember vaguely, about 10 years ago I entered username and passwd, but I don't remember how it was done.
Certainly you will need to enter the username and password given you by your ISP.

For most of them, you simply point your browser at the default address in the setup instructions to open an admin page. Then you enter the default password from the setup instructions to allow access.

It will NOT be plug-n-play, and there are no generic instructions, and there is not much anyone here can do to help without knowing the model of the modem and your ISP's requirements.

So read the setup instructions, or ask the ISP how to do it. It isn't difficult.

Last edited by astrogeek; 11-26-2015 at 05:05 PM. Reason: tpos, typs, typos
 
Old 11-26-2015, 04:49 PM   #3
Emerson
LQ Sage
 
Registered: Nov 2004
Location: Saint Amant, Acadiana
Distribution: Gentoo ~amd64
Posts: 7,675

Rep: Reputation: Disabled
Methinks you need to log into your modem and set up your account. See the modem manual.

Edit: Came out second fastest.
 
Old 11-26-2015, 05:39 PM   #4
jozmak
Member
 
Registered: Aug 2005
Posts: 81

Original Poster
Rep: Reputation: 1
Quote:
Originally Posted by Emerson View Post
Methinks you need to log into your modem and set up your account. See the modem manual.

Edit: Came out second fastest.
Thanks for the replies.

The modem came with no manual. The name of the modem is Camatel. I don't think this means anything, nowadays, everything imported from China.

I call the ISP tomorrow but I don't expect much because they probably say open Windows Control panel blah blah blah.

And when I tell them I have no windows installed, big silence I am sorry we can't...

I know that when I set up my modem the fist time, I entered username and passwd somewhere and it worked right away.

I'm just wondering is there any terminal commands available to set up username and passwd for the modem, for instance, something like when you set up a new user. Because I suspect that is the problem.

So many things have changed since last time I did this.

It's pity that pppeoconf is not available anymore on debian.

I think vaguely I used that when I set up my connection the first time.
 
Old 11-26-2015, 06:21 PM   #5
astrogeek
Moderator
 
Registered: Oct 2008
Distribution: Slackware [64]-X.{0|1|2|37|-current} ::12<=X<=15, FreeBSD_12{.0|.1}
Posts: 6,286
Blog Entries: 24

Rep: Reputation: 4238Reputation: 4238Reputation: 4238Reputation: 4238Reputation: 4238Reputation: 4238Reputation: 4238Reputation: 4238Reputation: 4238Reputation: 4238Reputation: 4238
It is very unlikely that there would be any commands in your distro for setting that up.

A quick duckduckgo for 'camatel modem setup' produces quite a few hits, not all of which looked useful. But this one did.

Download it and even if it is not your exact model, try following the Quick Start guide, ignoring the Window$ only parts - they are really irrelevant. Connect it to network, phone and powersupply and start about page 6 with this...

Quote:
1. Start your Web browser.
In the Address box, enter the following:
192.168.254.254
3. When prompted for a user name and password,
type admin for the user name and admin for the
password.
4. Click OK to enter the Quick Start page of web
interface from modem.
5. Type the user name and password provided by
...
 
Old 11-26-2015, 06:22 PM   #6
jozmak
Member
 
Registered: Aug 2005
Posts: 81

Original Poster
Rep: Reputation: 1
I installed debian pppoeconf, run it and I got the following message:

Sorry, I scanned 1 interface, but the Access │
Concentrator of your provider did not respond. Please │
check your network and modem cables. Another reason for │
the scan failure may also be another running pppoe │
process which controls the modem.
 
Old 11-26-2015, 06:28 PM   #7
Emerson
LQ Sage
 
Registered: Nov 2004
Location: Saint Amant, Acadiana
Distribution: Gentoo ~amd64
Posts: 7,675

Rep: Reputation: Disabled
I'm sure you do not need it, your modem does PPPoE for you.
 
Old 11-26-2015, 07:39 PM   #8
jozmak
Member
 
Registered: Aug 2005
Posts: 81

Original Poster
Rep: Reputation: 1
Quote:
Originally Posted by Emerson View Post
I'm sure you do not need it, your modem does PPPoE for you.
Thanks Emerson,

This is exactly the modem I have.

I followed the procedure but when entered the ip address they gave the supposed username and passwd box didn't come up, instead it said the address was not available.

I don't know why. Maybe the internet service provider already did some configuration on the modem, I have no idea.

Tomorrow, I call them because, at least, now I have something to tell them.

I report back what happened.
 
Old 11-27-2015, 03:00 AM   #9
berndbausch
LQ Addict
 
Registered: Nov 2013
Location: Tokyo
Distribution: Mostly Ubuntu and Centos
Posts: 6,316

Rep: Reputation: 2002Reputation: 2002Reputation: 2002Reputation: 2002Reputation: 2002Reputation: 2002Reputation: 2002Reputation: 2002Reputation: 2002Reputation: 2002Reputation: 2002
Quote:
Originally Posted by jozmak View Post
Thanks Emerson,

This is exactly the modem I have.

I followed the procedure but when entered the ip address they gave the supposed username and passwd box didn't come up, instead it said the address was not available.
My guess is that your computer has no route to this address 192.168.254.254. Fix your network config.
 
Old 11-27-2015, 03:13 AM   #10
astrogeek
Moderator
 
Registered: Oct 2008
Distribution: Slackware [64]-X.{0|1|2|37|-current} ::12<=X<=15, FreeBSD_12{.0|.1}
Posts: 6,286
Blog Entries: 24

Rep: Reputation: 4238Reputation: 4238Reputation: 4238Reputation: 4238Reputation: 4238Reputation: 4238Reputation: 4238Reputation: 4238Reputation: 4238Reputation: 4238Reputation: 4238
Yes, berndbausch is right - it might be that your router does not know where to send requests for that address.

You might want to connect your computer directly to the modem to get it going, then sort out the router addressing. If you need more help, it would be very helpful to post your network topology - router gateway and LAN addresses, dhcp options and how many computers are connected.

Also, if 192.168.254.254 does not work (although it should if that is your actual model) you might try 192.168.1.254 which is another common admin default address.
 
Old 11-27-2015, 05:36 AM   #11
Emerson
LQ Sage
 
Registered: Nov 2004
Location: Saint Amant, Acadiana
Distribution: Gentoo ~amd64
Posts: 7,675

Rep: Reputation: Disabled
You may add a virtual interface to your computer before attempting connection.
Code:
ifconfig eth0:0 192.168.254.1
 
Old 11-27-2015, 06:22 AM   #12
berndbausch
LQ Addict
 
Registered: Nov 2013
Location: Tokyo
Distribution: Mostly Ubuntu and Centos
Posts: 6,316

Rep: Reputation: 2002Reputation: 2002Reputation: 2002Reputation: 2002Reputation: 2002Reputation: 2002Reputation: 2002Reputation: 2002Reputation: 2002Reputation: 2002Reputation: 2002
Quote:
Originally Posted by Emerson View Post
You may add a virtual interface to your computer before attempting connection.
Code:
ifconfig eth0:0 192.168.254.1
Newer distros don't have ifconfig anymore.
Code:
ip address add 192.168.254.1/24 dev eth0
or shorter
Code:
ip a add 192.168.254.1/24 dev eth0
Assuming 24 is the correct prefix.
 
Old 11-27-2015, 11:38 AM   #13
jozmak
Member
 
Registered: Aug 2005
Posts: 81

Original Poster
Rep: Reputation: 1
Thanks for all the replies.

I apologize for replying late but each time I do the tips I have to unplug my old modem which still works more less - and set up the new one, and the old modem needs time to hook up again the internet. This is a nightmare.

Here is some info on my computer.

Code:
[mak@myhost ~]$ lspci -v
00:00.0 Host bridge: Advanced Micro Devices, Inc. [AMD/ATI] RS690 Host Bridge
	Subsystem: ASUSTeK Computer Inc. Device 826d
	Flags: bus master, 66MHz, medium devsel, latency 64

00:02.0 PCI bridge: Advanced Micro Devices, Inc. [AMD/ATI] RS690 PCI to PCI Bridge (PCI Express Graphics Port 0) (prog-if 00 [Normal decode])
	Flags: bus master, fast devsel, latency 0, IRQ 24
	Bus: primary=00, secondary=01, subordinate=01, sec-latency=0
	I/O behind bridge: 0000d000-0000dfff
	Memory behind bridge: f8000000-fbffffff
	Prefetchable memory behind bridge: 00000000d0000000-00000000dfffffff
	Capabilities: <access denied>
	Kernel driver in use: pcieport
	Kernel modules: shpchp

00:07.0 PCI bridge: Advanced Micro Devices, Inc. [AMD/ATI] RS690 PCI to PCI Bridge (PCI Express Port 3) (prog-if 00 [Normal decode])
	Flags: bus master, fast devsel, latency 0, IRQ 25
	Bus: primary=00, secondary=02, subordinate=02, sec-latency=0
	I/O behind bridge: 0000e000-0000efff
	Memory behind bridge: fdd00000-fddfffff
	Prefetchable memory behind bridge: 00000000fdc00000-00000000fdcfffff
	Capabilities: <access denied>
	Kernel driver in use: pcieport
	Kernel modules: shpchp

00:12.0 SATA controller: Advanced Micro Devices, Inc. [AMD/ATI] SB600 Non-Raid-5 SATA (prog-if 01 [AHCI 1.0])
	Subsystem: ASUSTeK Computer Inc. Device 81ef
	Flags: bus master, 66MHz, medium devsel, latency 64, IRQ 22
	I/O ports at ff00 [size=8]
	I/O ports at fe00 [size=4]
	I/O ports at fd00 [size=8]
	I/O ports at fc00 [size=4]
	I/O ports at fb00 [size=16]
	Memory at fe02f000 (32-bit, non-prefetchable) [size=1K]
	Capabilities: <access denied>
	Kernel driver in use: ahci
	Kernel modules: ahci

00:13.0 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB600 USB (OHCI0) (prog-if 10 [OHCI])
	Subsystem: ASUSTeK Computer Inc. Device 81ef
	Flags: bus master, 66MHz, medium devsel, latency 64, IRQ 16
	Memory at fe02e000 (32-bit, non-prefetchable) [size=4K]
	Kernel driver in use: ohci-pci
	Kernel modules: ohci_pci

00:13.1 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB600 USB (OHCI1) (prog-if 10 [OHCI])
	Subsystem: ASUSTeK Computer Inc. Device 81ef
	Flags: bus master, 66MHz, medium devsel, latency 64, IRQ 17
	Memory at fe02d000 (32-bit, non-prefetchable) [size=4K]
	Kernel driver in use: ohci-pci
	Kernel modules: ohci_pci

00:13.2 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB600 USB (OHCI2) (prog-if 10 [OHCI])
	Subsystem: ASUSTeK Computer Inc. Device 81ef
	Flags: bus master, 66MHz, medium devsel, latency 64, IRQ 18
	Memory at fe02c000 (32-bit, non-prefetchable) [size=4K]
	Kernel driver in use: ohci-pci
	Kernel modules: ohci_pci

00:13.3 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB600 USB (OHCI3) (prog-if 10 [OHCI])
	Subsystem: ASUSTeK Computer Inc. Device 81ef
	Flags: bus master, 66MHz, medium devsel, latency 64, IRQ 17
	Memory at fe02b000 (32-bit, non-prefetchable) [size=4K]
	Kernel driver in use: ohci-pci
	Kernel modules: ohci_pci

00:13.4 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB600 USB (OHCI4) (prog-if 10 [OHCI])
	Subsystem: ASUSTeK Computer Inc. Device 81ef
	Flags: bus master, 66MHz, medium devsel, latency 64, IRQ 18
	Memory at fe02a000 (32-bit, non-prefetchable) [size=4K]
	Kernel driver in use: ohci-pci
	Kernel modules: ohci_pci

00:13.5 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB600 USB Controller (EHCI) (prog-if 20 [EHCI])
	Subsystem: ASUSTeK Computer Inc. Device 81ef
	Flags: bus master, 66MHz, medium devsel, latency 64, IRQ 19
	Memory at fe029000 (32-bit, non-prefetchable) [size=256]
	Capabilities: <access denied>
	Kernel driver in use: ehci-pci
	Kernel modules: ehci_pci

00:14.0 SMBus: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 SMBus Controller (rev 14)
	Subsystem: ASUSTeK Computer Inc. Device 81ef
	Flags: 66MHz, medium devsel
	I/O ports at 0b00 [size=16]
	Capabilities: <access denied>
	Kernel driver in use: piix4_smbus
	Kernel modules: i2c_piix4, sp5100_tco

00:14.1 IDE interface: Advanced Micro Devices, Inc. [AMD/ATI] SB600 IDE (prog-if 8a [Master SecP PriP])
	Subsystem: ASUSTeK Computer Inc. Device 81ef
	Flags: bus master, 66MHz, medium devsel, latency 64, IRQ 16
	I/O ports at 01f0 [size=8]
	I/O ports at 03f4
	I/O ports at 0170 [size=8]
	I/O ports at 0374
	I/O ports at f900 [size=16]
	Kernel driver in use: pata_atiixp
	Kernel modules: pata_atiixp, pata_acpi, ata_generic

00:14.2 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 Azalia (Intel HDA)
	Subsystem: ASUSTeK Computer Inc. Device 8249
	Flags: bus master, slow devsel, latency 64, IRQ 16
	Memory at fe020000 (64-bit, non-prefetchable) [size=16K]
	Capabilities: <access denied>
	Kernel driver in use: snd_hda_intel
	Kernel modules: snd_hda_intel

00:14.3 ISA bridge: Advanced Micro Devices, Inc. [AMD/ATI] SB600 PCI to LPC Bridge
	Subsystem: ASUSTeK Computer Inc. Device 81ef
	Flags: bus master, 66MHz, medium devsel, latency 0

00:14.4 PCI bridge: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 PCI to PCI Bridge (prog-if 01 [Subtractive decode])
	Flags: bus master, VGA palette snoop, 66MHz, medium devsel, latency 64
	Bus: primary=00, secondary=03, subordinate=03, sec-latency=64
	I/O behind bridge: 0000c000-0000cfff
	Memory behind bridge: fdf00000-fdffffff
	Prefetchable memory behind bridge: fde00000-fdefffff

00:18.0 Host bridge: Advanced Micro Devices, Inc. [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
	Flags: fast devsel
	Capabilities: <access denied>

00:18.1 Host bridge: Advanced Micro Devices, Inc. [AMD] K8 [Athlon64/Opteron] Address Map
	Flags: fast devsel

00:18.2 Host bridge: Advanced Micro Devices, Inc. [AMD] K8 [Athlon64/Opteron] DRAM Controller
	Flags: fast devsel
	Kernel modules: amd64_edac_mod

00:18.3 Host bridge: Advanced Micro Devices, Inc. [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
	Flags: fast devsel
	Capabilities: <access denied>
	Kernel driver in use: k8temp
	Kernel modules: k8temp

01:00.0 VGA compatible controller: NVIDIA Corporation G84 [GeForce 8400 GS] (rev a1) (prog-if 00 [VGA controller])
	Flags: bus master, fast devsel, latency 0, IRQ 27
	Memory at fa000000 (32-bit, non-prefetchable) [size=16M]
	Memory at d0000000 (64-bit, prefetchable) [size=256M]
	Memory at f8000000 (64-bit, non-prefetchable) [size=32M]
	I/O ports at df00 [size=128]
	[virtual] Expansion ROM at fbfe0000 [disabled] [size=128K]
	Capabilities: <access denied>
	Kernel driver in use: nvidia
	Kernel modules: nouveau, nvidia

02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 01)
	Subsystem: ASUSTeK Computer Inc. P5B
	Flags: bus master, fast devsel, latency 0, IRQ 26
	I/O ports at ee00 [size=256]
	Memory at fddff000 (64-bit, non-prefetchable) [size=4K]
	[virtual] Expansion ROM at fdd00000 [disabled] [size=128K]
	Capabilities: <access denied>
	Kernel driver in use: r8169
	Kernel modules: r8169

[mak@myhost ~]$ 


mak@myhost ~]$ ip link
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: enp2s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP mode DEFAULT group default qlen 1000
    link/ether 00:1f:c6:ba:03:e0 brd ff:ff:ff:ff:ff:ff
[mak@myhost ~]$
As I said I have a very basic set up one computer, one modem and a dlink router.

I connected the modem strait to the computer as astrogeek suggested but still got the same error message.

I added the ip address to the system as many of you suggested but I am still not able to connect to the admin address.
 
Old 11-27-2015, 01:49 PM   #14
jozmak
Member
 
Registered: Aug 2005
Posts: 81

Original Poster
Rep: Reputation: 1
More info about my setup
Code:
mak@debian ~ $ ifconfig
eth0      Link encap:Ethernet  HWaddr 00:1f:c6:ba:03:e0  
          inet addr:192.168.0.102  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::21f:c6ff:feba:3e0/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:3001 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2703 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:3026962 (2.8 MiB)  TX bytes:234964 (229.4 KiB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:128 errors:0 dropped:0 overruns:0 frame:0
          TX packets:128 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:10368 (10.1 KiB)  TX bytes:10368 (10.1 KiB)

mak@debian ~ $
 
Old 11-27-2015, 02:16 PM   #15
yancek
LQ Guru
 
Registered: Apr 2008
Distribution: Slackware, Ubuntu, PCLinux,
Posts: 10,672

Rep: Reputation: 2526Reputation: 2526Reputation: 2526Reputation: 2526Reputation: 2526Reputation: 2526Reputation: 2526Reputation: 2526Reputation: 2526Reputation: 2526Reputation: 2526
Did you check on the bottom of the modem for a sticker which has the default admin user name and password? Pretty common on newer ones.
Open a terminal and run this command: route -n You should see output similar to that below:

Quote:
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
0.0.0.0 192.168.0.1 0.0.0.0 UG 0 0 0 eth0
Note the IP address under Gateway which will probably be different. Open a web browser and enter it: http://192.168.0.1 (obviously change this IP to whatever you got in your output. Hit the enter key and it should take you to the setup page.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
i can not connect to t he Internet by using modem connect moon_nader Linux - Networking 3 06-15-2010 03:12 PM
why my modem doesn't connect durin dial-up? buvanesh Linux - Newbie 4 10-28-2006 04:58 AM
cannot connect to the internet with modem shams Linux - Software 2 03-26-2004 10:13 PM
can't connect to the internet via modem shams Linux - Software 3 03-17-2004 11:06 PM
how do I connect to the Internet with a modem? slice4e Linux - General 2 05-09-2003 10:21 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 02:31 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration