LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 03-07-2004, 07:38 AM   #1
acarri
LQ Newbie
 
Registered: Mar 2004
Posts: 18

Rep: Reputation: 0
my ISP has blocked grant access only to windows boxes????? could this be?????


Hello everybody,

I'm building a router for my home lan, so I got a computer with two nics (rtl800 and realtek 8029), one 6 gig hdd, and dual boot win98 and redhat 9. First I set it up with win98 and everything worked great, then I tried to set it up with redhat but I had no luck. I got everything up and running, the nics are displayed with the ifconfig allright, but when I try ifup eth0 (dhcp), I receive this error:

Determining IP information for eth0...SIOCADDRT: Network is unreachable
done.
/sbin/ifup: line 268: [: : integer expression expected

My internal network works just fine, but I can't get outside. The extrange thing is that "ifup eth0" it assigns the correct ip to the nic (I have static ip). So I'm wondering if my ISP managed to let connect only windoze boxes...

Any help would be apprecitated...
Thanks...


Arthur Carrillo.
 
Old 03-07-2004, 08:04 AM   #2
snocked
Member
 
Registered: Dec 2002
Location: St. Louis, MO
Distribution: Slackware 9.1
Posts: 482

Rep: Reputation: 30
Yes, some ISPs filter out certain ports so you and I can't run ftp/http outside our networks.
 
Old 03-07-2004, 08:20 AM   #3
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,803
Blog Entries: 1

Rep: Reputation: 422Reputation: 422Reputation: 422Reputation: 422Reputation: 422
Quote:
The extrange thing is that "ifup eth0" it assigns the correct ip to the nic (I have static ip). So I'm wondering if my ISP managed to let connect only windoze boxes...
Well, since network traffic consists of TCP/IP it is HIGHLY unlikely that your ISP allows connections only to widows boxes. More than likely something isn't quite kosher with your RH setup.

What I don't get is why you are using DHCP when you have a static IP. However, I also don't know the setup of your lan, so a couple of answers would be helpful
1) Which card (eth0 or eth1) is the one connecting to the ISP?
2) Is it your ISP that assigned you a static IP or do they use DHSP?


I'm not sure what Snocked is on about. Yes, some ISPs block ports to prevent you from running servers, but that shouldn't get in the way of you surfing the net.
 
Old 03-07-2004, 10:47 AM   #4
2damncommon
Senior Member
 
Registered: Feb 2003
Location: Calif, USA
Distribution: PCLINUXOS
Posts: 2,918

Rep: Reputation: 103Reputation: 103
Do you need to manually enter your ISP's 2 DNS servers?
What does ifconfig show?
 
Old 03-07-2004, 03:40 PM   #5
acarri
LQ Newbie
 
Registered: Mar 2004
Posts: 18

Original Poster
Rep: Reputation: 0
Thanks everybody for your quick response, I'll try to answer you all of your questions.

I have an old pc which I want to turn in to a router, I had it up and running with freesco linux configured as a router but since a while a go stopped working (with the same error message redhat gives me "SIOCADDRT... can't add default route"), so I decided to format my hdd and install win98 and redhat 9. First I got it up and running (the router) with win98. I got two windows xp boxes that connects to this (win98) router to be able to get internet, and both connected to the internet very well. I also could ping from the win98 router to 200.23.249.1 which is my ISP DNS. Then I tried to set it up with redhat 9, I install it as a server with no graphical interface. Everything works great, I mean, it recongizes both nics:

realtek 8029as = eth0 and is connected to my ISP
rtl800 = eth1 and is connected to my internal lan

my ISP has a mac restriction, so I had to spoof my mac with:

ifconfig eth0 hw ether XX:XX:XX:XX:XX:XX

then I tried to connect to my ISP:

ifup eth0

then I got the error:

Determining IP information for eth0...SIOCADDRT: Network is unreachable
done.
/sbin/ifup: line 268: [: : integer expression expected

but still updates the ip with the valid one, by the way, it always assigns me the same ip 192.168.51.40 but it has to be assign via dhcp or it won't work, I don't know why, even when I try to manually assign it with win98, and yes I did copy all the parameters exactly as when dhcp assigns the ip.

here is my ifconfig output:

[root@localhost network-scripts]# ifconfig
eth0 Link encap:Ethernet HWaddr 00:C0:F0:45:99:BF
inet addr:192.168.51.40 Bcast:192.168.51.43 Mask:255.255.255.252
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:105 errors:0 dropped:0 overruns:0 frame:0
TX packets:2 errors:7 dropped:0 overruns:0 carrier:14
collisions:119 txqueuelen:100
RX bytes:16943 (16.5 Kb) TX bytes:2796 (2.7 Kb)
Interrupt:11 Base address:0x6200

eth1 Link encap:Ethernet HWaddr 00:02:2A:F1:A7:1E
inet addr:10.0.0.1 Bcast:10.0.0.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:1240 errors:0 dropped:0 overruns:0 frame:0
TX packets:1568 errors:0 dropped:0 overruns:0 carrier:0
collisions:1 txqueuelen:100
RX bytes:133398 (130.2 Kb) TX bytes:132991 (129.8 Kb)
Interrupt:10 Base address:0x6300

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:10 errors:0 dropped:0 overruns:0 frame:0
TX packets:10 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:700 (700.0 b) TX bytes:700 (700.0 b)


The above is what gives me after I spoofed my mac and after I do an ifup eth0.

so as you can see it still updates my ip with the valid one but when I try to ping 200.23.249.1 I have a no go. So maybe they managed to let only win boxes to connect to their network, or maybe the dhcp client is different from the one that comes with windoze, what give me the creeps is the line that claims that line 268 in dhcp has a problem and was expecting an integer...

Thanks in advance. Any help would be appreciated...

P.S. any of you know how to make the mac spoofing permanent, I mean, to be able to change it at the activation of the interface at boot up?

Last edited by acarri; 03-08-2004 at 02:12 AM.
 
Old 03-07-2004, 04:11 PM   #6
dfowensby
Member
 
Registered: Dec 2003
Location: OceanView Virginia, gem of the Southern Shore
Distribution: OpenSuSE Tumbleweed
Posts: 194
Blog Entries: 1

Rep: Reputation: 30
not sure if this is relevant, but i ran a Realtek 8039, and got the same nonexistant ip prob when i wrote in my own stuff during the install network config gui. tried it with the Sundance card, and got the same thing! this is all on a compaq presario s5000 with 40+15 dual hd's and 1 gig of ram. i had absolutely NO hassle at all with the old 5304 (249 megahertz chip----whoopee), slow as snails tho.
no probs on SuSE, so i just left the defaults in place on my next try, the install scripts "discovered" the dhcp bleep, and everything worked fine. just that my system thought my host.domain was <ip68_123_4_567.hr.hr.cox.net> and wouldn't let me use <owensby.us> in the /etc/hosts at all. it's a RH bug, i guess.
just a little clumsy, eh?
 
Old 03-08-2004, 01:02 AM   #7
acarri
LQ Newbie
 
Registered: Mar 2004
Posts: 18

Original Poster
Rep: Reputation: 0
yeah, but I had the same problem when freesco linux was installed in my router box..., any suggestions?
 
Old 03-09-2004, 12:38 PM   #8
ugge
Senior Member
 
Registered: Dec 2000
Location: Gothenburg, SWEDEN
Distribution: OpenSUSE 10.3
Posts: 1,028

Rep: Reputation: 45
Quote:
Originally posted by acarri

but still updates the ip with the valid one, by the way, it always assigns me the same ip 192.168.51.40 but it has to be assign via dhcp or it won't work, I don't know why, even when I try to manually assign it with win98, and yes I did copy all the parameters exactly as when dhcp assigns the ip.

here is my ifconfig output:

[root@localhost network-scripts]# ifconfig
eth0 Link encap:Ethernet HWaddr 00:C0:F0:45:99:BF
inet addr:192.168.51.40 Bcast:192.168.51.43 Mask:255.255.255.252
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:105 errors:0 dropped:0 overruns:0 frame:0
TX packets:2 errors:7 dropped:0 overruns:0 carrier:14
collisions:119 txqueuelen:100
RX bytes:16943 (16.5 Kb) TX bytes:2796 (2.7 Kb)
Interrupt:11 Base address:0x6200

eth1 Link encap:Ethernet HWaddr 00:02:2A:F1:A7:1E
inet addr:10.0.0.1 Bcast:10.0.0.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:1240 errors:0 dropped:0 overruns:0 frame:0
TX packets:1568 errors:0 dropped:0 overruns:0 carrier:0
collisions:1 txqueuelen:100
RX bytes:133398 (130.2 Kb) TX bytes:132991 (129.8 Kb)
Interrupt:10 Base address:0x6300

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:10 errors:0 dropped:0 overruns:0 frame:0
TX packets:10 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:700 (700.0 b) TX bytes:700 (700.0 b)
The reason why you have to use DHCP is probably due to the MAC restriction. My guess is that your ISP wants to boost the security a bit by only allowing certain NIC's to connect. That is NIC's with a certain MAC address.
The reason why it doesn't work if you configure your NIC manually might be because your ISP has configured their DHCP server and the Router/firewall at their end block all ports by default and then open them up as the DHCP server lends out IP addresses.
My guess is that your routing table doesn't get right and thus you can't connect to the internet. It might work if you could get your NIC to spoof the MAC right at startup instead.

This is only alot of guesses from what you have been describing as your problem. As you say it can be the DHCP client that can't handle this particular DCHP server. You might have to try another SHCP client to see if it works. Also check with your ISP to get information how it works.
 
Old 03-09-2004, 03:29 PM   #9
dfowensby
Member
 
Registered: Dec 2003
Location: OceanView Virginia, gem of the Southern Shore
Distribution: OpenSuSE Tumbleweed
Posts: 194
Blog Entries: 1

Rep: Reputation: 30
ok. try this: original OS-install dhcp setup with default entries etc in place: uncheck the default hostname autoconfig'ed by dhcp, write in your geek.frop.org or whatever, and leave the ip number addressing config part in default/dhcp-detect. this will work if you're on a "dynamic" address-issuing isp (something like what you would have to do in a dup modem config) such as Cox cable dsl uses.
luck -O
 
Old 03-09-2004, 10:05 PM   #10
charon79m
Member
 
Registered: Oct 2003
Distribution: Just about anything... so long as it is Debain based.
Posts: 297

Rep: Reputation: 30
Couple things don't add up...

First off... the IP address you are getting is in the PRIVATE IP address range. It is also subnetted down so your network has only 2 address in it. What this means is that you NIC gets one of the 2 available address on the network and your cable modem has the other address.

Continuing on with the subnetting issue, the address you are being handed is not a valid address for the subnet.

Decimal ___ Binary
252 = 11111100
040 = 00101000

This tells us that 40 is the network address. 41 and 42 are valid addresses, and 43 is the network's broadcast address. The error that the you get with ifup could be related to this addressing issue. Are you absolutely certain that your Win box is getting this same address including the subnet mask? Also, what is your default gateway in windows? Use the ipconfig /all or winipcfg command to get this information. If you can't get te above info in windows by using those commands boot to Win and at a command prompt type: Ping 192.168.51.43. Once you get your 4 responses, type: arp -a and see what IP addresses are listed in your ARP table. This will tell you the address of your cable router's private interface. Let's assume it's .42 for argument's sake.

Next, boot back into Linux. Configure your NIC for the other ip address (41) and then manually add the default gateway:

route add default gw 192.168.51.42

That might get you out to the internet on your Linux box.

MAC filtering is probably not the problem. Remember, your Windows boot that works just fine is using the NIC's hard coded MAC address. You shouldn't need to spoof the address.

I would guess that the Windows box is just too stupid to know it's not getting a valid address...

Hope this helps.

MrKnisely
 
Old 03-10-2004, 10:55 AM   #11
Darin
Senior Member
 
Registered: Jan 2003
Location: Portland, OR USA
Distribution: Slackware, SLAX, Gentoo, RH/Fedora
Posts: 1,024

Rep: Reputation: 45
if you are dual booting a win98 that connects to your ISP and linux that you are trying to get to connect then you shouldn't need to spoof anything, you should be able to just boot linux and have it use DHCP like win98 does and have it work. Why again are you spoofing the MAC if the same NIC works in 98? The MAC is part of the network card, and doesn't change from booting windows or linux.

If you can post the results of running "ipconfig /all" in a dos box under windows. try "ipconfig /all > c:\ipconfig.txt" then open c:\ipconfig.txt in a text editor like notepad.
 
Old 03-19-2004, 03:57 AM   #12
xlabs
LQ Newbie
 
Registered: Feb 2004
Posts: 2

Rep: Reputation: 0
Resuming A Bit the whole mess

Sorry that my english is so bad.

First I guess that some things must be clear first:



Starting from the problem you describe, I mean the ifup crashes, lets remember that the ifup has two stages: the dhcp stage where you ask for a lease to your isp, and then the real ifup when routing, dns and all that stuff starts. If you get a valid dhcp lease then the first stage is compleeted.The proof is that your nic gets updated with the new IP. Now for the seccond stage, well could be that it fails to add the default gateway or the dns enties(resolv.conf). Check if one of them dont update and you get closer to the solution.

Do you get the same problem if you reverse the nics? (eth0 LAN, eth1 ISP)

If you enter manually your configurtation, be sure that you enter the defult gateway(route add bla bla bla), valid dns entries(resolv.conf). IF even with that you dont get it working its because the dhcp server from your isp forces you to get a lease, otherwise it simply doesnt route traffic to you. This is the most common security practice.

IF everything works fine in 98, well its for sure that it is about configuration in your linux. Are you spoofing your mac in 98 too? If not then you dont have to spoof anything in linux. If yes, then you need to spoof it in linux too. Lot of poeple think that the mac is permanent in the nic. Yes thats true BUT doesnt mean you cant use another. When you request dhcp lease to your isp, your dhcp daemon sends the mac from your nic OR the mac you provide(ifconfig eth? hw ether bla bla bla). Of course you loose it when your box resets. To make it permanent, simply modify your "network" start script and add the line just before the interface is brought up.

Now lets think that the lease from your ISP lasts long enough: get the lease and then change your nic to manual with the data you know(ip, mask), add your default gateway and try to ping any IP number in the internet, like your dns server. This will tell you if everything works in the rounting part of your linux box. And last, check if resolv.conf gets updated with your dns servers.

I wish this could help a bit.

Xlabs.

Last edited by xlabs; 03-19-2004 at 04:09 AM.
 
Old 03-19-2004, 11:56 AM   #13
charon79m
Member
 
Registered: Oct 2003
Distribution: Just about anything... so long as it is Debain based.
Posts: 297

Rep: Reputation: 30
Xlabs,

The MAC address is hardcoded on your NIC. Linux gives you the option of reporting a different MAC; however, that's not changing the NIC's MAC address.

You do not have the luxury of easily spoofing your MAC in Win98.

The MAC address, I believe, can not be the issue here.

acarri,

I'd still like to see the full info of your 98 system's ipconfig /all.

Cheers,

MrKnisely
 
Old 03-19-2004, 07:29 PM   #14
gr00ve
Member
 
Registered: Jan 2004
Location: varies
Distribution: Blag, Slackware
Posts: 36

Rep: Reputation: 15
similiar

i had similair troubles ones, had to uncheck that "Bind 2 MAC" function on each adapter...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Howto grant access for a user to qtparted? powadha Debian 2 06-17-2005 03:18 AM
isp blocked port 25 berrance General 2 11-14-2004 08:25 AM
grant a user access to /fat-c n0x Slackware 4 05-02-2004 12:10 PM
grant telnet/ssl access to oly some users plisken Linux - General 3 02-21-2004 01:41 PM
Sendmail / Squirrelmail - external ISP blocked port 25 piers Linux - Newbie 5 04-27-2003 08:42 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 07:43 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration