LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 10-28-2015, 03:05 PM   #1
ThinkingMonkey
LQ Newbie
 
Registered: Oct 2015
Posts: 6

Rep: Reputation: Disabled
Multiple distros tried, still no DSL connection


Hi all,

I'm having major (but probably easily fixed if I knew what I was doing) network problems.

I had networking in college but it basically consisted of pinging other systems in the classroom. That's about all I remember about it anyway.

As my title says, so far I have tried the newest (as of 28 Oct 2015) distributions of Ubuntu, Mint, Debian, and now openSUSE to see if one or the other would automatically detect and set up my network.

My 'network' is extremely simple. I have no home network and connect to no other systems whatsoever. What I'm calling 'network' is connection to my DSL modem/router and thus the Internet.

Not one single distro I mentioned will set it up automatically and I've tried quite a bit of advice offered to other users on various forums and none of it works.

I have noticed a pattern though. Although my network card (Intel I217-V built-in on an EVGA Z87 motherboard) is detected and drivers installed (Intel e1000e driver) with no problems, it absolutely will not communicate with my modem/router.

My ISP is Windstream and the modem/router is a Sagemcom ADSL Model F@st 1704N.

It works perfectly with Windows XP, 7, 8.1, and 10 with no user intervention. It just works.

Of course I've tried using ipconfig (in Windows) and ifconfig (in Linux) to find out what IP addresses I should be trying but no luck with that so far.

When I say Linux will not communicate with the modem/router, I mean nothing at all.

When I'm booted into Linux, I can't even type 192.168.254.254 (works fine in Windows) into a browser to enter the setup screens of the modem/router. So of course setting the DHCP server to '192.168.254.254 won't work.

This has been going on for over a week now and still no Internet.

There is no doubt that there is an easy fix to this problem such as "Make sure there's not a checkmark in so-and-so box.", etc.

Like I said, if my network skills were better than a 3rd grader, I could fix this myself but as it is, I'm completely lost.

Can someone please help out with this problem? Any help is greatly appreciated.

Hugh


.
 
Old 10-28-2015, 03:21 PM   #2
jefro
Moderator
 
Registered: Mar 2008
Posts: 22,011

Rep: Reputation: 3629Reputation: 3629Reputation: 3629Reputation: 3629Reputation: 3629Reputation: 3629Reputation: 3629Reputation: 3629Reputation: 3629Reputation: 3629Reputation: 3629
"192.168.254.254 (works fine in Windows) into a browser to enter the setup screens" (seems to be an odd number by the way)

This is a clue.

What does ifconfig result in?


Hello and welcome to LQ by the way also.
 
Old 10-28-2015, 04:29 PM   #3
ThinkingMonkey
LQ Newbie
 
Registered: Oct 2015
Posts: 6

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by jefro View Post
"192.168.254.254 (works fine in Windows) into a browser to enter the setup screens" (seems to be an odd number by the way)

This is a clue.

What does ifconfig result in?


Hello and welcome to LQ by the way also.
Thank you for the welcome

The 192.168.254.254 is just the address you enter into any browser to enter the modem/router to change wireless passwords, view information, etc. I thought that was the address most routers or modems used to enter their setup screens. I had a Belkin router, though, that I believe may have been 192.168.2.1.

Anyway, it's where you get the popup that the default username and password to enter it are 'admin' and 'admin'.

Here are the results of ifconfig:

openSUSE-Z87:~ # ifconfig
lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:32 errors:0 dropped:0 overruns:0 frame:0
TX packets:32 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:2592 (2.5 Kb) TX bytes:2592 (2.5 Kb)
openSUSE-Z87:~ #

Thank you for your assistance.

Hugh


.
 
Old 10-28-2015, 04:37 PM   #4
Timothy Miller
Moderator
 
Registered: Feb 2003
Location: Arizona, USA
Distribution: Debian, EndeavourOS, OpenSUSE, KDE Neon
Posts: 4,007
Blog Entries: 26

Rep: Reputation: 1522Reputation: 1522Reputation: 1522Reputation: 1522Reputation: 1522Reputation: 1522Reputation: 1522Reputation: 1522Reputation: 1522Reputation: 1522Reputation: 1522
Well, ifconfig isn't even showing that you have an ethernet connection configured. To make it easier for further help, which distro do you currently have installed? It may also be that some other network management tool is managing your NIC, and that's why ifconfig doesn't see the interface.

Last edited by Timothy Miller; 10-28-2015 at 04:39 PM.
 
Old 10-28-2015, 05:04 PM   #5
suicidaleggroll
LQ Guru
 
Registered: Nov 2010
Location: Colorado
Distribution: OpenSUSE, CentOS
Posts: 5,573

Rep: Reputation: 2142Reputation: 2142Reputation: 2142Reputation: 2142Reputation: 2142Reputation: 2142Reputation: 2142Reputation: 2142Reputation: 2142Reputation: 2142Reputation: 2142
How about "ifconfig -a"
That will list all network adapters, even those that aren't currently configured. It would let us know if it's a driver problem or not.
 
Old 10-28-2015, 07:48 PM   #6
ThinkingMonkey
LQ Newbie
 
Registered: Oct 2015
Posts: 6

Original Poster
Rep: Reputation: Disabled
Further information

Hi all,

Quote:
To make it easier for further help, which distro do you currently have installed? It may also be that some other network management tool is managing your NIC, and that's why ifconfig doesn't see the interface.
I currently have openSUSE 13.2 ('Leap', not 'Tumbleweed', if that means anything), but please keep in mind that I have this exact same problem with Ubuntu, Mint, and Debian, too.

Quote:
How about "ifconfig -a"
That will list all network adapters, even those that aren't currently configured. It would let us know if it's a driver problem or not.
Oddly, ifconfig is showing an Ethernet connection (eno1)now whereas it was only loopback (lo) earlier. However, the Internet is not working still.

Results of ifconfig /a:
Code:
openSUSE-Z87:~# ifconfig /a
/a: error fetching interface information: Device not found
Results of ifconfig:
Code:
openSUSE-Z87:~# ifconfig
eno1   Link encap:Ethernet  HWaddr 00:1F:BC:10:D0:B3
       UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
       RX packets:45 errors:0 dropped:0 overruns:0 frame:0
       TX packets:68 errors:0 dropped:0 overruns:0 carrier:0
       collisions: 0 txqueuelen:1000
       RX bytes:3096 (3.0 Kb)  TX bytes: 16555 (16.1 Kb)
       Interrupt:20 Memory:f7300000-f7320000

lo     Link encap: Local loopback
       inet addr:127.0.0.1  Mask:255.0.0.0
       UP LOOPBACK RUNNING  MTU:65536  Metric:1
       RX packets:112 errors:0 dropped:0 overruns:0 frame:0
       TX packets:112 errors:0 dropped:0 overruns:0 carrier:0
       collisions:0 txqueuelen:0
       RX bytes:8336 (8.1 Kb)  TX bytes:8336 (8.1 Kb)

openSUSE-Z87:~#_

If it may assist someone who knows what they're doing, this is the result I get from running ipconfig in Windows 10 (same machine, same adapter, same modem/router as openSUSE). Internet and ping works just fine.

Code:
C:\Windows\system32>ipconfig /all

Windows IP Configuration

  Host Name..................: Z87-PC
  Primary Dns Suffix.........:
  Node Type..................: Hybrid
  IP Routing Enabled.........: No
  WINS Proxy Enabled.........: No
  DNS Suffix Search List.....: Home

Ethernet adapter Area 52 LAN:

  Connection-specific DNS Suffix..: Home
  Description.....................: Intel(R)Ethernet Connection I217-V                     
  Physical Address................: 00-1F-BC-10-D0-B3
  DHCP Enabled....................: Yes
  Autoconfiguration enabled.......: Yes
  Link-local IPv6 Address.........: fe80::d1fb:46f6:f46e:886f%8(Preferred)
  IPv4 Address....................: 192.168.254.1(Preferred)
  Subnet Mask.....................: 255.255.255.0
  Lease Obtained..................: Wednesday, October 28, 2015, 6:40:46 PM
  Lease Expires...................: Thursday, April 20, 2023 9:40:45 AM
  Default Gateway.................: 192.168.254.254
  DHCP Server.....................: 192.168.254.254
  DHCPv6 IAID.....................: 50339772
  DHCPv6 Client DUID..............: 00-01-00-01-1D-50-10-15-00-1F-BC-10-D0-B3 
  DNS Servers.....................: 192.168.254.254

I will gladly supply any additional information that may help with this problem.

Hugh


.
 
Old 10-28-2015, 08:06 PM   #7
suicidaleggroll
LQ Guru
 
Registered: Nov 2010
Location: Colorado
Distribution: OpenSUSE, CentOS
Posts: 5,573

Rep: Reputation: 2142Reputation: 2142Reputation: 2142Reputation: 2142Reputation: 2142Reputation: 2142Reputation: 2142Reputation: 2142Reputation: 2142Reputation: 2142Reputation: 2142
Quote:
Originally Posted by suicidaleggroll View Post
How about "ifconfig -a"
Quote:
Originally Posted by ThinkingMonkey View Post
Results of ifconfig /a
-a != /a

Windows switches/flags use /, Linux uses -.
 
Old 10-28-2015, 09:34 PM   #8
jefro
Moderator
 
Registered: Mar 2008
Posts: 22,011

Rep: Reputation: 3629Reputation: 3629Reputation: 3629Reputation: 3629Reputation: 3629Reputation: 3629Reputation: 3629Reputation: 3629Reputation: 3629Reputation: 3629Reputation: 3629
I don't see an IP address there.
"
eno1 Link encap:Ethernet HWaddr 00:1F:BC:100:B3
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:45 errors:0 dropped:0 overruns:0 frame:0
TX packets:68 errors:0 dropped:0 overruns:0 carrier:0
collisions: 0 txqueuelen:1000
RX bytes:3096 (3.0 Kb) TX bytes: 16555 (16.1 Kb)
Interrupt:20 Memory:f7300000-f7320000
"

inet addr:????

Usually in Suse you need to go to the network and configure it. I use Opensuse on a flash drive and each new computer I use it on I again have to go into network and check off some settings.


A quick setup might get you to router by something like ifconfig en0 192.168.254.x



A somewhat guide to ifconfig but you need to get at the OpenSuse guides. As you will note, the en0 is now more descriptive than eth0.

http://linux-ip.net/html/tools-ifconfig.html

http://www.aboutlinux.info/2006/11/i...mystified.html

http://doc.opensuse.org/

Last edited by jefro; 10-28-2015 at 09:38 PM.
 
Old 10-28-2015, 10:17 PM   #9
ThinkingMonkey
LQ Newbie
 
Registered: Oct 2015
Posts: 6

Original Poster
Rep: Reputation: Disabled
Hi,

Quote:
Originally Posted by suicidaleggroll View Post
-a != /a

Windows switches/flags use /, Linux uses -.
Oops.

Here's the corrected use of the switch, although it gives the same output as 'ifconfig' with no switches shown above except for slightly different TX and RX packets and sizes.

Results of ifconfig -a:
Code:
openSUSE-Z87:~# ifconfig -a
eno1   Link encap:Ethernet  HWaddr 00:1F:BC:10:D0:B3
       UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
       RX packets:48 errors:0 dropped:0 overruns:0 frame:0
       TX packets:7 errors:0 dropped:0 overruns:0 carrier:0
       collisions: 0 txqueuelen:1000
       RX bytes:3162 (3.0 Kb)  TX bytes:2422 (2.3 Kb)
       Interrupt:20 Memory:f7300000-f7320000

lo     Link encap: Local loopback
       inet addr:127.0.0.1  Mask:255.0.0.0
       UP LOOPBACK RUNNING  MTU:65536  Metric:1
       RX packets:32 errors:0 dropped:0 overruns:0 frame:0
       TX packets:32 errors:0 dropped:0 overruns:0 carrier:0
       collisions:0 txqueuelen:0
       RX bytes:2592 (2.5 Kb)  TX bytes:2592 (2.5 Kb)

openSUSE-Z87:~#_
One would think that Linux is simply not recognizing the network adapter correctly thus throwing everything else off but in all the distributions I've tried including the current openSUSE 13.2, the adapter seems to be recognized fine and the correct driver installed ('e1000e' according to Intel).

Below is a screenshot of YaST with the adapter listed. The information here is correct, to the best of my knowledge. It really is an Intel I217-V adapter and it's MAC address really is 00:1f:bc:10:d0:b3 according to Windows network diagnostics and Speccy.

Output from YaST2 (in openSUSE 13.2):
http://i.imgur.com/OyWim0N.png


Output from Piriform Speccy (in Windows 10) showing detailed network information:
http://i.imgur.com/N7GavHl.png


Thank you for your help.

Hugh


.
 
Old 10-29-2015, 10:12 AM   #10
suicidaleggroll
LQ Guru
 
Registered: Nov 2010
Location: Colorado
Distribution: OpenSUSE, CentOS
Posts: 5,573

Rep: Reputation: 2142Reputation: 2142Reputation: 2142Reputation: 2142Reputation: 2142Reputation: 2142Reputation: 2142Reputation: 2142Reputation: 2142Reputation: 2142Reputation: 2142
It looks like the NIC is being detected correctly, it's just not getting a DHCP address. You already know the subnet the router operates on, how about configuring your NIC with a static IP on that subnet to see if that gets you access?

IP: 192.168.254.10
Gateway: 192.168.254.254
Mask: 255.255.255.0

You can do it through the GUI menus. I use OpenSUSE on my laptop, but I don't use KDE, so I'm not exactly sure where you need to go, but it shouldn't be difficult to find. Usually there's an icon on the taskbar that you can right click to configure your NIC.
 
Old 11-01-2015, 09:52 PM   #11
ThinkingMonkey
LQ Newbie
 
Registered: Oct 2015
Posts: 6

Original Poster
Rep: Reputation: Disabled
Solved

Hi all,

Thank you all for your help.

What was suggested DID work, but only sometimes. And that led to the discovery of the main problem. The root of all my headaches.

It was a hardware issue. I began to suspect that may be possible after I applied the changes per your instructions and it seemed to work fine until I rebooted to Windows 10 then back to Linux (currently Debian, although as I mentioned, the same problem was present with Ubuntu, Mint, and openSUSE).

What was also suspicious was when I wiped openSUSE and re-reinstalled Debian yet again and the automatic network detection and setup (about the 3rd step in the setup, as you know) seemed to go just fine. After a reboot, it did not.

So step by step, what it was doing was (and yes I wrote this down trying to find a clue and it wasn't apparent at first, only in retrospect):

- Using Windows 10, network all fine and working
- Reboot with (any) Linux install DVD inserted and there were quickly problems (The dreaded "Your DHCP is not working" message)
- Complete the Linux install anyway
- Boot back to Windows to get online to read advice on what to check next.
- Reboot to Linux, still no network (Internet)

That was the never ending cycle for several days now. I was periodically doing complete re-installs of either openSUSE or Debian 8.2 fearing that if someone did provide a fix, all the previous failed entries I had made concerning the network might have goofed it up so that correct advice couldn't have helped. So I was trying to keep a relatively clean Linux install as much as possible.

Ok. So yesterday, I had a monitor flickering problem that I usually fix by completely powering off the monitor and computer for about a minute then back on and it will be good for several days or more. Not only powered off, but unplugged. (Yes, I need to replace this monitor and I will sooner or later).

So I did that. Well, I had the notion to boot into Debian while I was at the GRUB menu anyway, so I did and the network (Internet) was working flawlessly!

I had no idea what had been changed or not changed at that point. So I looked back over my notes and was pretty sure I had rebooted after each change so I rebooted into Windows to check my e-mail for notes. Couldn't find anything that caught my eye so I booted back into Debian to celebrate and guess what? No Internet.

SO I was thinking to myself that something or the other was existing in Windows that was changed in Linux but had no idea what, then I started to think of hardware settings.

After a lot of experimentation, here's all I did:

Disable the Wake-on-LAN (WoL) in both the BIOS and the network adapter settings in Device Manager in Windows (it's the same for 7, 8, 8.1, and 10). I had both off when I realized I could boot back and forth from Windows and Linux and still have Internet every single time without fail and I'm not about to re-enable one or the other to see if it makes a difference. They're both staying off.

I would have to guess that it being off in the BIOS will prevent it from being enabled in Windows but I really don't care at this point. Somebody besides me can check into that.

So getting a pure, virgin, cold boot straight into Linux without booting to Windows first is what made it work then I figured out how to make it stay working through cold or warm boot, both.

I don't know if it's this particular board (EVGA Z-87 FTW), or just the built-in adapter (Intel I217-V (Linux uses the Intel e1000e driver)) or both, but if you cannot get a Linux distro to automatically configure your network during setup, something it's been able to do for many, many years now, and you have the same setup I have, simply disable the Wake-on-LAN in the BIOS and in Windows' Device Manager.

I also imagine that someone who wasn't dual-booting would not have this problem since there would be no Windows to goof up the WoL to start with.

Thanks to everyone who was trying to help the un-helpable! lol

As always,
Hugh

EDIT: I forgot to mention that I spent half a day yesterday setting up a Belkin router that I got for my office and only used for a couple of weeks then boxed up, brought home and forgotten about. It's a Belkin N600 DualBand N+. I was basically just using it for 4 additional Ethernet ports. Plus it has a USB connection so you can make non-wireless printers, external storage, etc. wireless, or enable quick and easy NAS, etc. It's a good router. What I had been using at home prior to yesterday was the combination modem/router that's supplied by my ISP, Windstream.
I turned off all DHCP, WiFI, and just about everything else in the modem and enabled it all in the Belkin router because I had suspected at one point that maybe the Linux install just simply wasn't going to work with that modem.

So I set Linux to get DHCP, etc. from the router, which was assigned a single, static IP from the modem. I was letting the router run the whole show but nothing improved. Same problem as before, namely no Internet in Linux.

It was the WoL problem all along.


.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Slow internet connection on multiple linux distros but fast connection on windows Preston3050 Linux - Newbie 7 10-31-2013 12:21 AM
Slow internet connection on multiple linux distros but fast connection on windows Preston3050 Linux - Networking 1 10-29-2013 12:03 PM
Extremely slow ethernet connection on multiple linux distros bakslache Linux - Networking 2 07-13-2011 02:01 AM
[SOLVED] Multiple distros = multiple bootloaders. How do I set THE bootloader that shows? wingman358 Linux - General 6 07-23-2010 12:16 PM
DSL, i can`t setup my dsl internet connection . grimlair Linux - Laptop and Netbook 2 09-02-2007 12:59 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 06:55 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration