LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 12-22-2006, 10:58 AM   #1
hevnsnt
LQ Newbie
 
Registered: Feb 2004
Posts: 4

Rep: Reputation: 0
Moved Subnets: Now cannot resolve short name, but FQDN works fine?


Help!

I have a LAMP box on my companies internal network that I use for a knowledge base wiki. I had it all setup and working fine, however we recently changed locations (and subnets) and now I am having some problems with windows boxes resolving the host name.

Before: (names & ips changed to protect the innocent)
Code:
hostname: viki.central.company
IP: 10.82.50.214 (static)
Windows machines can resolve viki.central.company and just viki

Now:
Code:
hostname: viki.central.company
IP: 10.80.215.60
Windows machines can resolve viki.central.company but when you ping viki, it is returning back 10.82.50.214 and times out.

When I first moved, I put the box on DHCP to get an address, and then I took the address given to me by the DHCP server and made it static.

Does anyone have any ideas what could be going on? I need to be able to resolve "viki"!

Thanks!
 
Old 12-23-2006, 04:49 AM   #2
jimbo1954
Member
 
Registered: Oct 2006
Location: High Wycombe, Bucks, UK.
Distribution: Debian and Fedora Core in equal measure
Posts: 264

Rep: Reputation: 33
I'm not seeing anything in your post about changing the DNS entry for your device . You say you can try to ping the device by name, and it resolves to the old address...looks like a DNS server hasn't been told about the address change.

From the box you pinged from, try

"nslookup viki.central.company"

and see what device is responding with the address for viki...then examine the DNS records for viki on that machine. My guess is that you will find it's still pointed at the old address. Edit the entry for viki and see what happens.

If you're not using a DNS server, the resolution is probably happening in a "hosts" or "lmhosts" file on the device you are working from, so edit that file and check if it works.

If that doesn't help, could you come back with more info on the system distro, etc, might help.

HTH

Jimbo
 
Old 12-23-2006, 09:57 PM   #3
ARC1450
Member
 
Registered: Jun 2005
Location: Odenton, MD
Distribution: Gentoo
Posts: 290

Rep: Reputation: 30
Another idea: if the Winders boxes haven't been restarted, ipconfig /flushdns in the run menu. Windows has a bad, bad, bad habit of caching the stupidest shit sometimes.
 
Old 12-29-2006, 09:26 AM   #4
hevnsnt
LQ Newbie
 
Registered: Feb 2004
Posts: 4

Original Poster
Rep: Reputation: 0
Sorry, I was a little light on details there:


Yes I notified my DNS server team of the change, I have verified that the DNS has been updated to viki.central.company pointed to the correct IP.

When I NSLookup the FQDN (viki.central.company) , it finds the entry. When I NSLookup short name (viki) it cannot find it: (*** DNSSERVER.company.com can't find viki: Non-existent domain)

I have tried resolving this hostname from a machine that never new about viki, and it had the same results. (I had already tried the /flushdns, but figured that it might be better to try it on a new box) The strange thing is that I had three machines in my cube, two windows boxes, and the linux box. The windows machines ARE able to resolve each other by short name (windows1 & windows2) or by FQDN (windows1.central.company, etc)

I spoke with my DNS admin last week and they think that it is something on the machine, they say their entries are correct.

Here is a little more about the box:
LAMP installation running on a Ubuntu 6.10 Server
* Web Server: Apache 2.0
* Database Server: MySQL 5.0
* Mail Server: Postfix
* DNS Server: BIND9
* FTP Server: proftpd
* POP3/IMAP: Maildir format and therefore install Courier-POP3/Courier-IMAP.
* ISPConfig
* Samba
* Webalizer


Code:
root@viki:/etc# cat /etc/hosts
127.0.0.1       localhost
10.80.215.60    viki.central.company     viki

# The following lines are desirable for IPv6 capable hosts
::1     ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
ff02::3 ip6-allhosts



Quote:
Originally Posted by jimbo1954
I'm not seeing anything in your post about changing the DNS entry for your device . You say you can try to ping the device by name, and it resolves to the old address...looks like a DNS server hasn't been told about the address change.

From the box you pinged from, try

"nslookup viki.central.company"

and see what device is responding with the address for viki...then examine the DNS records for viki on that machine. My guess is that you will find it's still pointed at the old address. Edit the entry for viki and see what happens.

If you're not using a DNS server, the resolution is probably happening in a "hosts" or "lmhosts" file on the device you are working from, so edit that file and check if it works.

If that doesn't help, could you come back with more info on the system distro, etc, might help.

HTH

Jimbo
 
Old 12-29-2006, 11:36 AM   #5
farslayer
LQ Guru
 
Registered: Oct 2005
Location: Northeast Ohio
Distribution: linuxdebian
Posts: 7,239
Blog Entries: 5

Rep: Reputation: 190Reputation: 190
Is your DHCP server handing out the search domain information ?

Code:
useername@itg-debian:~$ more /etc/resolv.conf
search wmycompany.com
nameserver 192.168.10.25
nameserver 192.168.10.24
Code:
Microsoft Windows XP [Version 5.1.2600]
c:\aintx>ipconfig /all
Windows IP Configuration

        Host Name . . . . . . . . . . . . : ITG
        Primary Dns Suffix  . . . . . . . : mycompany.com
        DNS Suffix Search List. . . . . . : mycompany.com

Ethernet adapter Local Area Connection:

        Connection-specific DNS Suffix  . :
        Description . . . . . . . . . . . : Intel(R) PRO/100 Network Connection
        Physical Address. . . . . . . . . : 00-70-07-00-70-07
        Dhcp Enabled. . . . . . . . . . . : No
        IP Address. . . . . . . . . . . . : 192.168.10.3
        Subnet Mask . . . . . . . . . . . : 255.255.255.0
        Default Gateway . . . . . . . . . : 192.168.10.1
        DNS Servers . . . . . . . . . . . : 192.168.10.25
Basically that field of the DHCP scope says "If a domain is not provided take the short name and tack this domain information on it and attempt to resolve the FQDN name to an IP address"

It will be an option in the DHCP scope configuration.
OPTION 15 DNS DOMAIN NAME

The windows boxes are probably locating each others short name through local broadcasts..



Also the nslookup test should tell you WHAT server responded with that information.
I actually prefer using dig on a Linux box because it is more informative, and easy to query specific DNS servers..


And did you correct the /etc/hosts file on the linux box after it was moved ?
Code:
itg-debian:~# more /etc/hosts
127.0.0.1       localhost.localdomain   localhost       itg-debian
192.168.10.188   itg-debian.mydomain.com      itg-debian
Just for kicks I'd verify the hostname settings on the Linux box as well.. http://www.cpqlinux.com/hostname.html

Last edited by farslayer; 12-29-2006 at 11:46 AM.
 
Old 12-29-2006, 01:34 PM   #6
hevnsnt
LQ Newbie
 
Registered: Feb 2004
Posts: 4

Original Poster
Rep: Reputation: 0
Sorry I know this is long, and extremely confusing -- But thanks for helping out!

No, the DHCP server does NOT hand out search domain information. Each machine is configured to have several search domains. You hit it on the head here, central.company was not in the list. I have added that (on my windows machine) and it can now resolve viki.

Ok, that was a big one that I missed, thanks. But I still wonder how before the move machines were able to resolve viki without that in the search domain. And why it still tried to resolve to the old IP when "pinged" from a machine that knew nothing of viki.

Weird. Well I have a solution that will work.. Thanks all

Quote:
Originally Posted by farslayer
Is your DHCP server handing out the search domain information ?

Code:
useername@itg-debian:~$ more /etc/resolv.conf
search wmycompany.com
nameserver 192.168.10.25
nameserver 192.168.10.24
Code:
Microsoft Windows XP [Version 5.1.2600]
c:\aintx>ipconfig /all
Windows IP Configuration

        Host Name . . . . . . . . . . . . : ITG
        Primary Dns Suffix  . . . . . . . : mycompany.com
        DNS Suffix Search List. . . . . . : mycompany.com

Ethernet adapter Local Area Connection:

        Connection-specific DNS Suffix  . :
        Description . . . . . . . . . . . : Intel(R) PRO/100 Network Connection
        Physical Address. . . . . . . . . : 00-70-07-00-70-07
        Dhcp Enabled. . . . . . . . . . . : No
        IP Address. . . . . . . . . . . . : 192.168.10.3
        Subnet Mask . . . . . . . . . . . : 255.255.255.0
        Default Gateway . . . . . . . . . : 192.168.10.1
        DNS Servers . . . . . . . . . . . : 192.168.10.25
Basically that field of the DHCP scope says "If a domain is not provided take the short name and tack this domain information on it and attempt to resolve the FQDN name to an IP address"

It will be an option in the DHCP scope configuration.
OPTION 15 DNS DOMAIN NAME

The windows boxes are probably locating each others short name through local broadcasts..



Also the nslookup test should tell you WHAT server responded with that information.
I actually prefer using dig on a Linux box because it is more informative, and easy to query specific DNS servers..


And did you correct the /etc/hosts file on the linux box after it was moved ?
Code:
itg-debian:~# more /etc/hosts
127.0.0.1       localhost.localdomain   localhost       itg-debian
192.168.10.188   itg-debian.mydomain.com      itg-debian
Just for kicks I'd verify the hostname settings on the Linux box as well.. http://www.cpqlinux.com/hostname.html
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Suspend to Ram: works for a short time Peter_halv Linux - Laptop and Netbook 0 12-21-2006 06:43 AM
"Can't resolve host" as user, but works fine as root truthe Linux - Networking 2 10-22-2006 05:41 PM
e0 will Rx, but not Tx...e1 works fine giant Linux - Networking 2 09-15-2004 01:13 PM
Everything works fine... but no ADSL!! Conexus Slackware 10 04-11-2004 06:29 AM
Works just fine...I think /home/kyle Linux - Software 0 03-10-2004 05:09 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 11:58 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration