LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (https://www.linuxquestions.org/questions/linux-networking-3/)
-   -   Mounting windows xp file system, creates mnt point, however, cant read files in share (https://www.linuxquestions.org/questions/linux-networking-3/mounting-windows-xp-file-system-creates-mnt-point-however-cant-read-files-in-share-312993/)

cmd0a0 04-13-2005 07:36 PM

Mounting windows xp file system, creates mnt point, however, cant read files in share
 
Attempting to mount windows xp file system share on seperate machine.

When I use:
mount -t smbfs //servername/share /mountpoint

Receive warning 'Ignoring badly formed line in conjunction file: read only -yes'

When I df, the mount point has been created to the windows file system with an accurate block %. However, when I cd to mount point, there is no reference to my share directory or files within the directory.

Please advise on course of action.

Can ping to / from host remote using host name, ip, fully qualified names.

Also tried mount -t vfat //servername/share /mountpoint
Recv: special device does not exist.

I can ping servername being used.

jonaskoelker 04-14-2005 04:19 AM

try grepping your conj. files (or all your files...) for `read only -yes', and fix any appropriate file that shows up.

bruse 04-14-2005 04:23 AM

due to permission.
check ur shared file is view by others.

give read mode.

Rinish 04-14-2005 04:38 AM

mount -t smbfs - o username=loginname //hostname/share /mnt/mountdir

Rinish 04-14-2005 04:39 AM

this should work ^


thanks,
Rinish.P

cmd0a0 04-14-2005 08:54 AM

Rinish, this worked well:
mount -t smbfs - o username=loginname //hostname/share /mnt/mountdir

I now configured fstab to mount upon boot.

my syntax in fstab:

servername/share /mountpoint vfat <args>

Question with <args>: all files s/b rw,exec for applmgr user or dba group mbrs. Also, as applmgr, should be able to chmod,chgrp,chown as applmgr.
Currently, even as root, unable to change permisions.

I did read that the following args will work:
rw,exec,nosuid,nodev,user.

What do you think. Thanks.

cmd0a0 04-14-2005 01:59 PM

After doing more reading, I did find out that you cannot change the permissions when using vfat. Ultimately, you can set options to allow users / group the appropriate permissions to the dir / files.

That said, I will attempt to use the umask, uid and gid options and ensure that I can read/write files on the file system as applmgr & dba group.

Thanks.

cmd0a0 04-14-2005 07:48 PM

Still cant get the proper config using fstab. Upon boot, it states that it cannot identify my device. So i go back to the mount at the command line. I am able to mount, however, cannot write a file out to share on file system as user applmgr, even though i have specified the user explicitly.

I can however, edit any doc in the dir !

Any advise would be greatly appreciated.

Rinish 04-15-2005 01:49 AM

in ur fstab try with this
//host/share /mnt/mountdir smbfs uid=username,gid=groupname,username=username/domainname 0 0


Thanks,
Rinish.P

cmd0a0 04-15-2005 09:15 AM

Thanks for everyones assistance. Was able to resolve in fstab with :

//hostname/share /mnt/rman smbfs username=xxxx,password=xxxx,uid=500,gid=500,rw

Rinish 04-16-2005 12:28 AM

that was great cmd0a0


All times are GMT -5. The time now is 08:35 PM.