-   Linux - Networking (
-   -   Mounting a smb share as a local folder on Fedora 9 accessing a Windows Server (

AustinMarton 11-15-2009 02:38 PM

Mounting a smb share as a local folder on Fedora 9 accessing a Windows Server
I have managed to connect to the Windows server in the office and the shared folders I want are now available through the 'Places' menu. I can access the files through nautilus.

We want to use this setup for remote FPGA development so another computer can compile the system image and I download the image via JTAG on my fedora box. The problem I am having is the command line utility to download the image does not like the remote location 'smb://cmpyname/development/'. Is it possible for me to mount the samba share as a folder in the /mnt directory so it can be accessed as if it was local? Something to do with CIFS?


MS3FGX 11-15-2009 07:01 PM

The location "smb://cmpyname/development/" is specific to your desktop environment and file manager, it is not a real location on the system and as such software on your system will not be natively aware of it. It's only function is really just to browse remote shares.

To mount it locally you would do the same as any other device or filesystem, use the "mount" command.

A command might look like:


mount -t smbfs //cmpyname/development/ /mnt/development

jschiwal 11-15-2009 07:21 PM

Yes. You use cifs as the filetype. (smbfs is obsolete and might not be supported in your kernel) You can either mount it manually or add an entry in /etc/fstab. You may still want to mount it manually even using an /etc/fstab entry, in case the share isn't available when you boot.

Here is a general example:
//host/share /mnt/share cifs rw,uid=<yourusername>,gid=<yourgroup>,fmask=0117,dmask=0007,noauto,cred=/home/<yourusername>/.credentials

Create a .credentials file in your home directory and add two or three lines:
username=<your user name>
password=<your password>
domain=<domain name>

The third entry is only necessary if you use Active directory or NT style domains.
You don't want the credentials in the fstab file because it is world readable. So using a credentials file restricts who can read it. Use a full pathname to the file, as the ~ shortcut is understood by the shell and not the mount command.

The noauto option prevents the system from trying to mount it when you boot up. If that host is down, booting will fail with automounting.

There is a man page for "mount.cifs" which will describe other option you may want to use.

All times are GMT -5. The time now is 08:32 AM.