LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (https://www.linuxquestions.org/questions/linux-networking-3/)
-   -   Mounting a large directory over NFS... Mountpoint is empty? (https://www.linuxquestions.org/questions/linux-networking-3/mounting-a-large-directory-over-nfs-mountpoint-is-empty-163972/)

Shade 03-29-2004 08:43 PM

Mounting a large directory over NFS... Mountpoint is empty?
 
The title states the problem, I guess.

I tried to mount my /home/user/mp3 directory over NFS to my laptop, and it seems to work alright. But when I ls /mnt/share all I see is an empty directory... the mp3 dir is about 4.7 gb.

I tried with other subdirectories of my /home/user and everything else works fine.

I then tried exporting the whole /home/user and got the same result as with /home/user/mp3

What should I check out? Is there a limit to the filesizes? Something about network block devices in kernel config I remember seeing?

--Shade

Edit to add:

I'm sure the directories were mounted at the time, I checked with both the mount -f command and cat /proc/mounts


Shade 03-29-2004 09:14 PM

I just found that if I cd to /mnt/share and use ls, I see nothing.

However, if I try to cd to a directory that I know exists, I have no problems. For example, I mount /home/user at /mnt/share, and am able to cd to /mnt/share/mp3/bob_schneider, and see the contents...

So it is mounted, but I am unable to see the contents of a large dir ?

--Shade

ugge 03-30-2004 09:39 AM

Sounds like a file/directory permission issue.
In order to actually se what's in a directory you will need read and execute permissions to tha directory (drwx).
Check with ls- l

Shade 03-30-2004 09:55 PM

Thanks, but the permissions are correct, too. I even tried a chmod 777 on the directory in question.

any other ideas?
--Shade

Shade 04-15-2004 11:47 PM

BUMP!

I've been reading everything I can find on this, does anyone have any ideas, pointers, etc?

--Shade

Shade 04-18-2004 08:29 PM

*resolved*

via-rhine NIC in the server or the driver it used was flaky.
could not respond fast enough to mount such a large directory.
Disabling it in the bios and putting a cheap 8139 clone into it solved the problem.

Odd that it was hardware related.
--Shade


All times are GMT -5. The time now is 01:11 PM.