-   Linux - Networking (
-   -   "mount.nfs: an incorrect mount option was specified" (soft) (

catkin 09-18-2009 03:58 AM

"mount.nfs: an incorrect mount option was specified" (soft)
Hello :)

Adding NFS option "soft" in fstab results in "mount.nfs: an incorrect mount option was specified" on mount with -o remount. When "soft" is removed from fstab the same command completes silently.

  • ubuntu 8.04.3 host running:
    • Bridging (bridge-utils 1.2-2)
    • NFS server (nfs-kernel-server 1:1.1.2-2ubuntu2.2)
    • VirtualBox 3.0.6 with Slackware VM NIC configured as Bridged tap1
  • Slackware 13 guest. If NFS client software version is required, please tell me how to find it! :(
Option "soft" is wanted because Slackware sometimes looses the NFS connection with the host and this hangs shutdown. Otherwise the NFS mount works fine.

man 5 nfs on Slackware shows "soft" as an option.

Here's the relevant host exports and guest fstab lines

/home,no_root_squash,no_subtree_check) /home/c/hh nfs    bg,rw,soft      0 0



Smartpatrol 09-18-2009 11:27 PM


catkin 09-19-2009 05:30 AM


Originally Posted by Smartpatrol (Post 3689303)
I might be mistaken but i believe its a soft mount by default.

Thanks Smartpatrol :) According to the nfs man page on Slackware 13, the default is hard:

      soft / hard    Determines  the  recovery  behavior  of the NFS client after an NFS request times out.  If
                      neither option is specified (or if the hard option is specified), NFS requests are retried
                      indefinitely.  ...

All times are GMT -5. The time now is 09:56 AM.