LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 04-01-2006, 06:41 AM   #1
fadelhomsi
Member
 
Registered: Dec 2005
Location: Syria
Distribution: Suse, Mandriva
Posts: 52

Rep: Reputation: 15
Modem error


hello friends,
this error happens,
this is the log file

status is connecting
pppd[0]: Plugin passwordfd.so loaded
pppd[0]: --> WvDial: Internet dialer version 1.54.0
pppd[0]: ---> Initalizing modem
pppd[0]: --> Sending ATZ
pppd[0]: ATZ
pppd[0]: ERROR
pppd[0]:-->Bad init string
pppd[0]:stdin not read/write and$Modem not set
pppd[0]: Connection script failed
status is dissconnected


although it was working last week without problem,
but suddenly this happened,
any help is apperciated
thank u,
 
Old 04-01-2006, 10:54 PM   #2
Simon Bridge
LQ Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 198Reputation: 198
Clues are in /etc/wvdial.conf (or your appropriate script)

there should be a line saying modem=/dev/modem (or your modem)
the error is saying there is something wrong connected with this.

Have you tried using the user-interface tools to destroy the modem connection then recreate it afresh?
 
Old 04-02-2006, 01:55 PM   #3
fadelhomsi
Member
 
Registered: Dec 2005
Location: Syria
Distribution: Suse, Mandriva
Posts: 52

Original Poster
Rep: Reputation: 15
I tried that,
also I tried it with different distros like Mandrake, FC4, Arabian(live distro)
but all it didn't work
my modem is US Robotics
 
Old 04-03-2006, 05:46 AM   #4
Simon Bridge
LQ Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 198Reputation: 198
Quote:
Originally Posted by fadelhomsi
I tried that,
... what did you try?

To tell us your modem type - give us the lspci entry (for pci modem). The manufacturer is no guide. Anyway, you had it working before.
Quote:
also I tried it with different distros like Mandrake, FC4, Arabian(live distro)
but all it didn't work
... sounds like the modem is broken.

what does wvdial.conf say?
 
Old 04-08-2006, 08:36 AM   #5
fadelhomsi
Member
 
Registered: Dec 2005
Location: Syria
Distribution: Suse, Mandriva
Posts: 52

Original Poster
Rep: Reputation: 15
well,
I've tried wvdialconf newconffile,
and it says that there in no modem,
but how can I destroy the modem connection then recreate it afresh?
I will tell the output of lspci later.I amn't connected from my pc.
 
Old 04-09-2006, 06:26 PM   #6
Simon Bridge
LQ Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 198Reputation: 198
So, you tried using user-interface tools to destroy and recreate the connection? Thank you.

Usually the fedora network configuration dialog will do the trick - configure > highlight the ppp0 > delete, exit the dialog - add new modem connection.

You can also switch off, unplug the modem, switch on: kudzu asks if you want to remove the modem configuration - say "yes". Switch off, plug in modem, switch on: kudzu asks if you want to configure the modem - say "yes". This is not liked because of the windows-ism involved. HOwever, redhats network tools can be very picky when something goes wrong.

Now - I take it from your answers before that this is a pci/internal modem (win modem?) If you had to use special drivers to get your modem going in the first place, then changes to your kernel will stop them from working... have you done any updates since the modem was last working?

lspci output will be essential to understand the problem.
/etc/wvdial.conf content will also be important.
 
Old 04-10-2006, 11:20 AM   #7
fadelhomsi
Member
 
Registered: Dec 2005
Location: Syria
Distribution: Suse, Mandriva
Posts: 52

Original Poster
Rep: Reputation: 15
well, my modem is external, usually I use /dev/tts0,
but, then I tried lspci I didn't find any line refers to modem or tts0, could any program use this modem so I can't use it??? How I could know that????
 
Old 04-10-2006, 12:01 PM   #8
Darin
Senior Member
 
Registered: Jan 2003
Location: Portland, OR USA
Distribution: Slackware, SLAX, Gentoo, RH/Fedora
Posts: 1,024

Rep: Reputation: 45
If it's an external (and not USB) then it's probably not going to show up in lspci and it's not going to require special drivers put in the kernel so...

The contents of your wvdial.conf would probably help troubleshoot.

I would take a stab and try to get the modem to respond by configuring the dialer to use /dev/ttyS0, /dev/ttyS1, /dev/ttyS2.

Barring that, you could try to talk to the modem using minicom (use yum or download a package for it and transfer it over to install it if it's not on your system)
 
Old 04-10-2006, 11:37 PM   #9
Simon Bridge
LQ Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 198Reputation: 198
Quote:
well, my modem is external, usually I use /dev/tts0,
... (presumably you mean /dev/ttyS0) this is good news. External serial modems are supported.
Quote:
but, then I tried lspci I didn't find any line refers to modem or tts0, could any program use this modem so I can't use it??? How I could know that????
... if something was tying up your modem, wvdial would report an error to the effect that the device is busy. This is not you.

The advise to test with minicom is a good one. However, it is possible to be more direct... as root:

# echo "atz" > /dev/ttyS0
# echo "5551234" > /dev/ttyS0

...and watch for the modem lights flickering ... if they do not, then your modem is not in ttyS0 and you should try again with ttyS1,2,3 ... (it only goes up to 3, unless you have some sort of serial expansion installed).


While you are doing that, post us the content of /etc/wvdial.conf
Sounds like this will be vital.

I tend to favour this approach as it is unambiguous and dosn't depend on setting up minicom correctly. Choose the method you feel comfortable with and tell us what happens.
 
Old 04-12-2006, 03:21 AM   #10
fadelhomsi
Member
 
Registered: Dec 2005
Location: Syria
Distribution: Suse, Mandriva
Posts: 52

Original Poster
Rep: Reputation: 15
thanks alot,
This is the content of the wvdial.conf,
I will try what you advise me, and tell you next time, because (I am running the internet from the college's pcs not from my home).
well it's COM not usb.
have a good time

[Dialer Defaults]
Modem = /dev/ttsy0
Baud = 57600
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2
Init3 =
Area Code =
Phone = 0
Username =
Password =
Ask Password = 0
Dial Command = ATDT
Stupid Mode = 1
Compuserve = 0
Force Address =
Idle Seconds = 300
DialMessage1 =
DialMessage2 =
ISDN = 0
Auto DNS = 1

Last edited by fadelhomsi; 04-12-2006 at 03:36 AM.
 
Old 04-12-2006, 05:14 AM   #11
Simon Bridge
LQ Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 198Reputation: 198
It looks like you want to totally simplify your wvdial.conf, at least to start with.
This is mine:
Code:
[Modem0]
Modem = /dev/ttyS1 <---<<< note: dosn't have to be ttyS0.
Baud = 57600
SetVolume = 0
Dial Command = ATDT
Init1 = ATZ
Init3 = ATM0
FlowControl = CRTSCTS
[Dialer <my isp>]
Area Code = <nz telecom isp code>
Username = <username>
Password = <password>
Phone = <my isp dialup phone>
Stupid Mode = 1
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Inherits = Modem0
... note: usually you can get away with just Init1 = atz as an initialisation string - you modem manual should have an explanation of the AT?? codes.

I use a DSE XH1142 56k Intel Chipset Modem.
 
Old 04-14-2006, 04:40 PM   #12
fadelhomsi
Member
 
Registered: Dec 2005
Location: Syria
Distribution: Suse, Mandriva
Posts: 52

Original Poster
Rep: Reputation: 15
well

what do you mean by this :

usually you can get away with just Init1 = atz as an initialisation string - you modem manual should have an explanation of the AT?? codes.

thanks a lot
 
Old 04-15-2006, 06:35 PM   #13
Simon Bridge
LQ Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 198Reputation: 198
I'm sorry I was ill ... I didn't see you had init1 = atz already ... comment out "init2 =" line.

When you bought the modem, you got a manual with it (on CD and paper). In the manual there is a list of codes that all start "AT" with some combination of letters and numbers after them, and what they mean.

ath means hang up
atz means reset
atv0 means mute
atv1 means set a low volume
... and so on.

However - taking another look at this, I really think you should check:

echo "5551234" > /dev/ttyS0
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
modem error no carrier shams Mandriva 4 06-19-2008 04:35 AM
About usb modem error! burakerenn Linux - Networking 0 10-13-2005 04:36 PM
HELP!!! MODEM ERROR 2 - please help! corp769 Linux - Hardware 2 04-18-2005 06:56 PM
Modem Error essoft478 Linux - Hardware 0 12-08-2004 11:29 AM
i m getting error saying modem busy vipul_it Linux - Hardware 1 11-09-2004 07:42 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 11:33 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration