LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 12-17-2003, 03:58 AM   #1
Corbiere
LQ Newbie
 
Registered: Dec 2003
Location: Uk
Distribution: Suse 12.2
Posts: 5

Rep: Reputation: 0
Angry Mgetty won't start from inittab


I have mgetty set up to allow dialin. During the day I connect to the internet using wvdial via cron, 9-11am 12-2pm 3-5pm. During these times I have been using mgetty to listen in the background via inittab. Obviously during the above hours mgetty sees the modem lockfile and waits for the line to come free. The system has worked very well unill recently when the modem needed resetting.

After resetting the modem and a system reboot Mgetty will not start from inittab. tried init q counless times and checked over system logs but cannot see anything which explains why inittab will not start mgetty. mgetty will however run from the command line. I've looked for stale lock files and cant find any.

heres the entry in inittab

#modem getty
S0:235:respawn:/usr/sbin/mgetty -D -n 2 ttyS0

just in case inittab was defective I copied an old inittab from backup but still no joy.

mgetty logs are no help since they log only after mgetty is run.
when run from command line mgetty logs look fine.


What else should I check?

Any thoughts would be appreciated.

Corbiere
 
Old 12-17-2003, 05:44 AM   #2
beyer42
Member
 
Registered: Dec 2003
Location: San Jose
Distribution: Redhat WS 3
Posts: 410

Rep: Reputation: 30
It looks like you covered everything on the mgetty side.

I saw similar problem with mgetty not starting and somehow
running minicom on the modem and then quiting and rebooting
fixed the problem.

RE: [SLUG] mgetty won't start in inittab
 
Old 12-17-2003, 06:30 AM   #3
Corbiere
LQ Newbie
 
Registered: Dec 2003
Location: Uk
Distribution: Suse 12.2
Posts: 5

Original Poster
Rep: Reputation: 0
Angry

I've seen the same solution but I don't have minicom on my system yet. its something to try but I'm sceptical.

addenum.
just installed and run minicom on same modem. can connect to isp no problem. Mgetty still won't run from inittab!.

Last edited by Corbiere; 12-17-2003 at 07:31 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Mgetty and Minicom Murdock1979 Slackware 1 09-23-2005 11:10 AM
mgetty??? slack66 *BSD 3 01-01-2005 03:42 AM
mgetty problem saulgonzalez Linux - Networking 6 11-20-2003 10:49 AM
pppd and mgetty nitelifer Linux - Networking 0 07-15-2003 11:06 PM
mgetty ? dbeard Linux - Networking 2 06-28-2001 04:40 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 06:25 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration