LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (https://www.linuxquestions.org/questions/linux-networking-3/)
-   -   metasploit msrpcd help (https://www.linuxquestions.org/questions/linux-networking-3/metasploit-msrpcd-help-858225/)

pratorian 01-23-2011 09:08 PM

metasploit msrpcd help
 
Hey everyone,

I was really hoping for some help here. Im trying to get Metasploit and Armitage up and running, and im having one heck of a time! Ive gotten it all running once, closed it, then tried to reopen it minutes later to no avail. Im attempting to start 'msrpcd' using: sudo msfrpcd -f -U msf -P test -t Basic

Upon doing that i get this:

[*] XMLRPC starting on 0.0.0.0:55553 (SSL):Basic...
/opt/framework-3.5.1/msf3/lib/rex/socket/comm/local.rb:198:in `rescue in create_by_type': The address is already in use (0.0.0.0:55553). (Rex::AddressInUse)
from /opt/framework-3.5.1/msf3/lib/rex/socket/comm/local.rb:191:in `create_by_type'
from /opt/framework-3.5.1/msf3/lib/rex/socket/comm/local.rb:32:in `create'
from /opt/framework-3.5.1/msf3/lib/rex/socket.rb:46:in `create_param'
from /opt/framework-3.5.1/msf3/lib/rex/socket/tcp_server.rb:39:in `create_param'
from /opt/framework-3.5.1/msf3/lib/rex/socket/tcp_server.rb:29:in `create'
from /opt/framework-3.5.1/msf3/lib/msf/core/rpc/service.rb:17:in `initialize'
from /opt/framework-3.5.1/msf3/plugins/xmlrpc.rb:65:in `new'
from /opt/framework-3.5.1/msf3/plugins/xmlrpc.rb:65:in `initialize'
from /opt/framework-3.5.1/msf3/lib/msf/core/plugin.rb:31:in `new'
from /opt/framework-3.5.1/msf3/lib/msf/core/plugin.rb:31:in `create'
from /opt/framework-3.5.1/msf3/lib/msf/core/plugin_manager.rb:71:in `load'
from /opt/framework-3.5.1/msf3/lib/msf/base/simple/framework.rb:31:in `load'
from /opt/framework-3.5.1/msf3/msfrpcd:104:in `<main>'

Ive gone crazy Googling for the last several hours, and i just cant seem to figure it out. Any ideas?

Also - Im running Debian Lenny inside of Vmware Fusion, using a bridged(autodetect) network connection, running on a Macbook Pro. I was trying to get everything setup on my Mac outside of vmware but after two days of fail there, i decided to just give it a shot inside VMware since im a little better with Debian then i am the OSX Terminal.

I *should* have the latest versions of Metasploit, Armitage, Java, and all the dependencies.

Any help would be greatly appreciated! Thanks!

kbp 01-24-2011 04:47 PM

Quote:

The address is already in use
... have you checked that the port is available ? .. try netstat or lsof

pratorian 01-25-2011 04:02 AM

Quote:

Originally Posted by kbp (Post 4236522)
... have you checked that the port is available ? .. try netstat or lsof

I realize its unavailable, the thing thats gets me though, is that i had it working at one point, closed the app, and immediately re-opened it, and it will not work now.

Also, I ran netstat and lsof and found nothing at all pertaining to it.

kbp 01-25-2011 06:58 AM

If it's unavailable that means that a process still has it open, find the process and kill it...


All times are GMT -5. The time now is 12:08 AM.